Bug 63740 - EDITING: Autotext inserts new paragraph when user-defined text replaced
Summary: EDITING: Autotext inserts new paragraph when user-defined text replaced
Status: RESOLVED DUPLICATE of bug 53023
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
4.0.2.2 release
Hardware: Other Linux (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard: BSA
Keywords:
Depends on:
Blocks:
 
Reported: 2013-04-19 19:32 UTC by John Goold
Modified: 2014-05-19 06:27 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments
Writer file with auto-text in it for the suit symbols (clubs, diamonds,...) (35.18 KB, application/vnd.oasis.opendocument.text)
2013-04-21 15:32 UTC, John Goold
Details

Note You need to log in before you can comment on or make changes to this bug.
Description John Goold 2013-04-19 19:32:32 UTC
Problem description: Define auto-correct text combinations for the suit symbols (spades, hearts, diamonds, clubs). When inserting the symbol, a paragraph break is introduced after the symbol.

Steps to reproduce:
1. Insert the suit symbols into a string of text with a blank or tab following each symbol.
2. Select (highlight) a symbol (e.g. the diamond symbol), then press Ctl+F3. Define the name as "Diamond symbol" and the text to be replaced as "!d" (an exclamation point followed by the first letter of the suit symbol name). Select "New". Close the dialog box.
3. Create a new paragraph somewhere in the document and type some text into it. In the middle of the text type "!d". Select this and press F3.

Current behavior: The suit symbol is inserted and a new paragraph started.

Expected behavior: Only the suit symbol is inserted.

              
Operating System: Ubuntu
Version: 4.0.2.2 release
Comment 1 Urmas 2013-04-19 21:02:09 UTC
Cannot reproduce as described in 4.3.0.1, the symbol is inserted without paragraph breaks.
Comment 2 John Goold 2013-04-20 17:04:50 UTC
(In reply to comment #1)
> Cannot reproduce as described in 4.3.0.1, the symbol is inserted without
> paragraph breaks.

Can you point me at instructions for getting 4.3?  I'm getting updates beyond 4.0.2.2. I don't mind searching a site for the answer to this questions if I can get a vague pointer in the right direction.
Comment 3 Joel Madero 2013-04-20 19:08:02 UTC
4.3 is no a stable release currently, it's not recommended for daily use
Comment 4 Joel Madero 2013-04-20 19:08:28 UTC
4.0.3 (sorry for spam, but there is no 4.3 ;), even master is only at 4.1)
Comment 5 Joel Madero 2013-04-20 19:34:39 UTC
Also with reproducible steps provided I cannot reproduce.

Tested on Bodhi Linux with 4.0.1.2 release as well as 4.0.2.2 release

Can you try uploading a test document that has the !d and let us do the replacement?

Also when you did the replace text (step 2, highlight a symbol, did you also highlight the tab space or just the two character (!d) ?

Marking as NEEDINFO, get us a test case and answer that question real quick then mark as UNCONFIRMED, we'll test it out one more time.
Comment 6 John Goold 2013-04-21 15:32:15 UTC
Created attachment 78296 [details]
Writer file with auto-text in it for the suit symbols (clubs, diamonds,...)

This file is one of 12 that are included in a Master Document (.odm). All the files, including the Master Document, are based on the same template.
Comment 7 John Goold 2013-04-21 15:40:15 UTC
  Forgot to mention: I wondered if I had done something like you suggested (included a tab or something). So, while I was setting it up, I deleted my auto-text. Before redefining it, I carefully put extra blanks (spaces) on each side of the suit symbols. Then I selected each, one at a time, and re-created the auto-text.

I also noticed something strange at the time, but I don't know if it qualifies as a bug:

When I "name" the auto-text, the dialog box suggests the short-text to use (for example I named the club symbol auto-text, "Club symbol" and the suggested text was "Cs"). In all cases I changed this to be an exlamation mark followed by the first letter of the name of the symbol (e.g. "!c"); however, when I went back to define the next auto-text, the lower-case letter showed up as an upper-case letter. Nevertheless, the lower-case short-code works (with the paragraph-break bug).
Comment 8 Joel Madero 2013-04-21 17:16:23 UTC
So, with your selection you only selected the symbol itself or you selected the spaces also? (sorry just not quite clear on this still)

As for the second issue, sure that's a really trivial bug, you can open a new report, CC me on it and I'll triage it. That's of course really really minor but, it should stay as lower case probably
Comment 9 Joel Madero 2013-04-21 17:16:50 UTC
In the future please set the bug back to UNCONFIRMED if you provide the requested information - else QA is likely to miss it :)

Thanks!
Comment 10 John Goold 2013-04-21 20:10:54 UTC
Just the symbol... I have a really neat keyboard shortcut for typing in spaces :-)

I'll enter the cosmetic bug as a new one.
Comment 11 Laurent BP 2014-05-13 15:41:42 UTC
Hello,

I cannot reproduce with Autotext > New. I can only reproduce if I select Autotext > New (Text only) which is the same as bug 53023.
Comment 12 a07cd040897db54e103c 2014-05-19 06:27:01 UTC

*** This bug has been marked as a duplicate of bug 53023 ***