Bug 77482 - Writer: Inserting multi worded autotexts adds unnecessary line break
Summary: Writer: Inserting multi worded autotexts adds unnecessary line break
Status: RESOLVED DUPLICATE of bug 53023
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
4.2.3.3 release
Hardware: Other All
: medium major
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2014-04-15 11:01 UTC by a07cd040897db54e103c
Modified: 2014-09-16 15:19 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments
A screenshot of creating the autotext. (16.18 KB, image/png)
2014-04-15 11:01 UTC, a07cd040897db54e103c
Details
A screenshot *before* confirming Writers autotext suggestion with enter. (1.79 KB, image/png)
2014-04-15 11:02 UTC, a07cd040897db54e103c
Details
A screenshot *after* inserting the suggestet text (with unnecessary line break). (3.06 KB, image/png)
2014-04-15 11:03 UTC, a07cd040897db54e103c
Details

Note You need to log in before you can comment on or make changes to this bug.
Description a07cd040897db54e103c 2014-04-15 11:01:39 UTC
Created attachment 97395 [details]
A screenshot of creating the autotext.

Writer adds an unnecessary line breaks when inserting phrases from the autotext library.

This behaviour is very annoying, especially when writing continuous paragraphs which should contain predefined phrases.

I assume, that this is due to the mechanism LOs autotext suggestion is accepted - by pressing enter.

The expected behaviour is, that pressing enter to confirm an autotext suggestion sould only trigger the *insertion* of the desired text fragment and *ignore* the enter key.
Comment 1 a07cd040897db54e103c 2014-04-15 11:02:49 UTC
Created attachment 97396 [details]
A screenshot *before* confirming Writers autotext suggestion with enter.
Comment 2 a07cd040897db54e103c 2014-04-15 11:03:39 UTC
Created attachment 97397 [details]
A screenshot *after* inserting the suggestet text (with unnecessary line break).
Comment 3 Laurent BP 2014-05-13 15:42:57 UTC
Hello,

I cannot reproduce with Autotext > New. I can only reproduce if I select Autotext > New (Text only) which is the same as bug 53023.
Comment 4 a07cd040897db54e103c 2014-05-14 06:30:16 UTC
(In reply to comment #3)

Hello Laurent,

> I cannot reproduce with Autotext > New. I can only reproduce if I select
> Autotext > New (Text only) which is the same as bug 53023.

You are right. This seems to be the same bug. As you can see in attachment #97395 [details] i also used "New (Text only)".

For my case I can *NOT* workaround this issue by using Autotext > "New" because this also adds the current formatting of the text. As we use many different preformatted document templates with styles+formatting templates these two kinds of formatting would produce inexpected results.
Comment 5 Joel Madero 2014-05-16 20:09:46 UTC

*** This bug has been marked as a duplicate of bug 53023 ***