Bug 63832 - PRINTING: OLE-Bitmap breaks WYSIWYG. Print shows different format than visible on screen
Summary: PRINTING: OLE-Bitmap breaks WYSIWYG. Print shows different format than visibl...
Status: RESOLVED DUPLICATE of bug 63585
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
4.0.2.2 release
Hardware: Other Windows (All)
: high normal
Assignee: Not Assigned
URL:
Whiteboard: BSA
Keywords:
Depends on:
Blocks:
 
Reported: 2013-04-23 09:45 UTC by Alexandros Gougousoudis
Modified: 2013-04-23 12:16 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
ODT-File to show the effect (71.22 KB, application/vnd.oasis.opendocument.text)
2013-04-23 09:45 UTC, Alexandros Gougousoudis
Details
Result of printing (23.41 KB, application/pdf)
2013-04-23 09:46 UTC, Alexandros Gougousoudis
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Alexandros Gougousoudis 2013-04-23 09:45:35 UTC
Created attachment 78360 [details]
ODT-File to show the effect

Problem description: 
Bitmap-OLE-Object breaks WYSIWYG (printing). Print doesn't show the document as on screen

Steps to reproduce:
1. Create a new document
2. Insert a graphics as OLE-object to the upper right side
3. Paint a line on the left side, put some text beneath it.
4. Go to print the document.


Current behavior:
The line goes from the upper left, to the lower right during printing. On screen an print-preview everything is ok.

Expected behavior:

Printing as on screen (WYSIWYG)

              
Operating System: Windows XP
Version: 4.0.2.2 release
Comment 1 Alexandros Gougousoudis 2013-04-23 09:46:28 UTC
Created attachment 78361 [details]
Result of printing
Comment 2 Alexandros Gougousoudis 2013-04-23 09:47:27 UTC
The effect occurs regardless which printer(driver) has been taken and also occurs with Win 7 32/64 Pro.
Comment 3 Alexandros Gougousoudis 2013-04-23 09:48:07 UTC
The document created like this, printed without problems in OpenOffice 3.2.1
Comment 4 Alexandros Gougousoudis 2013-04-23 10:04:13 UTC
Same bug found in Version 4.0.3.1 (Build ID: a67943cd4d125208f4ea7fa29439551825cfb39)
Comment 5 Rainer Bielefeld Retired 2013-04-23 11:54:01 UTC
This one is at least related to "Bug 63585 - PRINTING: particular .ODT is printed without table borders and some elements are not on their places", "Bug 60280 - PRINTING of TABLE borders, borders around paragraphs and footer, some graphic elements suppressed by OLE objects in document"

For now I mark it as DUP

@Alexandros Gougousoudis:
Please watch fixes for Bug 63585 and reopen this bug if the reported problem will persist although that bug and related one will have been fixed

*** This bug has been marked as a duplicate of bug 63585 ***
Comment 6 Alexandros Gougousoudis 2013-04-23 12:16:03 UTC
Thx. Any idea when it'll be fixed? 

This bug causes massive impact in our work, because a lot of people can't print out their old documents with the right layout, after the migration from OO 3.2.1.

Workaround: Export as PDF and print with PDF-Viewer or switch off printing of bitmaps in printing dialog.