Bug Hunting Session
Bug 63851 - FILEOPEN: .docx Document Formatting issues if Graphics included - issue with Wrap > Contour ?
Summary: FILEOPEN: .docx Document Formatting issues if Graphics included - issue with ...
Status: RESOLVED DUPLICATE of bug 60351
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
4.0.2.2 release
Hardware: x86-64 (AMD64) All
: medium major
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2013-04-23 17:15 UTC by Russ Fineman
Modified: 2015-11-21 07:02 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:


Attachments
.docx_NewsLetter (542.35 KB, application/vnd.openxmlformats-officedocument.wordprocessingml.document)
2013-04-23 17:15 UTC, Russ Fineman
Details
PDF showing how the document is expected to look like (505.52 KB, application/pdf)
2013-04-23 22:04 UTC, Pedro
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Russ Fineman 2013-04-23 17:15:19 UTC
Created attachment 78385 [details]
.docx_NewsLetter

If I open a .docx document with writer and the document has numerous graphics and word wrapped text around the graphic, the .odt document loses parts oe all of the graphic. usually there is abox outline where graphic goes of near where it goes.

I found that turn off the test wrap option, it then displays the complete graphic but the text  looses a lot of its format.

This was originally reported around version 3.6 but a search does not turn up my report. I did a search on .docx and got 258 returns many of where sound simular.
example Bug #33077 and 33895. Some of the go back to 2011 but that does not means part of them are not resolved. 

If I open a .docx text only document I have no crippling problems.

My system is:
openSUSE 12.3(Linux 3.7.10-1.1-desktop x86_64)|KDE 4.10.2
"release 556"|Intel core2duo 2.5 MHZ,|8GB DDR3|GeForce
8400GS(NVIDIA-Linux-x86_64-310.32)

Let me know if I can supply more information

Russ
Comment 1 Jorendc 2013-04-23 20:39:05 UTC
Thanks for reporting and doing research as much as you can. We really appreciate that!

Is it possible to attach a pdf "how it should look like" (exported by word for example, or another program that displays the docx correctly). In this way we can compare it 1 on 1.

Thanks for your extra information.

Kind regards,
Joren

PS: please feel free to mark this bug back to UNCONFIRMED once you provided mentioned information
Comment 2 Pedro 2013-04-23 22:04:56 UTC
Created attachment 78402 [details]
PDF showing how the document is expected to look like

I can confirm that text wrapping around images is lost in this docx document.

Tested under Windows XP x86 SP3 using LO 4.0.2.2
Comment 3 Russ Fineman 2013-04-23 23:24:53 UTC
Jorendc Ref. comment 2.

I do not have the original, I sent you the document that was sent to me as an attachment. I have no Microsoft software on my systems, I am completely Linux with LO. 

I cannot save it as pdf without first bringing it into writer. then it is messed up. I think scribus maybe able to import it. I'll try. mean while I see in comment 2 Pedro was able to confirm it with XP and Lo 4.0.2.

I download 4.0.3 earlier and will try installing it hopefully later to night and see what happens.
Comment 4 Russ Fineman 2013-04-23 23:30:29 UTC
The document Pedro attached in comment 2 is what it should look like. I think I have the equal of 4.0.2.2. It is the openSUSE version (release). Could it be something they change or the Linux Version. I'll try to save it as PDF again and see what happens.

Thanks Pedro. 

Russ
Comment 5 Russ Fineman 2013-04-24 00:05:25 UTC
Just tried opening original with writer and then exported it as .pdf. Stll has graphics problems exported.
Comment 6 Cor Nouws 2013-04-24 08:04:39 UTC
hi all,

thanks for the issue, the docx and the PDF !

So the document is terrible in terms of formatting.
Loads of spaces and tabs to postition the text.
And use of Calibri (with direct formatting too) that will make it hard to open correct on an OS that does not have this font.

Nevertheless, I see two issues that may be worth investigating:
(4.0.3.rc1 on Linux)

 1- text flow compared to page width / margins
 2- wrapping (Contour) of the images.

AD 2: To me it looks the Wrap > Contour is set for every image and that this causes problems.
Could that be checked maybe in Word?
(I added this subject to the summary of the issue)

AD 1: Page margins have to be reduced a lot, in order to make " Congratulations to Lion Past Zone Chairperson" (to line of first column) fit on one line, 
(Now see what this does with the text on page 2..)
Maybe this is an issue to investigate: what happens with (page) margins and line wrapping? But my guess would be that this is stronly related to the font
Still, maybe one could test the following: remake the document in Word, using Arial and see what happens on LibreOffice (Linux) then?
(This may indeed be worth a seperate issue).
Pedro: since you seem to have access to Word: could you pls try this?
thanks,
Cor
Comment 7 Cédric Bosdonnat 2013-04-29 11:26:34 UTC
All problems with Contours here are mostly due to auto-contour. Those Auto-contour problems are also described in bug 60351 thought this one may have more related problems
Comment 8 QA Administrators 2015-03-04 02:23:59 UTC
** Please read this message in its entirety before responding **

To make sure we're focusing on the bugs that affect our users today, LibreOffice QA is asking bug reporters and confirmers to retest open, confirmed bugs which have not been touched for over a year.

There have been thousands of bug fixes and commits since anyone checked on this bug report. During that time, it's possible that the bug has been fixed, or the details of the problem have changed. We'd really appreciate your help in getting confirmation that the bug is still present.

If you have time, please do the following:

Test to see if the bug is still present on a currently supported version of LibreOffice (4.4.1.2 or later): https://www.libreoffice.org/download/

If the bug is present, please leave a comment that includes the version of LibreOffice and your operating system, and any changes you see in the bug behavior

If the bug is NOT present, please set the bug's Status field to RESOLVED-WORKSFORME and leave a short comment that includes your version of LibreOffice and Operating System

Please DO NOT

Update the version field
Reply via email (please reply directly on the bug tracker)
Set the bug's Status field to RESOLVED - FIXED (this status has a particular meaning that is not appropriate in this case)

Thank you for your help!

-- The LibreOffice QA Team
This NEW Message was generated on: 2015-03-03
Comment 9 Buovjaga 2015-03-24 17:16:56 UTC
The only clipped graphic: a bit of the mane of the lion next to "Transition to the new officers by providing records, helping them set goals and providing the status of on-going projects"

Win 7 Pro 64-bit, LibO Version: 4.4.1.2
Build ID: 45e2de17089c24a1fa810c8f975a7171ba4cd432
Locale: fi_FI
Comment 10 Mike Kaganski 2015-11-21 07:02:58 UTC

*** This bug has been marked as a duplicate of bug 60351 ***