Bug Hunting Session
Bug 95930 - DOCX IMPORT: invalid auto-contour for image text-wrap distorts image display
Summary: DOCX IMPORT: invalid auto-contour for image text-wrap distorts image display
Status: RESOLVED DUPLICATE of bug 60351
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
unspecified
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2015-11-19 13:06 UTC by Mike Kaganski
Modified: 2015-11-21 07:02 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Mike Kaganski 2015-11-19 13:06:53 UTC
A follow-up for bug 95755.

The attachment 120487 [details] is skewed on import: its picture wrapping is wrong, picture content is displayed wrong because of wrapping. Picture display is fixed by turning off Format->Wrap->Enable Contour...
Editing contour shows that some complex contour is created that makes the visible distortion.

Taken from http://habrahabr.ru/post/269301/
Comment 1 Mike Kaganski 2015-11-19 13:08:34 UTC
Setting NEW because already confirmed in bug 59755.
Comment 2 Mike Kaganski 2015-11-19 13:37:07 UTC
Actually this is a duplicate of Bug 60351, that was mistakingly closed WORKSFORME. The reason for closing it was that the specific images that were shown on screenshot attached to issue were displayed correctly in later LO versions. But the attachment 74270 [details] had numerous other images that are still affected, so that resolution seems to be a change in code that controls when the wrong contour is triggered, but not an actual correction.

Also, there are a code pointer by Cédric Bosdonnat (bug 60351 comment 5) and a patch by Anderson Cordeiro (bug 60351 comment 8, attachment 78840 [details]).

Not sure if I need to reopen that bug and mark this as duplicate, or let things as they are.
Comment 3 Cor Nouws 2015-11-19 18:22:26 UTC
Indeed same as/related to 63851 ?

maybe good to know is issue 87784.
Comment 4 Mike Kaganski 2015-11-21 07:02:48 UTC

*** This bug has been marked as a duplicate of bug 60351 ***