Bug Hunting Session
Bug 63992 - VLOOKUP fails to maintain proper link when file with link is re-opened
Summary: VLOOKUP fails to maintain proper link when file with link is re-opened
Status: RESOLVED DUPLICATE of bug 60835
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
3.6.5.2 release
Hardware: x86 (IA32) Linux (All)
: medium major
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2013-04-27 10:49 UTC by Rob D
Modified: 2013-06-07 03:41 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Rob D 2013-04-27 10:49:19 UTC
I create an ods spreadsheet (in Libre office) that links to another ods file.  The link works properly and looks like this:

=VLOOKUP(C20,'file:///home/Rob/Documents/truck/quotes.ods'#$Sheet1.A1:B15,2,0)

I save and close the file.  Seconds later I open it again look at the same cell and it looks like this and obviously stops working:

=VLOOKUP(C20,'file:///home/Rob/Documents/truck/home/Rob/Documents/truck/quotes.ods'#$Sheet1.A1:B15,2,0)

Note that it recursed part of the link address.

Here's how the data file looks:

BLDP	0.94	4/26/2013	3:59pm	0.02	0.95	0.96	0.9225	198878


This should be a very simple vlookup that finds BLDP moves over one column and picks up 0.94 when working correctly.
Comment 1 Joel Madero 2013-05-29 22:15:43 UTC
Same core cause - this one seems to be affecting quite a few users

*** This bug has been marked as a duplicate of bug 57738 ***
Comment 2 Rob D 2013-05-30 00:11:16 UTC
Hi,

I read a blog somewhere that solved the problem.  I was saving it as an 
xls.  When I instead saved it as an ods it worked fine.

Thanks,

Rob

On 05/29/2013 06:15 PM, bugzilla-daemon@freedesktop.org wrote:
> Joel Madero <mailto:jmadero.dev@gmail.com> changed bug 63992 
> <https://bugs.freedesktop.org/show_bug.cgi?id=63992>
> What 	Removed 	Added
> Status 	UNCONFIRMED 	RESOLVED
> Resolution 	--- 	DUPLICATE
> CC 		jmadero.dev@gmail.com
>
> *Comment # 1 <https://bugs.freedesktop.org/show_bug.cgi?id=63992#c1> 
> on bug 63992 <https://bugs.freedesktop.org/show_bug.cgi?id=63992> from 
> Joel Madero <mailto:jmadero.dev@gmail.com> *
> Same core cause - this one seems to be affecting quite a few users
>
> *** This bug has been marked as a duplicate ofbug 57738  <show_bug.cgi?id=57738>  ***
> ------------------------------------------------------------------------
> You are receiving this mail because:
>
>   * You reported the bug.
>
Comment 3 Markus Mohrhard 2013-06-07 03:41:04 UTC

*** This bug has been marked as a duplicate of bug 60835 ***