Bug Hunting Session
Bug 57738 - functions change link when linked to separate worksheet upon save/close/open - breaks usability
Summary: functions change link when linked to separate worksheet upon save/close/open ...
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
PreBibisect
Hardware: All Linux (All)
: high major
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: preBibisect
Depends on:
Blocks: mab3.6
  Show dependency treegraph
 
Reported: 2012-11-30 15:53 UTC by quantumboy
Modified: 2015-12-17 11:01 UTC (History)
9 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description quantumboy 2012-11-30 15:53:45 UTC
What works:
INDIRECT("'file://path/to/file/file.ods'#Sheet.A1")

What doesn't work:
1. I create "/home/<username>/Desktop/file.ods"
2. I create "work.ods" in the same directory.
3. In "work.ods" I give a cell the formula:
INDIRECT("'file.ods'#Sheet.A1")

What happens here is this:
Edit/Links: I see that a link is created correctly.
The formula returns the right value from "file.ods"

But when I close and reopen "work.ods":
I am presented with the error message:
"The following external file could not be loaded. Data linked from this file did not get updated.

file:///home/<username>/Documents/file.ods"

(Notice the difference! It is Documents and not Desktop!)

Now there are two links in the list:
1. The one created at first.
2. A new one mentioned in the error message.

The formula still gives the right value.

If I break the link the formula gets replaced by the value.

My LO version:
LibreOffice 3.5.4.2 
Build ID: 350m1(Build:2)

Save URLs relative to the file system is checked.

If a I change the path "My Documents" in the options the wrong and unnecessary link changes accordingly.
Comment 1 Joel Madero 2013-05-29 17:57:11 UTC
Thank you for reporting this issue! I have been able to confirm the issue on:
Version: 4.2.0.0.alpha0+Build ID: b0a1666f756aa5f5315366eca9d7d02ddd55d2b
Date:   Tue May 28 08:51:01 2013 +0300 
Platform: Bodhi Linux 2.2 x64

+ + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + +
As I've been able to confirm this problem I am marking as:

New (confirmed)
Major - loss of data
Low - default is high, I think this is a special case which won't impact many people unless it can be confirmed that it happens with other formulas as well. I have tested with sum function and it seems to work fine.


+ + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + +
LibreOffice is powered by a team of volunteers, every bug is confirmed (triaged) by human beings who mostly give their time for free. We invite you to join our triaging by checking out this link:
https://wiki.documentfoundation.org/QA/BugTriage and join us on freenode at #libreoffice-qa

There are also other ways to get involved including with marketing, UX, documentation, and of course developing -  http://www.libreoffice.org/get-help/mailing-lists/. 

Lastly, good bug reports help tremendously in making the process go smoother, please always provide reproducible steps (even if it seems easy) and attach any and all relevant material
Comment 2 Joel Madero 2013-05-29 20:07:13 UTC
*** Bug 59556 has been marked as a duplicate of this bug. ***
Comment 3 Joel Madero 2013-05-29 21:18:49 UTC
Upping this to high - have found 2 dupes in the last hour and apparently sum is affected also
Comment 4 Joel Madero 2013-05-29 21:18:56 UTC
*** Bug 60835 has been marked as a duplicate of this bug. ***
Comment 5 Joel Madero 2013-05-29 21:21:50 UTC
*** Bug 62600 has been marked as a duplicate of this bug. ***
Comment 6 Joel Madero 2013-05-29 21:22:48 UTC
Because other functions affected - updating title
Comment 7 Joel Madero 2013-05-29 22:15:43 UTC
*** Bug 63992 has been marked as a duplicate of this bug. ***
Comment 8 Joel Madero 2013-05-30 17:48:29 UTC
*** Bug 55009 has been marked as a duplicate of this bug. ***
Comment 9 Markus Mohrhard 2013-06-04 09:48:01 UTC
Does anyone here know if that worked correctly in one version?

Except for that information I suppose I should add it to my list of bugs.
Comment 10 Joel Madero 2013-06-04 14:15:48 UTC
Updating version - can confirm all the way back to earliest bibisect - I wouldn't be surprised if we found some more dupes that have been confirmed from way back when
Comment 11 Markus Mohrhard 2013-06-06 20:03:32 UTC
Ok, so I tried that and it opens fine for me.

So I need a few information. First it would be good to attach a document that shows the issue( make sure that you only save it once so that I can see if it is an export or an import issue).

Secondly it would be good to know the setting of Tools->Options->Load/Save->General->Save URLs relative to the file system.
Comment 12 Joel Madero 2013-06-06 20:05:35 UTC
Markus - bug 60835 has a nice package that shows the issue
Comment 13 quantumboy 2013-06-06 20:30:58 UTC
Interesting.
I use now a newer version and I cannot reproduce my original bug.

LibreOffice 3.5.7.2 
Build ID: 350m1(Build:2)

This may indicate that the bug has been somehow eliminated.
Comment 14 Joel Madero 2013-06-06 20:33:04 UTC
crazy - unless the dupe is mismarked (which would be my mistake), I was able to reproduce on master build from just a few days ago.

Perhaps the dupe isn't really a dupe? bug 60835
Comment 15 Markus Mohrhard 2013-06-06 21:33:22 UTC
(In reply to comment #14)
> crazy - unless the dupe is mismarked (which would be my mistake), I was able
> to reproduce on master build from just a few days ago.
> 
> Perhaps the dupe isn't really a dupe? bug 60835

Well this XLS issue is different because XLS only supports links on Windows so these problems are expected there.
Comment 16 Joel Madero 2013-06-06 21:35:17 UTC
crap, I wonder how many of the dupes are actually not dupes then, and those should be marked as NOTOURBUG?
Comment 17 Markus Mohrhard 2013-06-07 03:44:05 UTC
(In reply to comment #16)
> crap, I wonder how many of the dupes are actually not dupes then, and those
> should be marked as NOTOURBUG?

All.

This bug here has nothing to do with any of the mentioned duplicates. The bug seems to be fixed since some 3.5.x version.

All the other bugs are either the problem with XLS paths on Linux or other unrelated problems.
Comment 18 Robinson Tryon (qubit) 2015-12-17 11:01:26 UTC
Migrating Whiteboard tags to Keywords: (PreBibisect)
[NinjaEdit]