Download it now!
Bug 64168 - Odd behavior importing HTML table into CALC
Summary: Odd behavior importing HTML table into CALC
Status: RESOLVED DUPLICATE of bug 35756
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
4.0.3.1 rc
Hardware: All All
: medium major
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2013-05-02 20:45 UTC by kuko
Modified: 2013-05-29 04:17 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description kuko 2013-05-02 20:45:41 UTC
When I try to import an HTML document into Calc, if the document have the same row 10 times, everything's ok. When the document have the same row 10 000 times, Calc show just 6750 rows. If the document have the same row 100 000 times, libreoffice crash.

Steps to reproduce:

---------------------TABLE HEADER--------------------
<table border=1>
<caption>INDICADORES</caption>
<tr>
<th>Code</th>
<th>Number</th>
<th>Deno</th>
<th>Level</th>
<th>Nature</th>
<th>Load</th>
<th>MetricUnit</th>
<th>Aprobed</th>
<th>PlanifLevel</th>
<th>Activated</th>
<th>WayAdqui</th>
<th>Parent</th>
<th>Price</th>
</tr>
------------------------END---------------------------

-----------------------TABLE BODY---------------------
<tr>
<td style="mso-number-format:'@';">68160000014</td>
<td></td>
<td>FUSIBLE</td>
<td>Surtido</td>
<td>Equipo</td>
<td>Comunicaciones</td>
<td>Uno</td>
<td>Aprobed</td>
<td>Si</td>
<td>Si</td>
<td></td>
<td></td>
<td>0.000000</td>
</tr>
-----------------------END----------------------------

Step 1: Put the content betwen "--TABLE HEADER--" and "--END--" in to a file "DocHeader.txt". Put the contet betwen "--TABLE BODY--" and "--END--" in to a file "DocBody.txt".

Step 2: Create a file with 10 rows "file1.xls".
cat DocHeader.txt > file1.xls
for ((i=0;i<10;i++)); do cat DocBody.txt >> file1.xls; done

Step 3: Open the file "file1.xls" with LibreOffice-Calc. Everything's OK.

Step 4: Create a file with 10 000 rows "file2.xls".
cat DocHeader.txt > file2.xls
for ((i=0;i<10000;i++)); do cat DocBody.txt >> file2.xls; done

Step 5: Open the file "file2.xls" with LibreOffice-Calc. Just 6700 rows are show.

Step 6: Create a file with 10 000 rows "file3.xls".
cat DocHeader.txt > file3.xls
for ((i=0;i<100000;i++)); do cat DocBody.txt >> file3.xls; done

Step 7: Open the file "file3.xls" with LibreOffice-Calc. LibreOffice crash.
Comment 1 kuko 2013-05-15 15:11:26 UTC
Could someone please tell me in wich file or files in the source code I can find the logic of this funtionallity? Or another kind of orientation that allows me to try to solve the problem.
Comment 2 ign_christian 2013-05-15 16:24:12 UTC
Set "Component" to: "Spreadsheet" -> specific Calc issue

Similar to Bug 64572 ?
Comment 3 kuko 2013-05-16 16:36:19 UTC
Ok, thanks.
Comment 4 kuko 2013-05-16 16:39:15 UTC
Yes, it seems similar to to https://bugs.freedesktop.org/show_bug.cgi?id=64572.
Comment 5 ign_christian 2013-05-17 01:59:30 UTC
set Platform to: All -> affects Linux & Windows user (see Bug 64572)
Comment 6 Vladimir 2013-05-17 05:08:11 UTC
Yes, this case is very similar to mine (Bug 64572). I also opened a large html files with ten speakers and saw that the file is cut off at approximately 6500 line. I confirm this bug.
Comment 7 Joel Madero 2013-05-24 16:37:26 UTC
Is this just a duplicate of the other bug? If so let's mark it as a dupe and just put comments on the other one
Comment 8 ign_christian 2013-05-28 08:41:37 UTC
@Joel Madero: I can't confirm both this bug & Bug 64572 because I don't know how to compare that behavior. Maybe you can help kuko on Comment 1 ?
Comment 9 kuko 2013-05-28 18:19:24 UTC
I must make some test, but the releases notes of Libreoffice 4.1.0.0 says that this bug is fixed. And reading de content, is the same I've post.

*** This bug has been marked as a duplicate of bug 35756 ***
Comment 10 ign_christian 2013-05-29 04:17:44 UTC
Thanks kuko, that bug got away from my sight..:)
Could you also mark Bug 64572 whether it's a duplicate?