Download it now!
Bug 64189 - Image Export as EPS from Spreadsheet Broken
Summary: Image Export as EPS from Spreadsheet Broken
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
4.1.0.0.alpha0+ Master
Hardware: All All
: high major
Assignee: Tomaz Vajngerl
URL:
Whiteboard:
Keywords: bibisectRequest, regression
Depends on:
Blocks: 62135
  Show dependency treegraph
 
Reported: 2013-05-03 16:22 UTC by Joel Madero
Modified: 2015-12-17 07:14 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Joel Madero 2013-05-03 16:22:31 UTC
This was found while triaging Bug 62135:

Steps to Reproduce:

1. Open Spreadsheet
2. Create a scatter plot
3. Right click chart -> export as graphic...
4. Try to export EPS file

Observed:
Creates a 0 kb file

Expected:
Creates an eps file that looks nice

Regression from 4.0 series which works but as the problem mentioned in bug 62135

Notes: Whoever looks into this can also see bug 62135 as there is an issue with the export being fuzzy with 4.0 series - maybe both can be tackled at the same time but this blocks the solution for that one.
Comment 1 Joel Madero 2013-05-03 16:26:11 UTC
bibiect may be useful but it'll have to be off the new bibisect package which unfortunately I have not set up yet.

Joren - you mind bibisecting this with the new package? If you don't want to create a scatter plot you can get it from the attachment in bug 62135 and just export that.
Comment 2 Gerry 2013-05-03 21:19:58 UTC
Isn't this something which should have already taken care of in bug 60137?
 
The problem was that exporting a chart as graphic in LibreOffice 4.0 displayed all image formats, but in fact only the pixel formats were working. The vector formats resulted in a 0 Byte file. According to bug 60137, this ought to be fixed in release 4.1.

I think Tomaz Vajngerl can clarify whether this is a regression or not. Therefore, I copy him to this bug.
Comment 3 Tomaz Vajngerl 2013-05-04 08:35:07 UTC
Yes, graphic export for charts in LO 4.0 works only for raster graphic formats. For vector graphic formats it still exports the chart as raster - this is the problem in bug 62135. The exception is svg, which exports as a 0 byte file because of another bug in SVG export and graphicfilter. This all has been fixed for LO 4.1. 

In this bug report it is about EPS export in LO 4.1 which I can reproduce and confirm. Looks like a new bug in graphicfilter concerning EPS because I was able to export charts as EPS when I fixed vector export in LO 4.1. 

I will take a look at this.

Regards, Tomaž
Comment 4 Tomaz Vajngerl 2013-05-04 09:36:32 UTC
Hi,

I found out the problem is commit [1] by Peter Foley. The problem is in graphicfilter.cxx line 2062.

PFilterCall pFunc = (PFilterCall) aLibrary.getFunctionSymbol(OUString(aFilterName+EXPORT_FUNCTION_NAME));

aFilterName has the value (in case of EPS export) "libepslo.so" but as far as I understand this it should be "eps" for this to work. Peter can you please take a look at this?

[1]: http://cgit.freedesktop.org/libreoffice/core/commit/?id=eacf12eeb174e35a301570726bf74434a4dd4b94
Comment 5 Jorendc 2013-05-04 12:45:46 UTC
Hi Tomaz, Joel, Gerry,

When I first read the bug title, I thought immediately at Bug 64161. Exporting an EPS file as PDF (using Impress) is also quite borked. Duplicate/related?

Kind regards,
Joren
Comment 6 Tomaz Vajngerl 2013-05-04 13:24:55 UTC
(In reply to comment #5)
> Hi Tomaz, Joel, Gerry,
> 
> When I first read the bug title, I thought immediately at Bug 64161.
> Exporting an EPS file as PDF (using Impress) is also quite borked.
> Duplicate/related?
> 
> Kind regards,
> Joren

Hi,

I think it's a different problem. Probably PDF export or EPS import/export itself. This bug exists only in 4.1 but not in 4.0. In 4.0 EPS chart export works, but does not export what the user wants/expects.

Regards, Tomaž
Comment 7 Peter Foley 2013-05-06 21:00:04 UTC
(In reply to comment #4)
> Hi,
> 
> I found out the problem is commit [1] by Peter Foley. The problem is in
> graphicfilter.cxx line 2062.
> [1]:
> http://cgit.freedesktop.org/libreoffice/core/commit/
> ?id=eacf12eeb174e35a301570726bf74434a4dd4b94

So, it looks like the commit is broken.
I've reverted it for will now and will take another look at it at some point.
Comment 8 Markus Mohrhard 2013-05-27 13:24:31 UTC
(In reply to comment #7)
> (In reply to comment #4)
> > Hi,
> > 
> > I found out the problem is commit [1] by Peter Foley. The problem is in
> > graphicfilter.cxx line 2062.
> > [1]:
> > http://cgit.freedesktop.org/libreoffice/core/commit/
> > ?id=eacf12eeb174e35a301570726bf74434a4dd4b94
> 
> So, it looks like the commit is broken.
> I've reverted it for will now and will take another look at it at some point.

So I suppose we can close this bug report?
Comment 9 Jorendc 2013-06-08 11:48:06 UTC
(In reply to comment #8)
> > So, it looks like the commit is broken.
> > I've reverted it for will now and will take another look at it at some point.
> 
> So I suppose we can close this bug report?

Version: 4.2.0.0.alpha0+ Build ID: 55ff402fa24bcf9478e7fde94f2ab57c2223b7f ... still reproducible. Exporting a chart in EPS format result in a 0 byte image -> REOPENED
Comment 10 Tomaz Vajngerl 2013-06-22 13:25:47 UTC
Hi,

This should hopefully be fixed with [1].

Regards, Tomaž


[1] http://cgit.freedesktop.org/libreoffice/core/commit/?id=4449a227c86807af70abf4837d32fcd17181340d
Comment 11 ign_christian 2013-07-14 01:56:26 UTC
Perhaps duplicate to Bug 60137 that has been fixed?
Comment 12 Tomaz Vajngerl 2013-07-14 20:12:04 UTC
(In reply to comment #11)
> Perhaps duplicate to Bug 60137 that has been fixed?

No, this bug was "created" after that bug was already fixed. Both symptoms were a 0 byte file but this is always like that if an exception occurs in graphicfilter at saving of an image. Still.. this bug should also be fixed now so someone should confirm and close this bug.

Regards, Tomaž
Comment 13 Robinson Tryon (qubit) 2015-12-17 07:14:15 UTC
Migrating Whiteboard tags to Keywords: (bibisectrequest)
[NinjaEdit]