Bug 62135 - Blurry numbers and large EPS file exported from Calc 4.0.1
Summary: Blurry numbers and large EPS file exported from Calc 4.0.1
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
4.0.0.3 release
Hardware: All All
: low normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
: 58683 (view as bug list)
Depends on: 64189
Blocks:
  Show dependency treegraph
 
Reported: 2013-03-10 23:57 UTC by Marduk
Modified: 2014-04-29 22:58 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments
Example ODS file and exported EPS (22.77 KB, application/zip)
2013-03-10 23:57 UTC, Marduk
Details
Eps generated from sample file. (46.78 KB, image/x-eps)
2013-03-11 02:06 UTC, m.a.riosv
Details
Observed behavior (12.77 KB, image/png)
2013-04-22 17:24 UTC, Marduk
Details
Expected behavior (11.80 KB, image/png)
2013-04-22 17:37 UTC, Marduk
Details
EPS generated from example file with LO 4.2.5.0.0+ (17.63 KB, image/x-eps)
2014-04-29 11:44 UTC, Jean-Baptiste Faure
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Marduk 2013-03-10 23:57:31 UTC
Created attachment 76299 [details]
Example ODS file and exported EPS

With LibreOffice Calc 4.0 it is possible to directly export a chart in vector format (EPS for example) with a click of the secondary button. No more copy and paste to Draw to export as PDF, or so I thought. It turns out that in the exported EPS graphic, the numbers (axis labels) look pixelated. Moreover the file weighs over a MB for a simple scatter plot with only four points.

A moderator at LibreOffice Forum suggested to raise a bug report.
Comment 1 m.a.riosv 2013-03-11 02:06:14 UTC
Created attachment 76301 [details]
Eps generated from sample file.

Hi Marduk,
I can not reproduce the issue. Attached EPS (47 KB) generated without any change from your sample file.
Win7x64 Ult.
Version 4.0.1.2 (Build ID: 84102822e3d61eb989ddd325abf1ac077904985)
Comment 2 Marduk 2013-03-12 17:04:31 UTC
(In reply to comment #1)

I did some tests in Windows 7 HP 64-bit and the file size is greatly reduced indeed. However the numbers are still rasterized. I viewed all files, including your attachment, with Illustrator CS3. Zoom in to see what I mean. 

I also opened the EPS's generated by Draw and the one I got from Calc with Vim and there is clearly a difference in the way they are created. I wonder why they did not use the same mechanism. It looks to me that even if you choose LZW compression in Draw the data are not actually compressed, whereas in Calc you do not have a choice and the data is compressed. Moreover changing the value of TextMode as explained in http://www.puschmann.net/page/?p=95 affects the behavior of Draw only.
Comment 3 Joel Madero 2013-04-22 16:10:08 UTC
Marduk - can you provide explicit steps on how to accomplish what you want to accomplish. Usually bug reports should be in the format:

Computer info (OS, LibreOffice version, etc...)

Steps to reproduce problem
1...
2...
3...


Observed:
the wrong behavior summarized


Expected:
What you expect to see


It's good to be consistent with this format so QA can quickly reproduce the problem and triage it -- we're not all familiar with every feature that LibreOffice has (even if we spend hours and hours triaging bugs :) )

Thanks!
Comment 4 Marduk 2013-04-22 17:24:21 UTC
Created attachment 78336 [details]
Observed behavior
Comment 5 Marduk 2013-04-22 17:37:48 UTC
Created attachment 78337 [details]
Expected behavior
Comment 6 Marduk 2013-04-22 17:47:45 UTC
My apologies. This is my first bug report ever.

Computer info: I have tried this on Win 7 64 Pro, OS X 10.7.5 and Arch Linux with latest updates using every LibreOffice release (not RC) in the 4.0 series.

Steps to reproduce problem:

1. Create a scatter plot, like in the attached ODS example file
2. Right click on the plot and select Export as graphic
3. Choose EPS format
4. Open EPS file with the latest Illustrator trial, Preview (OS X), evince, zathura, etc.

Observed:

- All text looks pixelated, rasterized or whatever the right word is (see attached "observed behavior" png file)

Expected

- Text should be vectorized, scalable, nice (see attached "expected behavior" png file)

I have now attached PNG files in addition to the previous EPS file so that you know what I see. Try zooming in in the EPS file and you will see what I mean.

Why not use SVG? As noted in other bug report it comes out blank.

Thanks for helping.
Comment 7 QA Administrators 2013-04-22 17:48:47 UTC
Perfect, thanks for steps, will investigate :-D
Comment 8 Joel Madero 2013-04-22 17:49:47 UTC
sorry I posted as wrong user :) I will investigate this, thanks for posting info
Comment 9 Joel Madero 2013-05-03 16:17:04 UTC
Thank you for reporting this issue! I have been able to confirm the issue on:
Version: 4.0.0.3 release
Platform: Bodhi Linux 2.2 x64

+ + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + +
As I've been able to confirm this problem I am marking as:

New (confirmed)
Normal - can prevent high quality work 
Low - not an incredibly used feature, still legible just not perfect

Note; feature appears completely broken in 4.1 master build....this is a much more serious problem, reporting it now

+ + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + +
LibreOffice is powered by a team of volunteers, every bug is confirmed (triaged) by human beings who mostly give their time for free. We invite you to join our triaging by checking out this link:
https://wiki.documentfoundation.org/QA/BugTriage and join us on freenode at #libreoffice-qa

There are also other ways to get involved including with marketing, UX, documentation, and of course developing -  http://www.libreoffice.org/get-help/mailing-lists/. 

Lastly, good bug reports help tremendously in making the process go smoother, please always provide reproducible steps (even if it seems easy) and attach any and all relevant material
Comment 10 Joel Madero 2013-06-02 03:17:28 UTC
*** Bug 58683 has been marked as a duplicate of this bug. ***
Comment 11 Jean-Baptiste Faure 2014-04-29 11:44:31 UTC
Created attachment 98175 [details]
EPS generated from example file with LO 4.2.5.0.0+

Not reproducible for me with LO 4.2.5.0.0+ under Ubuntu 14.04 x86-64.
The EPS I generated from example file does not contains any preview while the EPS in first attachment (attachment 76299 [details]) contains a binary image.

Best regards. JBF
Comment 12 retired 2014-04-29 22:58:13 UTC
JBF, thanks for testing. When looking at your exported EPS file it's neither very big in file size nor shows up pixelated when opened with preview.app on OSX 10.9.2.

thus setting to WORKSFORME as of comment 11.