Bug 64518 - FORMATTING: Wrong alignment on user-defined format cells in combination with 'Use printer metrics for text formatting'
Summary: FORMATTING: Wrong alignment on user-defined format cells in combination with ...
Status: RESOLVED DUPLICATE of bug 66089
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
3.6.6.2 release
Hardware: x86 (IA32) All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2013-05-13 07:22 UTC by ign_christian
Modified: 2016-05-16 17:12 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments
Sample file (6.85 KB, application/vnd.openxmlformats-officedocument.spreadsheetml.sheet)
2013-05-13 07:22 UTC, ign_christian
Details
Screenshot from LO 4.0.4.2 (99.05 KB, image/png)
2013-06-24 01:48 UTC, ign_christian
Details

Note You need to log in before you can comment on or make changes to this bug.
Description ign_christian 2013-05-13 07:22:34 UTC
Created attachment 79228 [details]
Sample file

1. Open attached sample file which created with MS Office -> see that numbers on column B overlapping borders
2. Choose & click any cell on column B (B4 - B22)
3. Click 'Align Left' on toolbar -> see that cell value moves to the right (vice versa)

Using LO 4.0.3.3 (Win7 Home Premium 32bit)

See also Bug 56678
Comment 1 ign_christian 2013-05-31 11:37:26 UTC
This bug still happen on LO 4.0.4.1, not only XLSX file but also XLS & ODS.

Seems that LO wrongly read cell with number format: (1.234)
Format code: _(* #.##0_);_(* \(#.##0\);_(* -_);_(@_)
Comment 2 ign_christian 2013-06-23 16:03:14 UTC
Change version to 3.6.6.2 (oldest known version), tested on Ubuntu 12.04 32bit
Comment 3 Cor Nouws 2013-06-23 16:38:36 UTC
hi ign_christian,

I do not see the overlap (step 1) in LibreOffice 3661, 4042 and 4101 on Ubuntu
I do see the movement with clicking left align repeatedly (step 3).
Comment 4 ign_christian 2013-06-24 01:48:43 UTC
Created attachment 81288 [details]
Screenshot from LO 4.0.4.2

Hi Cor Nouws, thanks for testing.

My previous description lacks of details. I try to explain more: (see screenshot)
- Cell B4 - B22 are center aligned (shown on the button highlighted)
- Click Align Left on any of the cells will move the value to the right
- Click Align Right on any of the cells will move the value to the left (that should be correct position)

I've just checked with OOO 3.3.0 (Win XP) that behavior not occured (correct alignment). I'll try again after resetting user profile.
Comment 5 ign_christian 2013-06-24 02:17:26 UTC
After resetting user profile on LO 4.0.4.2 (Win7 32bit), I experience same behavior with you on comment 3.

Values correctly positioned with Align Center button highlighted. But clicking Left or Right alignment repeatedly didn't change alignment. That result is the same if testing attachment from Bug 66089 (not only on .xlsx, also on .xls).

Strange..that behavior not happen on OOO 3.3.0
Comment 6 ign_christian 2013-06-24 02:51:39 UTC
> Values correctly positioned with Align Center button highlighted. But
> clicking Left or Right alignment repeatedly didn't change alignment. 
Sorry..clicking Align Right will move value a bit to the right.

Same behavior on LO 3.6.6.2 (Ubuntu 12.04 32bit) after resetting user profile.

So the original bug description has changed, what should we do with this bug report? Change the summary/description or open new bug report ?
Comment 7 retired 2013-06-24 08:57:29 UTC
ign_christian: I think it's fine to keep this bug, maybe adjust the title accordingly.

I can also confirm Cor Nouws findings: File looks fine in LO 4.1.0.1 on OS X 10.8.4. But alignment is off when playing with Left / Right alignment button.

Setting to NEW.

<<OT: Btw: you are doing awesome work here. Never saw you on the QA IRC though - maybe you wanna hop on? Would be great to meet you "in person" (https://wiki.documentfoundation.org/QA/IRC).>>
Comment 8 ign_christian 2013-06-25 02:29:59 UTC
> I can also confirm Cor Nouws findings: File looks fine in LO 4.1.0.1 on OS X
> 10.8.4. But alignment is off when playing with Left / Right alignment button.
Thank you for confirming James.

> <<OT: Btw: you are doing awesome work here. Never saw you on the QA IRC
> though - maybe you wanna hop on? Would be great to meet you "in person"
> (https://wiki.documentfoundation.org/QA/IRC).>>
If that only for QA, so that's not for me. Since I only an ordinary user, & don't have such qualification as a QA guy :)
Comment 9 ign_christian 2014-06-28 07:30:50 UTC
After observing Bug 66089, I found same cause for this problem: "Use printer metrics for text formatting" enabled.

It begins since LO 3.6.x until 4.3.0.1. 

But if we disable "printer metrics", alignment not working at all on cells B4:B21.
Comment 10 QA Administrators 2015-07-18 17:44:02 UTC
** Please read this message in its entirety before responding **

To make sure we're focusing on the bugs that affect our users today, LibreOffice QA is asking bug reporters and confirmers to retest open, confirmed bugs which have not been touched for over a year.

There have been thousands of bug fixes and commits since anyone checked on this bug report. During that time, it's possible that the bug has been fixed, or the details of the problem have changed. We'd really appreciate your help in getting confirmation that the bug is still present.

If you have time, please do the following:

Test to see if the bug is still present on a currently supported version of LibreOffice (4.4.1 or later): https://www.libreoffice.org/download/

If the bug is present, please leave a comment that includes the version of LibreOffice and your operating system, and any changes you see in the bug behavior
 
If the bug is NOT present, please set the bug's Status field to RESOLVED-WORKSFORME and leave a short comment that includes your version of LibreOffice and Operating System

Please DO NOT

Update the version field
Reply via email (please reply directly on the bug tracker)
Set the bug's Status field to RESOLVED - FIXED (this status has a particular meaning that is not appropriate in this case)


If you want to do more to help you can test to see if your issue is a REGRESSION. To do so: 1. Download and install oldest version of LibreOffice (usually 3.3 unless your bug pertains to a feature added after 3.3)

http://downloadarchive.documentfoundation.org/libreoffice/old/

2. Test your bug 3. Leave a comment with your results. 4a. If the bug was present with 3.3 - set version to "inherited from OOo"; 4b. If the bug was not present in 3.3 - add "regression" to keyword


Feel free to come ask questions or to say hello in our QA chat: http://webchat.freenode.net/?channels=libreoffice-qa

Thank you for your help!

-- The LibreOffice QA Team This NEW Message was generated on: 2015-07-18
Comment 11 Laurent BP 2016-05-16 17:12:19 UTC
(In reply to ign_christian from comment #9)
> After observing Bug 66089, I found same cause for this problem: "Use printer
> metrics for text formatting" enabled.
So it should be marked as duplicate
 
> But if we disable "printer metrics", alignment not working at all on cells
> B4:B21.
With Tools>Options>LibreOffice cal>General - "Use printer metrics for text formatting" disable I don't see any bug. LibO is trying to do its best with this format:
_(* #.##0_);_(* \(#.##0\);_(* -_);_(@_)
You set alignment center, while in the same time you fill with space left part of the cell "_(* ". So your cells appear right aligned because LibO adds as much as possible spaces characters on the left.

You must also be careful with some points:
- decimal and thousand separators are different according to the language indicated in Format > Cells > Numbers. So a dot or space in your language may be a different separator in another language, making confusion. Moreover, XLSX does not save the language, so your file open differently according to the language used by user.
- there is 4 alignment positions: left, center, right or default. Default is right for number and left for text. So clicking on left/center/right alignment buttons will activate default alignment or force a specific alignment.

As I do no see alignment problem with Version: 5.0.4.2
Build ID: 00m0(Build:2)
Locale : fr-FR (fr_FR.UTF-8)
on Linux OpenSuse 13.2
I close it as duplicate. If you do not agree, please feel free to set it at NEW again and explain what should be expected.

*** This bug has been marked as a duplicate of bug 66089 ***