Download it now!
Bug 64532 - [FILEOPEN] Loading DOCX with Table-of-Contents in loses first 2 lines in ToC
Summary: [FILEOPEN] Loading DOCX with Table-of-Contents in loses first 2 lines in ToC
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
4.0.0.3 release
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard: BSA (target:4.3.0)
Keywords:
Depends on:
Blocks:
 
Reported: 2013-05-13 11:28 UTC by Adam CloudOn
Modified: 2014-02-14 15:46 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:


Attachments
DOCX containing Table-of-Contens (25.70 KB, application/vnd.openxmlformats-officedocument.wordprocessingml.document)
2013-05-13 11:28 UTC, Adam CloudOn
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Adam CloudOn 2013-05-13 11:28:11 UTC
Created attachment 79245 [details]
DOCX containing Table-of-Contens

Problem description: 
DOCX was created in Word. When trying to open in LO - the first 2 lines of the ToC are missing.

Steps to reproduce:
1. Load attached DOCX in LO.
2. Table-of-Contents doesn't show the first 2 lines it should show

Current behavior:
Table-of-Contents doesn't show the first 2 lines it should show

Expected behavior:
Table-of-Contents should show lines called 'Heading 1', 'Heading 2', 'Heading 3'

Operating System: Windows 8
Version: 4.0.2.2 release
Comment 1 Joel Madero 2013-05-13 15:28:26 UTC
This one is quite strange as I can confirm the behavior but I see what's going on and IMO it seems like either MSO bug or user error. If you put the cursor near "Heading 1" and look at what style is being used it's Content 1 (which won't appear in TOC), if you go down to "Heading 3" you'll see that it's "Heading 11" which will appear in TOC. 

Opening the document in MSO I see that they show up BUT that the fonts are different (Heading 1-2 are both 12 size, Heading 3+ are all 14). 

Then further investigation shows that all are set to Heading Level 1 on Windows....which is strange as they *should* all be same font size if they are the same heading level. 

This being said, I can confirm that MSO and LibreOffice show different things and thus, for now marking this as a bug -- if a dev disagrees they can mark as whatever they find appropriate.

I have been able to confirm the issue on:
Version: 4.0.0.3 release
Date:   Wed May 8 18:48:38 2013 +0200 
Platform: Bodhi Linux 2.2 x64

+ + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + +
As I've been able to confirm this problem I am marking as:

Version: 4.0.0.3 release (version is oldest confirmed version, we use comments to say it's been confirmed on later release)

New (confirmed)
Normal - partial loss of data but really I'm not sure it's our bug, therefore marking as normal for now.
High - bumped up from default medium because MSO shows the table right


+ + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + +
LibreOffice is powered by a team of volunteers, every bug is confirmed (triaged) by human beings who mostly give their time for free. We invite you to join our triaging by checking out this link:
https://wiki.documentfoundation.org/QA/BugTriage and join us on freenode at #libreoffice-qa

There are also other ways to get involved including with marketing, UX, documentation, and of course developing -  http://www.libreoffice.org/get-help/mailing-lists/. 

Lastly, good bug reports help tremendously in making the process go smoother, please always provide reproducible steps (even if it seems easy) and attach any and all relevant material
Comment 2 ign_christian 2013-05-14 03:01:50 UTC
reproducible on LO 4.0.3.3 (Win7 Home Premium 32bit)
Comment 3 Julien Nabet 2013-05-18 06:23:38 UTC
On pc Debian x86-64 with master sources updated yesterday, I reproduced the problem.
I noticed these logs:
warn:legacy.osl:5968:1:oox/source/docprop/docprophandler.cxx:320: For now unexpected tags are ignored!
warn:legacy.osl:5968:1:oox/source/docprop/docprophandler.cxx:320: For now unexpected tags are ignored!
warn:legacy.osl:5968:1:oox/source/docprop/docprophandler.cxx:320: For now unexpected tags are ignored!
warn:legacy.osl:5968:1:oox/source/docprop/docprophandler.cxx:320: For now unexpected tags are ignored!
warn:legacy.osl:5968:1:oox/source/docprop/docprophandler.cxx:320: For now unexpected tags are ignored!
warn:legacy.osl:5968:1:oox/source/helper/storagebase.cxx:71: StorageBase::StorageBase - missing base input stream

Cédric/Michael: one for you?
Comment 4 Cédric Bosdonnat 2014-01-20 08:57:37 UTC
Restricted my LibreOffice hacking area
Comment 5 Jorendc 2014-02-14 15:46:22 UTC
Looks fixed to me, tested using Mac OSX 10.9 with LibreOffice Version: 4.3.0.0.alpha0+ Build ID: a315454f349469923490e4116806ee19263849b8

'Heading 1' and 'Headin 2' is correctly displayed. I did compare the document with Word for Mac 2011.

Marking as RESOLVED WORKSFORME