Download it now!
Bug 64685 - Superscript broken in master
Summary: Superscript broken in master
Status: VERIFIED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
4.1.0.0.alpha0+ Master
Hardware: x86-64 (AMD64) Linux (All)
: medium normal
Assignee: Khaled Hosny
URL:
Whiteboard: target:4.2.0 target:4.1.0.0.beta2
Keywords:
: 64921 (view as bug list)
Depends on:
Blocks: mab4.1
  Show dependency treegraph
 
Reported: 2013-05-16 19:58 UTC by Jean-Baptiste Faure
Modified: 2013-05-27 08:14 UTC (History)
6 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Jean-Baptiste Faure 2013-05-16 19:58:03 UTC
Steps to reproduce:
- type some text in a document
- select one character and hit the superscript button in the formatting toolbar

==> the character becomes subscript.

- activate autocorrection if it is not
- type 1er in French or 1st in English

==> er and st becomes subscript instead of superscript

I am currently doing bisect to localize the regression. At least it is between
http://cgit.freedesktop.org/libreoffice/core/commit/?id=f99df8b7ac4cba88ba5f6aa5439605fcff2d1e3e (GOOD)
http://cgit.freedesktop.org/libreoffice/core/commit/?id=252b6b608f5fc35b154846c3487809fe5e147ab7 (BAD)


Best regards. JBF
Comment 1 Jean-Baptiste Faure 2013-05-17 21:31:38 UTC
If my bisect is right the problematic commit is http://cgit.freedesktop.org/libreoffice/core/commit/?id=f22006dc6ac34a35a060e15466cf6b2d2058617d

Best regards. JBF
Comment 2 Arnaud Versini 2013-05-18 11:55:38 UTC
Confirmed on Ubuntu 13.04.
Comment 4 Jean-Baptiste Faure 2013-05-23 14:14:11 UTC
For the record : tested on LO 4.1.0.0.alpha1+ Build ID: 90212f0a0cd42bb1895843ec6d66677f16bbb15 and verified that the bug affects this branch too.

Best regards. JBF
Comment 5 Khaled Hosny 2013-05-25 11:50:08 UTC
*** Bug 64921 has been marked as a duplicate of this bug. ***
Comment 6 Commit Notification 2013-05-27 07:46:42 UTC
Khaled Hosny committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=6e6b028164176e39219dccbe1b84380b10b6e64f

Fix fdo#64685 - Superscript broken in master



The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 7 Commit Notification 2013-05-27 07:54:37 UTC
Khaled Hosny committed a patch related to this issue.
It has been pushed to "libreoffice-4-1":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=0c0e7f1bd48d1a89ccdba3f5e773186123943e43&h=libreoffice-4-1

Fix fdo#64685 - Superscript broken in master


It will be available in LibreOffice 4.1.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 8 Jean-Baptiste Faure 2013-05-27 08:14:53 UTC
verified on Version: 4.1.0.0.alpha1+
Build ID: 0c0e7f1bd48d1a89ccdba3f5e773186123943e4

Thank you very much :-)
JBF