Download it now!
Bug 64711 - Impress is closed on slide show with all hidden slides in presentation or group
Summary: Impress is closed on slide show with all hidden slides in presentation or group
Status: VERIFIED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Impress (show other bugs)
Version:
(earliest affected)
3.3.0 release
Hardware: Other All
: medium normal
Assignee: Caolán McNamara
URL:
Whiteboard: target:7.1.0 target:7.0.3
Keywords:
: 136967 (view as bug list)
Depends on:
Blocks: Slide-Show Crash
  Show dependency treegraph
 
Reported: 2013-05-17 11:10 UTC by gmolleda
Modified: 2020-09-29 09:54 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description gmolleda 2013-05-17 11:10:53 UTC
Steps:
1.- Create a new impress file, with 4 slides A, B, C, D
2.- Hide B and D slides
3.- Go to option "Slide Show" - "Custom Slide Show..."
4.- New button, add B and D to custom group.
5.- Use the check box [V] Use Custom Slide Show
If you like, you could save the file because all will be close.
6.- Press button "Start"

7.- The Impress is closed.


Solution: check with a while loop for all slides in the custom group, if ONE slide is not hidden then break loop and follow running.

Please: add a button in "Custom Slide Show" for change all slides in group to "Show Slide" and all other slides to "Hide Slide".
Comment 1 ign_christian 2013-05-18 05:31:03 UTC
reproducible on LO 4.0.3.3 (Win7 32bit) -> Impress will close & reopening LO will start Document Recovery
Comment 2 QA Administrators 2015-03-04 02:21:40 UTC Comment hidden (obsolete)
Comment 3 gmolleda 2015-03-04 14:16:04 UTC Comment hidden (obsolete)
Comment 4 tommy27 2016-04-16 07:23:28 UTC Comment hidden (obsolete)
Comment 5 gmolleda 2016-04-19 12:16:15 UTC Comment hidden (obsolete)
Comment 6 gmolleda 2016-04-20 05:53:57 UTC
The bug was present with 3.3.0: "inherited from OOo"
Comment 7 QA Administrators 2017-05-22 13:23:27 UTC Comment hidden (obsolete)
Comment 8 gmolleda 2017-05-22 18:24:16 UTC Comment hidden (obsolete)
Comment 9 QA Administrators 2018-05-23 02:36:17 UTC Comment hidden (obsolete)
Comment 10 gmolleda 2018-05-23 09:37:02 UTC
Same behaviour in LibreOffice 6.0.4.2 Impress.
Comment 11 Timur 2020-09-23 18:42:43 UTC
*** Bug 136967 has been marked as a duplicate of this bug. ***
Comment 12 Telesto 2020-09-24 06:56:49 UTC
@Caolan
You might be interested as the idea is to replace the crash with an (error) dialog
See https://bugs.documentfoundation.org/show_bug.cgi?id=136967#c3
Comment 13 Caolán McNamara 2020-09-24 14:15:35 UTC
I'll take this to fix just the crash
Comment 14 Commit Notification 2020-09-25 07:57:50 UTC
Caolán McNamara committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/582a73abd2e5b51d8a21af2997395cd4db707a80

tdf#64711 pointer deleted out from under std::shared_ptr

It will be available in 7.1.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 15 Caolán McNamara 2020-09-25 08:35:44 UTC
crash fixed in master, backport to 7-0 in gerrit
Comment 16 Walter 2020-09-28 08:17:22 UTC
I tested the development build and LibreOffice does not crash any more. Thanks for fixing this bug so quickly :)

Walter
Comment 17 Timur 2020-09-28 08:37:49 UTC
Fine, no crash, I set Verified. 
From steps in Description I see another bug I'll report for Custom slide show. 
Message "All slides are hidden.." would be yet another bug.
Comment 18 Timur 2020-09-28 08:39:34 UTC
@Walter: I corrected your wrong status, when you confirm the fix, than it's Reoslved->Verified Fixed, WFM is else, when no fix is known. 
https://bugs.documentfoundation.org/page.cgi?id=fields.html#bug_status
Comment 19 Timur 2020-09-28 08:58:25 UTC
This is MSO behavior - that I do not support :
1. if all slides are hidden, slide show shows all slides
2. if a single slide is shown and rest is hidden, that single slide is shown.

I think LO behavior of not running any slide if all are hidden is OK. 
Only would we need a warning message as proposed in https://bugs.documentfoundation.org/show_bug.cgi?id=136967#c3 and that would be new enhancement bug, if someone wants to file.
Comment 20 Commit Notification 2020-09-29 09:54:51 UTC
Caolán McNamara committed a patch related to this issue.
It has been pushed to "libreoffice-7-0":

https://git.libreoffice.org/core/commit/01eefecf1eca39969e1b7f04ca80204105452979

tdf#64711 pointer deleted out from under std::shared_ptr

It will be available in 7.0.3.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.