Download it now!
Bug 64711 - Impress is closed when show a custom slide show with all group are hidden slides
Summary: Impress is closed when show a custom slide show with all group are hidden slides
Status: NEW
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Impress (show other bugs)
Version:
(earliest affected)
3.3.0 release
Hardware: Other All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: Slide-Show
  Show dependency treegraph
 
Reported: 2013-05-17 11:10 UTC by gmolleda
Modified: 2019-01-05 13:46 UTC (History)
0 users

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description gmolleda 2013-05-17 11:10:53 UTC
Steps:
1.- Create a new impress file, with 4 slides A, B, C, D
2.- Hide B and D slides
3.- Go to option "Slide Show" - "Custom Slide Show..."
4.- New button, add B and D to custom group.
5.- Use the check box [V] Use Custom Slide Show
If you like, you could save the file because all will be close.
6.- Press button "Start"

7.- The Impress is closed.


Solution: check with a while loop for all slides in the custom group, if ONE slide is not hidden then break loop and follow running.

Please: add a button in "Custom Slide Show" for change all slides in group to "Show Slide" and all other slides to "Hide Slide".
Comment 1 ign_christian 2013-05-18 05:31:03 UTC
reproducible on LO 4.0.3.3 (Win7 32bit) -> Impress will close & reopening LO will start Document Recovery
Comment 2 QA Administrators 2015-03-04 02:21:40 UTC Comment hidden (obsolete)
Comment 3 gmolleda 2015-03-04 14:16:04 UTC
Same behaviour in LibreOffice 4.4.1.2.
Comment 4 tommy27 2016-04-16 07:23:28 UTC Comment hidden (obsolete)
Comment 5 gmolleda 2016-04-19 12:16:15 UTC
The bug is present in Libreoffice 5.1.2.2, the LibreOffice close with message of error about recovery the file closed.
Comment 6 gmolleda 2016-04-20 05:53:57 UTC
The bug was present with 3.3.0: "inherited from OOo"
Comment 7 QA Administrators 2017-05-22 13:23:27 UTC Comment hidden (obsolete)
Comment 8 gmolleda 2017-05-22 18:24:16 UTC
Same bug in version 5.3.3.2
Comment 9 QA Administrators 2018-05-23 02:36:17 UTC Comment hidden (obsolete)
Comment 10 gmolleda 2018-05-23 09:37:02 UTC
Same behaviour in LibreOffice 6.0.4.2 Impress.