Download it now!
Bug 64894 - FILEOPEN RTF Some characters prevent type autodetection
Summary: FILEOPEN RTF Some characters prevent type autodetection
Status: RESOLVED DUPLICATE of bug 78731
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
4.0.3.3 release
Hardware: Other Windows (All)
: medium minor
Assignee: Not Assigned
URL:
Whiteboard: BSA
Keywords:
: 64893 (view as bug list)
Depends on:
Blocks:
 
Reported: 2013-05-23 07:26 UTC by nr5519
Modified: 2015-06-17 13:15 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments
Word-2003 doc with this bug (155.30 KB, application/msword)
2013-05-23 07:26 UTC, nr5519
Details
Minimal example (114 bytes, application/msword)
2013-05-23 11:15 UTC, Urmas
Details

Note You need to log in before you can comment on or make changes to this bug.
Description nr5519 2013-05-23 07:26:39 UTC
Created attachment 79692 [details]
Word-2003 doc with this bug

1. Open file with mouse double-click
2. Get this:
{\rtf\ansi\deff0\ansicpg1252 
{\fonttbl 
{\f0\froman Times New Roman;}} 
{\colortbl\red0\green0\blue0;} 
{\info{\author WinXP}} 
\jexpand\viewkind1\viewscale100 
\paperw12190\paperh17260\margl683\margr136\margt683\margb382 
\cols2\colno1\colw8855\colsr-0\colno2\colw2514\pard\li1065\ri0\sl-218\slmult0 \fs18\cf0\par\pard\li1065\ri0\sl-218\slmult0 \fs18\cf0\par\pard....
Operating System: Windows XP
Version: 4.0.3.3 release
Comment 1 Urmas 2013-05-23 11:15:12 UTC
Created attachment 79700 [details]
Minimal example
Comment 2 Urmas 2013-05-23 11:17:33 UTC
If the document is of explicitly RTF filetype, it is opened correctly.
Otherwise, the presence of certain characters makes it opened as a text file.
Comment 3 Urmas 2013-05-25 08:42:22 UTC
*** Bug 64893 has been marked as a duplicate of this bug. ***
Comment 4 QA Administrators 2015-04-19 03:22:07 UTC
** Please read this message in its entirety before responding **

To make sure we're focusing on the bugs that affect our users today, LibreOffice QA is asking bug reporters and confirmers to retest open, confirmed bugs which have not been touched for over a year.

There have been thousands of bug fixes and commits since anyone checked on this bug report. During that time, it's possible that the bug has been fixed, or the details of the problem have changed. We'd really appreciate your help in getting confirmation that the bug is still present.

If you have time, please do the following:

   *Test to see if the bug is still present on a currently supported version of LibreOffice (4.4.1 or later)
   https://www.libreoffice.org/download/

   *If the bug is present, please leave a comment that includes the version of LibreOffice and your operating system, and any changes you see in the bug behavior
 
   *If the bug is NOT present, please set the bug's Status field to RESOLVED-WORKSFORME and leave a short comment that includes your version of LibreOffice and Operating System

Please DO NOT

   *Update the version field
   *Reply via email (please reply directly on the bug tracker)
   *Set the bug's Status field to RESOLVED - FIXED (this status has a particular meaning that is not appropriate in this case)


If you want to do more to help you can test to see if your issue is a REGRESSION. To do so: 

1. Download and install oldest version of LibreOffice (usually 3.3 unless your bug pertains to a feature added after 3.3)

http://downloadarchive.documentfoundation.org/libreoffice/old/

2. Test your bug 
3. Leave a comment with your results. 
4a. If the bug was present with 3.3 - set version to "inherited from OOo"; 
4b. If the bug was not present in 3.3 - add "regression" to keyword


Feel free to come ask questions or to say hello in our QA chat: http://webchat.freenode.net/?channels=libreoffice-qa

Thank you for your help!

-- The LibreOffice QA Team This NEW Message was generated on: 2015-04-18
Comment 5 Buovjaga 2015-06-17 12:20:34 UTC
Confirmed.

Win 7 Pro 64-bit Version: 5.1.0.0.alpha1+
Build ID: 80ec99db4325a439a8a3f1d420d0a80f8bf9c439
TinderBox: Win-x86@62-merge-TDF, Branch:MASTER, Time: 2015-06-16_00:00:20
Locale: fi-FI (fi_FI)
Comment 6 Maxim Monastirsky 2015-06-17 13:15:57 UTC
This one is earlier than Bug 78731, but the latter has a comment from one of libwpd devs.

*** This bug has been marked as a duplicate of bug 78731 ***