Download it now!
Bug 64972 - 4.1.0.0.beta1: strikethrough displays too high, like overline
Summary: 4.1.0.0.beta1: strikethrough displays too high, like overline
Status: VERIFIED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: UI (show other bugs)
Version:
(earliest affected)
4.1.0.0.beta1
Hardware: x86-64 (AMD64) Linux (All)
: medium normal
Assignee: Khaled Hosny
URL:
Whiteboard: target:4.1.0.0.rc2 target:4.2.0
Keywords: regression
: 66174 (view as bug list)
Depends on:
Blocks:
 
Reported: 2013-05-25 00:43 UTC by Terrence Enger
Modified: 2013-07-01 13:12 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:


Attachments
collected screenshots (189.09 KB, application/vnd.oasis.opendocument.text)
2013-05-25 00:43 UTC, Terrence Enger
Details
writer document pictured in first attachment (8.17 KB, application/vnd.oasis.opendocument.text)
2013-05-25 00:50 UTC, Terrence Enger
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Terrence Enger 2013-05-25 00:43:18 UTC
Created attachment 79777 [details]
collected screenshots

The on-screen rendering of strikethrough has deteriorated from version
4.1.0.0.alpha1+ (build 8450a99) to 4.1.0.0.beta1 (build 3a2c2d2) in
that the striking-through line has moved up to almost the level of an
overline.  I see this behaviour in both Writer and Calc.  See attached
file description.odt, which contains screenshots.

Both versions of Writer are from downloaded .deb files, executing from
"parallel" installations on ubuntu-quantal (13.04) 64-bit:

    $ uname -a
    Linux quantal64 3.5.0-27-lowlatency #30-Ubuntu SMP PREEMPT Wed Apr 3 18:26:33 UTC 2013 x86_64 x86_64 x86_64 GNU/Linux

I am leaving LO version field of this report "unspecified", as 4.1.0.0
seems to not be available yet.

I am leaving status UNCONFIRMED.  Will somebody agree with me that the
behaviour is bad?
Comment 1 Terrence Enger 2013-05-25 00:50:53 UTC
Created attachment 79778 [details]
writer document pictured in first attachment

and a very simple document it is.
Comment 2 Terrence Enger 2013-05-25 00:56:57 UTC
adding LO version to summary, just until it is allowed in the version field
Comment 3 Commit Notification 2013-05-25 11:30:06 UTC
Khaled Hosny committed a patch related to this issue.
It has been pushed to "libreoffice-4-1":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=5e2d59e4b910631c802d5c7c42b7411e5a8b8db6&h=libreoffice-4-1

Fix fdo#64972 - strikethrough displays too high


It will be available in LibreOffice 4.1.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 4 Commit Notification 2013-05-25 11:30:26 UTC
Khaled Hosny committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=753f5721970805224e8bdfc5b9fdb2611ba9aa34

Fix fdo#64972 - strikethrough displays too high



The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 5 Terrence Enger 2013-05-30 12:23:22 UTC
I see it fixed in commit 45abf35, pulled around 2013-05-29 15:00 UTC.
Comment 6 Commit Notification 2013-06-04 10:20:54 UTC
Petr Mladek committed a patch related to this issue.
It has been pushed to "libreoffice-4-1":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=1d34b905fad48b7aee7ccf39e33d952846f00fea&h=libreoffice-4-1

Revert "Fix fdo#64972 - strikethrough displays too high"


It will be available in LibreOffice 4.1.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 7 Petr Mladek 2013-06-04 11:10:10 UTC
I have reverted this fix in the libreoffice-4-0 branch because it made Impress almost unusable, see the bug #65132.
Comment 8 Commit Notification 2013-06-12 10:48:29 UTC
David Tardon committed a patch related to this issue.
It has been pushed to "libreoffice-4-1":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=4e0a8fc68bda2a88de5468a61218996a099d3302&h=libreoffice-4-1

Revert "Revert "Fix fdo#64972 - strikethrough displays too high""


It will be available in LibreOffice 4.1.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 9 Terrence Enger 2013-06-19 00:27:09 UTC
Silly me!  I reported good results in comment 5, when I was looking at
the document only as saved, zoom factor 160%.  Today I wanted
something to do with my brand new local build of master (commit id
60e2096 pulled 2013-06-18 12:15 UTC), so I tried looking at different
zoom factors.  Bad idea, as now I see that the appearance of
overscore, strikethrough, and underscore depends dramatically on the
zoom factor.

I am setting bug status REOPENED because I cannot set it to
UNCONFIRMED at the same time.  In particular, I would like
confirmation that we expect the appearance of decorated text to be
more-or-less similar across a wide range of zoom factors.


It would have been a lot better for me to capture screenshots rather
than wordy descriptions, and if anybody cares I shall do the
screenshots.  Meanwhile, between the combination of and old screen and
my Mark 1 eyeballs, my description of the smaller zoom factors is
something of a guess:

zoom        overline            strikethrough            underline
-------     ------------------- ---------------------    --------------------

65%         somewhere up there  even higher (bad)        somewhere down there

100%        at top of ascenders above x-height           above bottom
                                                         of descenders

110% to     above whitespace    at top of x-height       above bottom 
  140%       above ascenders                              of descenders

160% to     above whitespace    below top of             overlaps bottom
  180%        above ascenders     x-height (good)          of descenders

200% to     ditto               above half of x-height   ditto
  220%

250%        touches top of      below half of x-height   ditto 
              ascenders

280% to     overlaps top of     ditto                    ditto
  440%        ascenders

490% to     overlaps x-height   just above baseline      ditto
  600%


Thanks,
Terry.
Comment 11 Jorendc 2013-06-25 22:59:44 UTC
*** Bug 66174 has been marked as a duplicate of this bug. ***
Comment 12 Terrence Enger 2013-07-01 13:12:14 UTC
With master commit a08f579, pulled 2013-06-28 18:30 UTC, the result looks good at all zoom factors from the smallest I can distinguish up to 600% (the largest offered).

Thank you, Khaled.