Bug 65152 - CALC: Superscript and Spacing character formats not copied by Clone Formatting - clarify Help per Comment 7
Summary: CALC: Superscript and Spacing character formats not copied by Clone Formattin...
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Documentation (show other bugs)
Version:
(earliest affected)
Inherited From OOo
Hardware: All All
: low minor
Assignee: Rafael Lima
URL:
Whiteboard: BSA target:7.3.0
Keywords:
Depends on:
Blocks: Clone-Formatting
  Show dependency treegraph
 
Reported: 2013-05-30 01:43 UTC by Jim Avera
Modified: 2021-09-20 20:22 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
Small spreadsheet showing the problem (23.44 KB, application/vnd.oasis.opendocument.spreadsheet)
2013-05-30 01:43 UTC, Jim Avera
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Jim Avera 2013-05-30 01:43:46 UTC
Created attachment 80003 [details]
Small spreadsheet showing the problem

If certain character formatting options are applied to all the text in a cell, and then the format paintbrush used to copy the cell's format to other cells, then only some of the character formatting selections are copied.   

It appears that color, shadow, outline, and font are copied, but not super/subscript, kerning, or character spacing (condensed etc.)   All these are options set with Format->Character... while all the characters in the source cell are selected.

See attached demo spreadsheet.

Steps to reproduce:
1. Increase column A width to about 3 inches.
2. Put identical text in A1 and A2, long enough to not quite fit in the cell
3. Select all the characters in A1
4. Format->Character...
   Under Font-Position check 'Superscript' and/or set Spacing to "Condensed" by 0.5pt
   Under Effects check Outline & Shadow
   Click outside the cell to de-select the text
5. Click A1 to select the cell
6. Click the format copy paintbrush icon
7. Click in A2 to copy the format

Results: A2 changes to have the same Outline/Shadow effects and color as A1, but does not change to have the same Font-Position options (condensed, superscript etc.)

Expected Results: All formatting options would be copied
Operating System: Ubuntu
Version: 4.0.3.3 release
Comment 1 ign_christian 2013-06-09 03:33:42 UTC Comment hidden (obsolete)
Comment 2 Joel Madero 2013-09-24 21:50:46 UTC Comment hidden (obsolete)
Comment 3 QA Administrators 2015-04-01 14:41:32 UTC Comment hidden (obsolete)
Comment 4 Jim Avera 2015-04-11 20:06:34 UTC
Problem still there in 4.4.2.0.0+ 

It does not seem to be possible to copy character formatting from A1 into A2 in the demo spreadsheet using the Format Paintbrush.   Holding Control or not when clicking makes no difference.
Comment 5 tommy27 2016-04-16 07:24:22 UTC Comment hidden (obsolete)
Comment 6 Jim Avera 2016-05-31 19:36:44 UTC
Bug is still there in 5.2.0.0.alpha0 (build from 2016-04-11).

I changed the bug title to specifically mention that Superscript and Spacing character format options are not copied by the paintbrush.

Here are simplified STEPS TO REPRODUCE:

1.  Open the attached bugdemo.ods
2.  Click in A1 (selects the cell)
3.  Click the Clone Formatting Paintbrush
4.  Click in A4

RESULTS: Font side and outline change in A4, but the result does not have the Superscript or modified character Spacing of the text in A1

EXPECTED RESULTS: All character attributes would be cloned
Comment 7 Timur 2017-10-04 16:40:56 UTC
I'm a little bit confused.
Help says: "In Calc, the Clone Formatting tool only applies to cell formatting."
That would make sense. Because in the demo, Outline & Shadow belong to Cell properties and that's why they are cloned and superscript is not, because it's text formatting. 

Later, Help says: 
"Calc table or cells are selected: Copies the formatting that is specified in the Format - Cells dialog as well as the formatting of the cell contents"
I don't understand part "as well as the formatting of the cell contents". It's the same all the way from OO.
I guess it doesn't reflect to Format-Character. In that case, this is NotaBug. 

But instead of closing, I'll convert this one to Documentation issue to clarify Help on that part.

https://help.libreoffice.org/6.0/en-US/text/shared/guide/paintbrush.html?DbPAR=SHARED#bm_id380260
Comment 8 Commit Notification 2021-08-30 11:56:06 UTC
Rafael Lima committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/help/commit/5737332355e2d047e7ab6112cc4767d2b0639dba

tdf#65152 Improve Clone Formatting tool help page
Comment 9 Rafael Lima 2021-09-20 20:22:01 UTC
This bug is now fixed in the latest build of the help:

https://help.libreoffice.org/7.3/en-US/text/shared/guide/paintbrush.html