Download it now!
Bug 112872 - Amend Clone formatting help with details regarding direct formatting
Summary: Amend Clone formatting help with details regarding direct formatting
Status: NEW
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Documentation (show other bugs)
Version:
(earliest affected)
4.4.0.3 release
Hardware: All All
: medium normal
Assignee: Not Assigned
URL: https://help.libreoffice.org/6.4/en-U...
Whiteboard:
Keywords:
: 115910 (view as bug list)
Depends on:
Blocks: Clone-Formatting Help-Changes-Features
  Show dependency treegraph
 
Reported: 2017-10-04 11:22 UTC by Gerald Pfeifer
Modified: 2019-11-11 16:26 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:


Attachments
Sample document (10.28 KB, application/vnd.oasis.opendocument.text)
2017-10-04 11:22 UTC, Gerald Pfeifer
Details
Video showing the issue (1.61 MB, video/mp4)
2017-10-04 11:23 UTC, Gerald Pfeifer
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Gerald Pfeifer 2017-10-04 11:22:23 UTC
Created attachment 136755 [details]
Sample document

This is a bug a colleague has encountered and recorded as a video, where
clone formatting does not appear to be working, in particular the font
size from the heading is not transferred to the text body.

If I change the color of the heading and use clone formatting into the
text body, that works.

Similarly if I increase the font size of the heading and then repeat the
experiment, that works as well.


As an interesting side note: the file has been created with LibreOffice
on Windows and it also does not work there. The paragraph in font type
Calibri has been c&p'ed from Outlook into the document. (It should be
possible to change this paragraph with clone formatting though.)
Comment 1 Gerald Pfeifer 2017-10-04 11:23:32 UTC
Created attachment 136756 [details]
Video showing the issue
Comment 2 Timur 2017-10-04 13:16:55 UTC
Looks not like a bug to me. 
Because when you clone formatting, only the character formatting is copied, and your heading doesn't have additional character formatting while text is already character formatted. 
You may use Ctrl on destination and it will include paragraph formatting, so you'll get what you want. 

https://help.libreoffice.org/6.0/en-US/text/shared/guide/paintbrush.html?DbPAR=SHARED#bm_id380260

If not sure it's a bug, please ask first on ask.libreoffice.org. 
When submitting a bug, please write exact steps. No need for a video.

Now I'm not sure whether this should be closed as NotaBug ar changed to Documentation type in order to clarify this Help page.
Comment 3 Gerald Pfeifer 2017-10-04 14:59:55 UTC
I got confused since increasing the font size on the heading did then
change the behavior.

At least for a "naive" user this is really a bit tricky/confusing.
(And two colleagues fell into this before.)
Comment 4 Timur 2017-10-04 15:34:22 UTC
Increasing the font size on the source text was direct formatting that overwrote destination one :)

I'll mark this as documentation issue and rename. For example, add another bulb or example symbol with sth. like this:
"If text without character formatting is format cloned to text with character formatting, destination formatting will not be changed because it takes priority. 
It will be changed though with paragraph formatting, hold down Ctrl when you click."

If I'm wrong, someone please correct.
Comment 5 Mike Kaganski 2018-01-13 09:41:57 UTC
See also bug 59029 comment 11.
Comment 6 Timur 2018-02-21 17:00:14 UTC
*** Bug 115910 has been marked as a duplicate of this bug. ***