Download it now!
Bug 65156 - Sidebar looks Very Bad when using Dark Theme (high contrast)
Summary: Sidebar looks Very Bad when using Dark Theme (high contrast)
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: UI (show other bugs)
Version:
(earliest affected)
4.2.0.0.alpha0+ Master
Hardware: All All
: medium major
Assignee: Not Assigned
URL:
Whiteboard: target:4.2.0
Keywords:
: 67322 (view as bug list)
Depends on:
Blocks: Sidebar-UI-UX
  Show dependency treegraph
 
Reported: 2013-05-30 03:52 UTC by Joel Madero
Modified: 2016-10-24 14:02 UTC (History)
5 users (show)

See Also:
Crash report or crash signature:


Attachments
High Contrast Sidebar (448.80 KB, image/xcf)
2013-05-30 03:52 UTC, Joel Madero
Details
high contrast sidebar as png. (119.49 KB, image/png)
2013-06-05 09:39 UTC, Michael Meeks
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Joel Madero 2013-05-30 03:52:00 UTC
Created attachment 80011 [details]
High Contrast Sidebar

When using a dark theme the sidebar looks quite bad - attached you'll find the image. Not sure if it's just not been implemented yet (sidebar high contrast) or if this is in fact a bug. Either way - enough people use dark themes and this feature is going to catch *some* heat anyways, would be good to have it at least looking pretty on every system :)

Overall - I'm actually liking the sidebar as an optional feature, thanks all for the hard work
Comment 1 V Stuart Foote 2013-05-30 05:09:26 UTC
Joel,

Agree that the sidebar feature does not render well in high contrast themes. But, this should probably be --resolved not our bug--.

The entire sidebar has not gone through any LibreOffice UX review. Its port from IBM Symphony was done into GTK+ by only a couple of active Apache OpenOffice project developers--followed by a pretty robust QA cycle when the branch was merged with trunk. 

I doubt very much if any review of artwork and Icons for high contrast themes has been undertaken as devs are still working out basic GUI function, similar to the ongoing issues with the a LibreOffice Template Manager GUI

A very active meta bug for ongoing Sidebar development is available on the Apache OpenOffice bugzilla portal at https://issues.apache.org/ooo/show_bug.cgi?id=121420

Caolán is staying on top of the AOO commits being done, so the LibreOffice master/4.2.0alpha builds are current, with the LODev4.1.0beta1+ getting updates as well.  So both will offer functional experimental "preview" of the sidebar.
Something for the QA team to discuss is if we should put any resources toward this effort--see my item in Nabble QA.

But over at AOO, Andre is having some issues with focus the GTK widgets for the GUI, I don't know if there is a LO dev in a position to lend a hand, but if folks want to help the feedback needs to be going to the primary developers/maintainers. I'd encourage anyone with some extra time to spin up /Admin or parallel installations of Apache OpenOffice and contribute feedback against that.  I say that because I think we are some time away from doing any substantive rework of the sidebar in LibreOffice--if ever--depending on ESC and UX-advisory positions to use it or not.

Stuart
Comment 2 Michael Meeks 2013-05-30 08:27:05 UTC
Stuart - an interesting post; clearly we can and will fix the sidebar as/when we have more UX feedback -and- we're out of the bug-fixing phase for 4.1; for now I think the main focus is non-experimental features :-)

Having said that patches to fix anything in LibreOffice are always welcome.

Thanks !
Comment 3 Michael Meeks 2013-06-05 09:39:09 UTC
Created attachment 80334 [details]
high contrast sidebar as png.
Comment 4 Michael Meeks 2013-06-05 09:50:40 UTC
Kendy reports: Panels that are converted to the .ui format and layout scheme will have this fixed, that's an ongoing process for 4.1 of course ...
Comment 5 Maxim Monastirsky 2013-08-04 14:57:02 UTC
*** Bug 67322 has been marked as a duplicate of this bug. ***
Comment 6 Maxim Monastirsky 2013-10-14 05:58:42 UTC
Fixed in master a long time ago.