Download it now!
Bug 67322 - VIEWING: Sidebar: Background color of some icons doesn't comply with system standard
Summary: VIEWING: Sidebar: Background color of some icons doesn't comply with system s...
Status: RESOLVED DUPLICATE of bug 65156
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: UI (show other bugs)
Version:
(earliest affected)
4.1.0.4 release
Hardware: Other All
: medium minor
Assignee: Not Assigned
URL:
Whiteboard: BSA
Keywords: regression
Depends on:
Blocks: Sidebar-Properties
  Show dependency treegraph
 
Reported: 2013-07-25 19:38 UTC by Ettore Atalan
Modified: 2016-10-24 13:51 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments
Screenshot of sidebar in LibreOffice 4.1 (23.11 KB, image/jpeg)
2013-07-25 19:38 UTC, Ettore Atalan
Details
Screenshot of LibreOffice 4.1.0 release on Windows 7 (17.75 KB, image/png)
2013-08-01 07:29 UTC, Maxim Monastirsky
Details
Screenshot of 4.2.0.0.alpha0+ Build ID: 8b96cfd6caedbad7b3b79e57421a834f18c5c511 TinderBox: Win-x86@6-debug, Branch:master, Time: 2013-07-27_22:47:00 (17.13 KB, image/png)
2013-08-01 07:30 UTC, Maxim Monastirsky
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Ettore Atalan 2013-07-25 19:38:15 UTC
Created attachment 83006 [details]
Screenshot of sidebar in LibreOffice 4.1

Problem description: 
The icon background color within the sidebar doesn't comply completely with system standard. On my system the background color is dark, but some icons still have a white background.


Steps to reproduce:
1. Change your system colors to dark background and white text
2. Start LibreOffice (e.g. Writer, Calc, etc)
3. Enable sidebar

Current behavior:
Some icons within the sidebar have a white background.

Expected behavior:
That all icons have the same background color, which should comply with system standard.
Operating System: Ubuntu
Version: 4.1.0.4 release
Last worked in: 3.6.6.2 release
Comment 1 Jorendc 2013-07-26 19:28:46 UTC
@Kendy: thoughts :)?
Comment 2 Maxim Monastirsky 2013-08-01 07:28:15 UTC
This has nothing to do with Linux or dark theme, as it's reproducible on Windows too. And it seems to be already fixed in master. Still, would be great if someone can confirm that on Linux too, as the original report is about Linux.

I think it's because some panels weren't converted to the new .ui format in-time for 4.1.0 release (and that's why the sidebar considered experimental).
Comment 3 Maxim Monastirsky 2013-08-01 07:29:09 UTC
Created attachment 83415 [details]
Screenshot of LibreOffice 4.1.0 release on Windows 7
Comment 4 Maxim Monastirsky 2013-08-01 07:30:52 UTC
Created attachment 83416 [details]
Screenshot of 4.2.0.0.alpha0+ Build ID: 8b96cfd6caedbad7b3b79e57421a834f18c5c511 TinderBox: Win-x86@6-debug, Branch:master, Time: 2013-07-27_22:47:00
Comment 5 Maxim Monastirsky 2013-08-04 14:57:02 UTC

*** This bug has been marked as a duplicate of bug 65156 ***