Bug 65457 - Provide visual clues in presenter view for custom animations and slide transitions
Summary: Provide visual clues in presenter view for custom animations and slide transi...
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Impress (show other bugs)
Version:
(earliest affected)
3.3.0 release
Hardware: Other All
: medium enhancement
Assignee: Ciorba Edmond
QA Contact:
URL:
Whiteboard: target:4.2.0
Keywords: difficultyInteresting, easyHack, skillCpp
: 40040 (view as bug list)
Depends on:
Blocks:
 
Reported: 2013-06-06 12:56 UTC by Thorsten Behrens (CIB)
Modified: 2015-12-16 00:22 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Thorsten Behrens (CIB) 2013-06-06 12:56:29 UTC
Provide, to the presenter, a visual clue that slides will have custom animations and/or a slide transition. That way, the person running the presentation knows when multiple clicks are necessary to show the full slide content.
Comment 1 Thorsten Behrens (CIB) 2013-06-06 13:25:48 UTC
The general idea is similar to the one described in bug 65456, though there is no existing code in presenter screen for that yet.

Suggestion: stick an icon into sdext/source/presenter/PresenterSlidePreview.cxx rendering, when there is a transition or custom animation set.
Comment 2 Commit Notification 2013-07-18 08:01:49 UTC
Ciorba Edmond committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=0218b0e2fa510d7acd7413dbedefd9ad50257f76

fdo#65457 -  Provide visual clues in presenter view.



The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 3 Samuel Mehrbrodt (CIB) 2013-07-19 08:38:40 UTC
Hi Edmond,

thanks for working on that.

I tried it out, but I see two problems here:

* On the current Slide there is no clue that there are animations/transitions
* On the "Next Slide" the image is _in_ the Slide, which is a bit confusing.

I think it would be better to display an Image on top of the Slide, next to the "Current Slide", "Next Slide" text.

What do you think?
Comment 4 ign_christian 2013-08-03 02:43:18 UTC
*** Bug 40040 has been marked as a duplicate of this bug. ***
Comment 5 Robinson Tryon (qubit) 2015-12-16 00:22:06 UTC
Migrating Whiteboard tags to Keywords: (EasyHack DifficultyInteresting SkillCpp)
[NinjaEdit]