Download it now!
Bug 65623 - Cannot reset ruler origins
Summary: Cannot reset ruler origins
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Draw (show other bugs)
Version:
(earliest affected)
4.0.3.3 release
Hardware: x86 (IA32) Windows (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2013-06-10 22:51 UTC by gltyrebiter
Modified: 2015-04-23 13:09 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description gltyrebiter 2013-06-10 22:51:07 UTC
Also existed in 4.0.2.2

May be related to Bug ID 65622
Comment 1 Jorendc 2013-06-27 21:06:45 UTC
What do you mean with 'reset ruler origins'?
Can't find something relevant in the View menu entry or Tools > Options page.

@Bug reporter: can you please provide more information so we can try to reproduce this behavior?

Kind regards,
Joren
Comment 2 gltyrebiter 2013-06-28 15:31:30 UTC
Well, it's as plain as the egg on my face...

The only helpfile reference I can find to this feature, I now realize, only mentions Impress at the top of the page:

"You can use vertical and horizontal rulers at the left and upper edges of the LibreOffice Impress workspace..."

"To change the origin (0 point) of the rulers, drag the intersection of the two rulers in the top left corner into the workspace. Vertical and horizontal guides appear. Continue to drag until the vertical and horizontal guides are where you want the new origin to be, and then release. To reset the origins of the rulers to the default values, double-click the intersection."

I must have remembered this feature from my ancient version of Visio. I should probably re-enter this bug as a request for a new feature.

Also, my apologies for the inefficient use of bandwidth; I'm new to this open-source stuff and I need to learn the reporting conventions.
Comment 3 Jorendc 2013-06-28 16:27:02 UTC
Thanks for your extra information!

(In reply to comment #2)
> Well, it's as plain as the egg on my face...
> 
> The only helpfile reference I can find to this feature, I now realize, only
> mentions Impress at the top of the page:
> 
> "You can use vertical and horizontal rulers at the left and upper edges of
> the LibreOffice Impress workspace..."
> 
> "To change the origin (0 point) of the rulers, drag the intersection of the
> two rulers in the top left corner into the workspace. Vertical and
> horizontal guides appear. Continue to drag until the vertical and horizontal
> guides are where you want the new origin to be, and then release. To reset
> the origins of the rulers to the default values, double-click the
> intersection."

Interesting. It completely doesn't work here. Drag the intersection to my workspace result in ... nothing.

> I must have remembered this feature from my ancient version of Visio. I
> should probably re-enter this bug as a request for a new feature.

Why you should so? Looks like this doesn't work as it is mentioned in the documentation. Possibly related to Bug 65622.
 
> Also, my apologies for the inefficient use of bandwidth; I'm new to this
> open-source stuff and I need to learn the reporting conventions.

No need to apologize :). Thanks for your extra information and feedback!

Tested using Windows 8, with LibreOffice 4.1.0.1 and latest master. Reproducible.

Kind regards,
Joren
Comment 4 Richard Wilson 2013-07-21 17:45:29 UTC
I tried adding vertical ruler as per Help info for Writer. But it only appeared on a single page of my document. I needed this so I could insert a "fold mark" short horizontal line at the appropriate place on the left hand side of the first page of my document, but the vertical ruler was on the second page. On the Writer/Tools/Options, the horizontal and vertical ruler were already selected. I tried deselecting and reselecting them, but that didn't change anything, still just got vertical ruler on the wrong single page of the document.
 Eventually cured the problem by going to View, not for Writer, but for Writer-Web, which also contained selections for horizontal and vertical rulers, and then got my vertical ruler on the first page of the document.
Comment 5 QA Administrators 2015-04-01 14:41:19 UTC
** Please read this message in its entirety before responding **

To make sure we're focusing on the bugs that affect our users today, LibreOffice QA is asking bug reporters and confirmers to retest open, confirmed bugs which have not been touched for over a year.

There have been thousands of bug fixes and commits since anyone checked on this bug report. During that time, it's possible that the bug has been fixed, or the details of the problem have changed. We'd really appreciate your help in getting confirmation that the bug is still present.

If you have time, please do the following:

   *Test to see if the bug is still present on a currently supported version of LibreOffice (4.4.1 or later)
   https://www.libreoffice.org/download/

   *If the bug is present, please leave a comment that includes the version of LibreOffice and your operating system, and any changes you see in the bug behavior
 
   *If the bug is NOT present, please set the bug's Status field to RESOLVED-WORKSFORME and leave a short comment that includes your version of LibreOffice and Operating System

Please DO NOT

   *Update the version field
   *Reply via email (please reply directly on the bug tracker)
   *Set the bug's Status field to RESOLVED - FIXED (this status has a particular meaning that is not appropriate in this case)


If you want to do more to help you can test to see if your issue is a REGRESSION. To do so: 

1. Download and install oldest version of LibreOffice (usually 3.3 unless your bug pertains to a feature added after 3.3)

http://downloadarchive.documentfoundation.org/libreoffice/old/

2. Test your bug 
3. Leave a comment with your results. 
4a. If the bug was present with 3.3 - set version to "inherited from OOo"; 
4b. If the bug was not present in 3.3 - add "regression" to keyword


Feel free to come ask questions or to say hello in our QA chat: http://webchat.freenode.net/?channels=libreoffice-qa

Thank you for your help!

-- The LibreOffice QA Team This NEW Message was generated on: 2015-04-01
Comment 6 Buovjaga 2015-04-23 13:09:40 UTC
(In reply to gltyrebiter from comment #2)
> guides are where you want the new origin to be, and then release. To reset
> the origins of the rulers to the default values, double-click the
> intersection."

For me in Draw, the double-click reset works. Closing as WFM. Feel free to open, if I'm wrong.

Win 7 Pro 64-bit Version: 5.0.0.0.alpha1+ (x64)
Build ID: f3375fa07f27bd2ade519af3c07d69040d10eaa9
TinderBox: Win-x86_64@42, Branch:master, Time: 2015-04-22_23:38:50
Locale: fi_FI