Bug 65660 - Loss of cell conditional formatting and formulae when copying lines
Summary: Loss of cell conditional formatting and formulae when copying lines
Status: RESOLVED DUPLICATE of bug 59288
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
4.0.3.3 release
Hardware: x86 (IA32) Windows (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2013-06-11 21:12 UTC by Mik Fowler
Modified: 2014-07-25 14:20 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Mik Fowler 2013-06-11 21:12:29 UTC
This details three related issues affecting copying selected line(s) from one sheet to another in the same file. A further issue of similar nature is also detailed where it affects copying and pasting within the same sheet.

1. When one or more adjacent line(s) is/are selected, copied then pasted to another sheet, any conditional formatting assigned to any cells in the line(s) is lost.

2. When two or more non-adjacent lines are selected, copied and then pasted to another sheet, any formulae within any cell is replaced with the current absolute value of the originating cell and any conditional formatting assigned to any cell is lost.

3. When a single cell with assigned conditional formatting is selected, copied and then pasted to a different sheet, the conditional formatting is lost.

Where multiple adjacent lines are copied, only conditional formatting is lost, cell formulae do not appear to be affected.

Where two or more non-adjacent lines are copied, both conditional formatting and formulae are lost.

4. When two or more non-adjacent lines are selected, copied and then pasted to a position within the same sheet, any formulae within the lines is replaced with the absolute values of the originating cells; conditional formatting of any cells in the originating lines is successfully copied.

The conditional formatting in question assigns a background colour to the cell according to its ascii content; red for "n" and green for "y". The formatting is defined as "Excel_CondFormat_4_1_1" and "Excel_CondFormat_4_1_2" (or similar), respectively. The spreadsheets concerned are all based on one that was originally drafted using MS Office 2000. I do not know if alternate forms of conditional formatting are affected in the same way.

The above have not affected version(s) 3.x.x, that I am aware of. I have been using Libreoffice for approximately two years and have commonly used the above editing actions.
Comment 1 Ken Biondi 2013-06-12 05:45:22 UTC
Hello Mik,

Would it be possible for you to attach an example file?
Comment 2 Ken Biondi 2013-06-21 02:37:08 UTC
I'm can confirm the following: "1. When one or more adjacent line(s) is/are selected, copied then pasted to another sheet, any conditional formatting assigned to any cells in the line(s) is lost."

I cannot confirm the other related bugs described without more information such as sample files and screenshots.  I suggest that the other three related bugs be separated out into individual bug reports.

This bug seems to be related to bug 57849

Tested using LO 4.0.3.3
WIN 8
Comment 3 Markus Mohrhard 2013-06-28 23:16:21 UTC
Could we please use one bug report per issue and have a test document for each one with a clear description how to reproduce it.
Comment 4 Owen Genat (retired) 2013-12-15 00:01:44 UTC
I agree with comment #3. In addition this would appear to be a duplicate of bug 59288.
Comment 5 ign_christian 2014-07-25 14:20:22 UTC
Marking dup per comment 4

@Mik Fowler, please only report 1 issue / bug report as suggested by Markus if you still have issue in latest stable release

*** This bug has been marked as a duplicate of bug 59288 ***