Bug Hunting Session
Bug 65689 - FILESAVE: Files not saved as .pptx correctly
Summary: FILESAVE: Files not saved as .pptx correctly
Status: RESOLVED DUPLICATE of bug 71961
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Impress (show other bugs)
Version:
(earliest affected)
4.0.3.3 release
Hardware: Other Linux (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard: BSA
Keywords:
Depends on:
Blocks:
 
Reported: 2013-06-12 21:43 UTC by Charles Lindsey
Modified: 2014-02-15 17:54 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments
The complete presentation, which exhibits the problem (261.09 KB, application/vnd.oasis.opendocument.presentation)
2013-06-12 21:43 UTC, Charles Lindsey
Details
The file as saved in .pptx (274.24 KB, application/vnd.openxmlformats-officedocument.presentationml.presentation)
2013-06-13 15:58 UTC, Charles Lindsey
Details
created with Impress in pptx format (1006.23 KB, application/vnd.openxmlformats-officedocument.presentationml.presentation)
2013-09-13 14:32 UTC, Dominik Wujastyk
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Charles Lindsey 2013-06-12 21:43:58 UTC
Created attachment 80744 [details]
The complete presentation, which exhibits the problem

Problem description: 
A presentation created in .odp format, when saved as .pptx, loses all the formatting and animation. More specifically, the slides appear to be in Default format (as seen by pressing F11), rather than in the hierarchical Outline-n of the original. The fault was also seen in LibreOffice 3.6.2 as bundled with Ubuntu 12.10. I today ensured that my Ubuntu was up-to-date and installed LibreOffice 4.0.3.3 from https://launchpad.net/~libreoffice/+archive/libreoffice-4-0

Steps to reproduce:
1. Open Museums.odp (attached)
2. Run slide show, and observe animation (lots of flyins, etc)
3. Save as .pptx
4. Open the .pptx and run the slide show

Current behavior: The formatting is lost and the animations screwed up

Expected behavior: The slide show should have appeared the same

I suspect the cause is something in my Ubuntu setup, but I have seen reports of simlar things in http://ask.libreoffice.org/en/question/6348/distorted-impress-pages-when-saved-as-pptx/, and I have also had problems creating a .docx from a .odt.

If you cannot reproduce the problem, I can supply the .pptx that my system produced (it does not seem possible to add two attachents to this bug report).

              
Operating System: Ubuntu
Version: 4.0.3.3 release
Comment 1 Charles Lindsey 2013-06-13 15:58:24 UTC
Created attachment 80785 [details]
The file as saved in .pptx
Comment 2 Charles Lindsey 2013-06-13 16:04:05 UTC
I unzipped the .pptx today, and examined the various .xml components (though I am no expert in these). My suspicions lie in the two slideMaster files, which do not contain any txStyle elements, nor can I find any such elements in any of the other files. So if it has no text style information anywhere, it is hardly surprising that it fails to layout any text correctly.

I have now attached the complete .pptx file for you to look at.
Comment 3 Thomas van der Meulen 2013-06-20 16:40:53 UTC
Thank you for your bug report, I can reproduce this bug running LibreOffice Version: 4.1.0.1
Build ID: 1b3956717a60d6ac35b133d7b0a0f5eb55e9155 on Mac osx 10.8.4. 

The .pttx looks very screwed up yes.
Comment 4 Dominik Wujastyk 2013-09-13 14:32:10 UTC
Created attachment 85772 [details]
created with Impress in pptx format

This is the file that seems to have spontaneously reverted to some corrupted form, and can't be restored.
Comment 5 Dominik Wujastyk 2013-09-13 14:38:16 UTC
Comment on attachment 85772 [details]
created with Impress in pptx format

Reporting this on behalf of my wife.
She created an Impress file using Libreoffice 4.0.0.3 under Windows Vista.  The file was created from the beginning as a pptx file.

During 2 weeks work, the file was open all the time (bad practice, I know), and saved routinely.  Dropbox reports about 36 saved versions.

Two days ago, suddenly the file became severely corrupted.  Several embedded images and a video disappeared; text formatting completely scrambled. 

All my best efforts to recover the file have failed.  I've tried going back to earlier versions, updating LO to 4.1, uploading the pptx to Google Docs, etc. etc.  Nothing helps. :-(

The problem file is attached.
Comment 6 tommy27 2014-02-15 17:54:55 UTC
after looking at your test files I think that you stumbled upond 2 LibO bugs about .pptx

Bug 71961 - FILESAVE: text doesn't fit into text boxes after saving as .PPTX

Bug 73627 - FILESAVE: incorrect text font size after saving from .ODP to .PPTX

I mark this report as a DUPLICATE of the first one.

*** This bug has been marked as a duplicate of bug 71961 ***