Download it now!
Bug 73627 - FILESAVE: incorrect text font size after saving from .ODP to .PPTX
Summary: FILESAVE: incorrect text font size after saving from .ODP to .PPTX
Status: VERIFIED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Impress (show other bugs)
Version:
(earliest affected)
4.2.0.2 rc
Hardware: x86-64 (AMD64) All
: medium critical
Assignee: Andras Timar
URL:
Whiteboard: Confirmed:4.2.0.2:OSX target:4.2.4
Keywords:
: 61387 72581 75000 (view as bug list)
Depends on:
Blocks:
 
Reported: 2014-01-14 19:43 UTC by vulcain
Modified: 2014-04-19 05:56 UTC (History)
6 users (show)

See Also:
Crash report or crash signature:


Attachments
ODP Test File (12.65 KB, application/vnd.oasis.opendocument.presentation)
2014-01-14 19:43 UTC, vulcain
Details
Screencast of the openning of ODP - Expected result for saving (99.37 KB, image/png)
2014-01-14 19:46 UTC, vulcain
Details
ODP Test File saved as pptx (32.92 KB, application/vnd.openxmlformats-officedocument.presentationml.presentation)
2014-01-14 19:54 UTC, vulcain
Details
Screenshot after saving in pptx (94.06 KB, image/png)
2014-01-14 19:55 UTC, vulcain
Details
Screenshot after saving in pptx 4.3.0alpha+ (27.69 KB, image/png)
2014-02-15 13:56 UTC, tommy27
Details

Note You need to log in before you can comment on or make changes to this bug.
Description vulcain 2014-01-14 19:43:21 UTC
Created attachment 92083 [details]
ODP Test File

In LibreOffice 4.2.0.2 Build ID: 601a398b803303d1a40a3299729531824fe0db56

1) Launch Impress
2) Open the attached test_moztrap_export_PowerPoint.odp file
3) Select ODF Presentation as saving format
4) Click Save
5) Reopen the saved ODP file in LibreOffice
6) The size of text font are reduce (see attachement)

Expected: have the same size when we export to pptx
Comment 1 vulcain 2014-01-14 19:46:44 UTC
Created attachment 92084 [details]
Screencast of the openning of ODP - Expected result for saving
Comment 2 vulcain 2014-01-14 19:53:08 UTC
(In reply to comment #0)
> Created attachment 92083 [details]
> File reference for test
> 
> In LibreOffice 4.2.0.2 Build ID: 601a398b803303d1a40a3299729531824fe0db56
> 
> 1) Launch Impress
> 2) Open the attached test_moztrap_export_PowerPoint.odp file
> 3) Select ODF Presentation as saving format
> 4) Click Save
> 5) Reopen the saved ODP file in LibreOffice
> 6) The size of text font are reduce (see attachement)
> 
> Expected: have the same size when we export to pptx

Erratum 

3) Select Microsoft PowerPoint 2007/2010 XML (.pptx) as saving format and click Save

5) Open the saved PPTX file 

For information. No problem when we select Microsoft PowerPoint 97/2000/XP/2003 (.ppt) as saving format
Comment 3 vulcain 2014-01-14 19:54:30 UTC
Created attachment 92086 [details]
ODP Test File saved as pptx

Text font size are reduce
Comment 4 vulcain 2014-01-14 19:55:54 UTC
Created attachment 92087 [details]
Screenshot after saving in pptx

Screenshot after saving in pptx  and reopen in LibreOffice
Comment 5 retired 2014-01-15 10:57:24 UTC
Simple repro steps:

1. open "ODP Test File) with LO
2. save as pptx
3. view pptx with LO

-> reduced font size confirmed. and the bullet points show as another icon which is wrong.

Setting to NEW
Comment 6 Jean-Baptiste Faure 2014-01-25 10:31:28 UTC
I reproduce the the described problem with version 4.2.0.3.0+ on Ubuntu 13.10.
But:
1/ in the test file, the used font is Albany AMT which is not installed on my  system
2/ when exporting in OOXML format the font is chnaged in Liberation Sans. It is the same if I do the test with my onw files in which the used fonts are installed.

Best regards. JBF
Comment 7 A (Andy) 2014-02-15 12:58:21 UTC
*** Bug 75000 has been marked as a duplicate of this bug. ***
Comment 8 A (Andy) 2014-02-15 13:02:08 UTC
reproducible with LO 4.2.0.4 (Win 8.1)

Changed the Bug Importance to Critical: IMPRESS is with that bug not usable for pptx files (see also bug report 75000)
Comment 9 tommy27 2014-02-15 13:56:40 UTC
Created attachment 94116 [details]
Screenshot after saving in pptx 4.3.0alpha+

tested under Win7 64bit

seems a very old issue... I can reproduce steps in Comment 5 in all the LibO versions I have from 3.3.3 to 4.2.0... font size shrinks after saving as .pptx and reopening

however using 4.3.0.0.alpha0+ (*) the font size stays the same.
only bullet style changes from "black full circle" to "empty rectangle" see screenshot.

(*) Build ID: a995462e6855061816c6529c366f20ace2b45868
TinderBox: Win-x86@42, Branch:master, Time: 2014-01-31_23:29:34
Comment 10 tommy27 2014-02-15 14:02:44 UTC
basically it seems the the font size issue is solved in 4.3.0alpha+ while is still present in the 4.2.x branch.

I add Impress expert to CC list, maybe he can identify what fixed the issue in master and try to backport it to 4.2.x
Comment 11 tommy27 2014-02-15 14:04:27 UTC
*** Bug 61387 has been marked as a duplicate of this bug. ***
Comment 12 tommy27 2014-02-15 15:15:43 UTC
*** Bug 72581 has been marked as a duplicate of this bug. ***
Comment 13 tommy27 2014-02-15 15:37:08 UTC
marking this as RESOLVED WORKSFORME because issue is not present anymore in 4.3 master.

however a backport fix to 4.2.x would be very appreciated
Comment 14 vulcain 2014-02-16 20:03:10 UTC
Not resolved in LibreOffice 4.2.1.1 Build ID: d7dbbd7842e6a58b0f521599204e827654e1fb8b

For LibreOffice 4.2.1 RC2 ??
Comment 15 vulcain 2014-03-10 09:25:55 UTC
Marked REOPENED because bug still here in 4.2.2.1 (Build ID: 3be8cda0bddd8e430d8cda1ebfd581265cca5a0f) 

I open this bug for 4.2, not for 4.3
Comment 16 Commit Notification 2014-03-16 14:30:55 UTC
Muthu Subramanian committed a patch related to this issue.
It has been pushed to "libreoffice-4-2":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=3f16ae0233442bd2b8f2f0ebde9a2741a41ef6c4&h=libreoffice-4-2

fdo#73627 n#828390: Explictly export font properties.


It will be available in LibreOffice 4.2.4.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 17 vulcain 2014-03-28 16:12:33 UTC
Sadly it's not in LibreOffice 4.2.3.2 Build ID: 7c5c769e412afd32da4d946d2cb0c8b0674e95e0

 T_T
Comment 18 vulcain 2014-04-02 19:10:24 UTC
It's could be backport to 4.2.3 RC3, no ??

It's the second stable version of 4.2 since comment 9 who push the patch in 4.3. And we had two RC since comment 16. It's better to have the backport now and no wait again one month (5 may) for 4.2.4
Comment 19 dvdypkaz 2014-04-03 08:48:23 UTC
I'm not a programmer at all, just a regular user, but I found a workaround to resize the text, if that helps someone produce a patch for 4.2:

http://ask.libreoffice.org/en/question/30998/impress-text-appears-smaller-then-normal/?answer=32313#post-id-32313
Comment 20 vulcain 2014-04-03 12:45:25 UTC
(In reply to comment #19)
> I'm not a programmer at all, just a regular user, but I found a workaround
> to resize the text, if that helps someone produce a patch for 4.2:
> 
> http://ask.libreoffice.org/en/question/30998/impress-text-appears-smaller-
> then-normal/?answer=32313#post-id-32313

There are already a patch for this bug. But we must wait LO 4.2.4 or 4.3
I reopen this bug for have the patch in LO 4.2.3 (a third RC coming soon)
Comment 21 tommy27 2014-04-05 12:28:43 UTC
@ vulcain@gmx.com  

please do not reopen FIXED reports asking for backport.
this is not the correct procedure.

4.2.3 RC3 is out but unfortunately it does not include a backport.
you should wait 1 month more for 4.2.4 which will feature the patch.
Comment 22 Andras Timar 2014-04-07 08:24:44 UTC
(In reply to comment #21)
> 4.2.3 RC3 is out but unfortunately it does not include a backport.
> you should wait 1 month more for 4.2.4 which will feature the patch.

I tried, but the patch was down-voted.
https://gerrit.libreoffice.org/#/c/8823/
Comment 23 vulcain 2014-04-19 05:56:55 UTC
I confirm on Ubuntu 12.04.4 x86_64 with LibreOffice 4.2.4.1
Build ID: d4c441391e20647b3d2e8dde4d20aa868e77e515

Bug is fixed.

Thanks