Bug Hunting Session
Bug 65774 - formula's 'catalog' diacritics have different vertical spacing
Summary: formula's 'catalog' diacritics have different vertical spacing
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Formula Editor (show other bugs)
Version:
(earliest affected)
3.6.5.2 release
Hardware: x86-64 (AMD64) Linux (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
: 65597 (view as bug list)
Depends on:
Blocks: Formula-Editor
  Show dependency treegraph
 
Reported: 2013-06-15 05:55 UTC by Yury
Modified: 2019-06-08 09:13 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments
small doc exposing the problem (313.49 KB, application/vnd.oasis.opendocument.text)
2013-06-15 05:56 UTC, Yury
Details
how the sample doc looks here (and its PDF product, too) (6.43 KB, image/png)
2013-06-15 05:57 UTC, Yury
Details
2016-04-18 proofpic: formulas in starmath (14.34 KB, image/png)
2016-04-18 06:59 UTC, Yury
Details
2016-04-18 proofpic: print preview (11.83 KB, image/png)
2016-04-18 06:59 UTC, Yury
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Yury 2013-06-15 05:55:24 UTC
The 'catalog' diacritics (like hat or dot) get different vertical spacing when in different contexts. Might sit almost on top of the letter, or might be put further up.

Attaching proofpic and doc. The 1st formula in doc is 

{hat {dot {f``}}} = 
{∂ {hat {f`}} {}^{{}^{}} } over {∂t``} 
`+` 
i over ħ left( {hat H} {hat {f}} - {hat {f}} {hat H} right)

the 2nd formula is

{
hat{ f }
{}^{{}^{}}
}

-- BTW, look what one has to include to get rid of vertical cropping in certain environments (font faces etc.) -- 1st formula, 2nd line, and 2nd formula, 3rd line.

The difference I'm talking about is between the last line's /hat f/ in the 1st formula and the /hat f/ in the 2nd formula. The PDF I've created from the doc shows the difference, too.

This looks like it's related to bug 62355.

I understand this might be considered not a major problem (who looks at spacing closely, anyway?), but it points (again) to a certain randomness in implementation? or design? of renderer.
Comment 1 Yury 2013-06-15 05:56:33 UTC
Created attachment 80834 [details]
small doc exposing the problem
Comment 2 Yury 2013-06-15 05:57:16 UTC
Created attachment 80835 [details]
how the sample doc looks here (and its PDF product, too)
Comment 3 Jorendc 2013-06-27 20:28:12 UTC
*** Bug 65597 has been marked as a duplicate of this bug. ***
Comment 4 QA Administrators 2015-03-17 00:06:28 UTC Comment hidden (obsolete)
Comment 5 Jean-Baptiste Faure 2015-03-28 16:39:16 UTC
Not reproducible for me if I remove useless braces and small space characters, like this:
hat dot f = {∂ hat f} over {∂t} + i over ħ left( hat H hat f - hat f hat H right)

Tested with LibreOffice 4.4.3.0.0+ built at home under Ubuntu 14.10 x86-64

The question is: why these useless braces?

Best regards. JBF
Comment 6 Yury 2015-03-28 17:15:44 UTC
The problem's still there in 4.3.6.2. I have no 4.4 on this system at the moment.

As to the "useless" braces -- they are there to avoid vertical cropping (another issue).

Regardless of their "uselessness", those shouldn't influence the output.
Comment 7 tommy27 2016-04-16 07:23:09 UTC Comment hidden (obsolete)
Comment 8 Gert Haubensak 2016-04-18 06:36:54 UTC
Try to write, say,  1/%beta in the formula editor. There will be no vertical spacing between the fraction stroke and the greek letter beta. The bug seems still to be  present in LibO 5.0.5. I got rid of it by inserting the spacing sign ` before typing %beta. You might change  the program appropriately.
Comment 9 Yury 2016-04-18 06:52:05 UTC
Still there in 5.1.2.1.0.

I get three vertical positions for `hat` over `f`, all perceptibly different -- 1) partial hat f, 2) hat f in line, 3) hat f standalone from 2nd formula.

BTW, the horizontal placement looks non-uniform, too.

Now, combined diacritics `hat {dot f}` look very good, w/r to vertical and horizontal placement both.

Font is Times New Roman from MS webpack.
Comment 10 Yury 2016-04-18 06:59:26 UTC
Created attachment 124442 [details]
2016-04-18 proofpic: formulas in starmath
Comment 11 Yury 2016-04-18 06:59:54 UTC
Created attachment 124443 [details]
2016-04-18 proofpic: print preview
Comment 12 QA Administrators 2017-05-22 13:22:50 UTC Comment hidden (obsolete)
Comment 13 Gert Haubensak 2017-05-23 18:59:35 UTC
The bug is still here. In fractions with a greek letter in the denominator, the vertical spacing between the fraction line and the gvreek letter is missung.The bug might be corrected by inserting ´ before the letter.
Comment 14 Jean-Baptiste Faure 2017-05-24 04:55:07 UTC
Please, do not change the version number, it shows the oldest version in which the bug has been seen.
Why did you set the bug as fixed if it is still there as you said in the comment #13 ? Set back to new.

Best regards. JBF
Comment 15 Gert Haubensak 2017-05-24 08:30:14 UTC
The bug is still present. In fractions with a greek letter in the denominator, the vertical spacing between the fraction line and the greek letter is missing.I have resolved the problem for myself by inserting ' (the symbol for small spacings).
Comment 16 QA Administrators 2019-05-24 02:58:01 UTC Comment hidden (obsolete)
Comment 17 Yury 2019-05-24 09:16:14 UTC
Looks okay in 6.1.5.2 on linux/64.
Comment 18 Jean-Baptiste Faure 2019-06-08 09:13:00 UTC
(In reply to Yury from comment #17)
> Looks okay in 6.1.5.2 on linux/64.

Thank you very for your test. Closing as WorksForMe as we do not know which commit solved the problem.

Best regards. JBF