Bug Hunting Session
Bug 66050 - LibreOffice crashes after adding Extension Duden Korrector
Summary: LibreOffice crashes after adding Extension Duden Korrector
Status: RESOLVED DUPLICATE of bug 59107
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Extensions (show other bugs)
Version:
(earliest affected)
4.1.0.1 rc
Hardware: All Windows (All)
: high critical
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2013-06-22 16:05 UTC by Hans Immel
Modified: 2013-08-20 09:50 UTC (History)
8 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Hans Immel 2013-06-22 16:05:56 UTC
LibreOffive 4.1.rc1 doesn't start when Duden Korrektor is installed.

stlport_vc7145.dll is located in LibreOffive/URE/bin!


Problemsignatur:
  Problemereignisname:	APPCRASH
  Anwendungsname:	soffice.bin
  Anwendungsversion:	4.1.0.1
  Anwendungszeitstempel:	51c0bd49
  Fehlermodulname:	MSVCR100.dll
  Fehlermodulversion:	10.0.40219.325
  Fehlermodulzeitstempel:	4df2be1e
  Ausnahmecode:	40000015
  Ausnahmeoffset:	0008d6fd
  Betriebsystemversion:	6.1.7601.2.1.0.256.48
  Gebietsschema-ID:	1031
  Zusatzinformation 1:	3662
  Zusatzinformation 2:	3662833c1524c1fd1c131c0267f4527d
  Zusatzinformation 3:	e084
  Zusatzinformation 4:	e0843312b0bb00a8a98da2a2b993f9cc
Comment 1 Julien Nabet 2013-06-22 20:24:10 UTC
Hans: what version of Duden do you use? What's your Windows version?
I put fdo#58177 in see also, you might be interested in this one.
Comment 2 Hans Immel 2013-06-23 06:21:56 UTC
Korrektor / Duden Rechtschreibung 8.0.0.2

Crash happens on my DELL Latitude E6430 with Windows 7 64bit SP2 as well as on my Samsung NC10 with Windows XP 32bit SP3.

Duden works fine on both Systems with LibreOffice 4.0.4 as long, as the instructions of Duden support are followed: "Duden Korrektor will work with this version only if you put the stlport_vc7145.dll from 3.6.x installation somewhere in your %PATH%.Note that you will have to have also MSVCR90.DLL installed on your system."

This however does not seem to apply to 4.1. Crash seems to have to do with a MSVCR90.DLL

Can#T say wether it's a duplicate of fdo#58177 because LO doesn't even start...
Comment 3 retired 2013-06-23 15:06:57 UTC

*** This bug has been marked as a duplicate of bug 66082 ***
Comment 4 Stephan Bergmann 2013-07-09 14:39:37 UTC
#libreoffice-dev on FreeNode:
> <sberg> Fridrich, our official LO 4.1 Windows builds use msvcr100.dll now, right?  I wonder whether that's causing the trouble in fdo#66050, when the Duden extension needs stlport_vc7145.dll, and copying that over from an old inst needs msvcr90.dll, and needing two different msvcr versions in one process makes it all break down
> <Fridrich> sberg: it could eventually, yes, but I really have no solution there
> <Fridrich> sberg: the solution would be that they simply rebuild that whole extension using as linker libraries the static multithreaded ones
> <sberg> Fridrich, thx; not looking for a solution, just wanting to label the issue correctly ;)  (it's currently marked duplicate of a Mac-only issue, which is apparently wrong)
Comment 5 Petr Mladek 2013-07-11 15:31:24 UTC
Copying stlport_vc7145.dll was just a workaround that worked with LO-4.0. IMHO, the correct solution would be that Duden corrector authors provide a clean build that would work with LibreOffice out of box.

I understand that it is very annoying for affected people. But I am not sure if we could do something about this from the LibreOffice side. Such bugs could not block the release with many other useful fixes and improvements => lowering the severity a bit.
Comment 6 Julien Nabet 2013-07-11 15:47:34 UTC
Petr: i don't think duden guys will help, see gerry's comment 23 in fdo 58177
Comment 7 Michael Meeks 2013-07-11 16:34:40 UTC
Well; that's sad - if Duden won't fix it their extension won't work with any modern OpenOffice derivative; on the plus side, perhaps that will stimulate people to help invest in improving Free Software solutions for German grammar / correction.
Comment 8 pernegger 2013-07-28 16:15:37 UTC
When I updated LO from 4.0.x to 4.1.0 today (on Windows), Writer and "Chooser" would crash on launch, something about "MSVC100.dll". A little googling revealed this to be Duden Korrektor's fault (again).
I realise that closed source extensions with uncooperative developers are a pain, I just wanted you to know that a workaround from the LO side would be much appreciated. Sadly, Duden Korrektor is so far ahead of the competition (libre or not), that someone who works a lot with written German can hardly do without it. For now I've just downgraded to 3.6.x (4.0 was very buggy here, anyway), but that's only a stop gap measure, obviously.
Comment 9 Thorsten Behrens (CIB) 2013-07-29 17:31:09 UTC
(In reply to comment #8)
> When I updated LO from 4.0.x to 4.1.0 today (on Windows), Writer and
> "Chooser" would crash on launch, something about "MSVC100.dll".
>
Using this dll

 http://dev-builds.libreoffice.org/stlport_vc7145.dll

instead of the one from the 3.x series improved things for me.
Comment 10 Tobias Heilig 2013-07-30 05:18:31 UTC
(In reply to comment #8)
> I realise that closed source extensions with uncooperative developers are a
> pain, I just wanted you to know that a workaround from the LO side would be
> much appreciated. Sadly, Duden Korrektor is so far ahead of the competition
> (libre or not), that someone who works a lot with written German can hardly
> do without it. For now I've just downgraded to 3.6.x (4.0 was very buggy
> here, anyway), but that's only a stop gap measure, obviously.

+1

I totally agree with that!
Comment 11 Tobias Heilig 2013-07-30 05:35:24 UTC
(In reply to comment #9)
> Using this dll
> 
>  http://dev-builds.libreoffice.org/stlport_vc7145.dll
> 
> instead of the one from the 3.x series improved things for me.

I just tried that one with LO 4.1.0.1 under Windows 7 Enterprise 32-bit SP1.
It doesn't make any difference here. LO still crashes after installing "Die Duden-Rechtschreibprüfung 9.0 für OpenOffice und LibreOffice".

I downgrade to LO 4.0.4.
Comment 12 Tobias Heilig 2013-07-31 05:05:24 UTC
I received the following Answer from the Duden Support Hotline:

----- QUOTE BEGIN -----
Sehr geehrter Herr Heilig,

vielen Dank für Ihre Anfrage und Ihr Interesse an unserer Software.

LibreOffice 4.1 ist gerade neu erschienen und die Duden Rechtschreibprüfung für OpenOffice und LibreOffice lässt sich derzeit nicht einbinden.

Allerdings prüfen wir gerade, ob wir einen Workaround für LO 4.1 zur Verfügung stellen können.
Bitte haben Sie noch etwas Geduld. Wir werden ggf eine Lösung auf unserer Homepage bereitstellen.

Danke für Ihr Verständnis.


Mit freundlichen Grüßen
Ihr Team der Duden-Hotline für den Privatkundenbereich
----- QUOTE END -----

So now we have to poll their homepage periodically to see if they have a workaround.
BTW: They answered my query within a couple of ours. Very quick!
Comment 13 retired 2013-08-20 09:50:57 UTC
Closing Duden Korrektor bugs as NOTOURBUG. This extension is broken beyond repair and Duden is not willing to fix it. The plug in is not OpenSource so nothing the community could do about it.

NOTOURBUG is the correct state. Thanks for understanding. And feel free to give the BI-Media group a phone call and address this problem if you like: http://www.bi-media.de/

*** This bug has been marked as a duplicate of bug 59107 ***