Bug Hunting Session
Bug 66082 - Extensionname: Installation of Duden Korrektor version 9.0 aborts on Mac OS X
Summary: Extensionname: Installation of Duden Korrektor version 9.0 aborts on Mac OS X
Status: RESOLVED DUPLICATE of bug 66703
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Extensions (show other bugs)
Version:
(earliest affected)
4.1.0.1 rc
Hardware: Other Mac OS X (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard: BSA
Keywords: regression
Depends on:
Blocks:
 
Reported: 2013-06-23 14:17 UTC by bugzilla
Modified: 2013-07-09 14:13 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description bugzilla 2013-06-23 14:17:35 UTC
Problem description: The installation of Duden Korrektor version 9.0 is not possible on Mac OS X with LibreOffice (Version 4.1.0.1 RC).

Steps to reproduce:
1. Install LibreOffice (Version 4.1.0.1 RC) on Mac OS X 10.8.4
2. Activate current Java version in the LibreOffice's options (Java Version: 1.6.0_45 from Apple)
3. Try to install Duden Korrektor version 9.0 with Extension Manager for all users

Current behavior: The installation of Duden Korrektor aborts with following message:

(com.sun.star.uno.RuntimeException) { { Message = "javaloader error - no mapping from java to C++ ", Context = (com.sun.star.uno.XInterface) @0 } }



Expected behavior: Successful installation as with LibreOffice 4.0.4
Operating System: Mac OS X
Version: 4.1.0.1 rc
Last worked in: 4.0.4.2 release
Comment 1 retired 2013-06-23 15:00:05 UTC
Official reply from the Duden guys in Mannheim/Germany: "Die Duden Rechtschreibprüfung 9.0, Aufgrund der geringen Nachfrage, vorerst die letzte Version für OpenOffice / LibreOffice sein wird."

This info can be found here: https://bugs.freedesktop.org/show_bug.cgi?id=58177#c23

Since Duden now officially states that the plugin is not working with LO 4.x and they will no longer provide any patches, I'm setting this to NOTOURBUG.
Comment 2 retired 2013-06-23 15:03:28 UTC
Note that they deliberately don't list LO 4.x in the supported software listing: http://www.duden.de/shop/software-horbucher/die-duden-rechtschreibpruefung-9-0-fuer-openoffice-und-libreoffice
Comment 3 retired 2013-06-23 15:06:57 UTC
*** Bug 66050 has been marked as a duplicate of this bug. ***
Comment 4 bugzilla 2013-06-23 15:24:44 UTC
Now LibreOffice crashes when choosing Writer. Bug 66087 opened.
Comment 5 bugzilla 2013-06-29 22:59:59 UTC
A similar bug was detected with LanguageTool 2.1 extension for LibreOffice. See Bug 66389 for more information.
Comment 6 Stephan Bergmann 2013-07-09 14:13:45 UTC

*** This bug has been marked as a duplicate of bug 66703 ***