Bug 66703 - REPORTBUILDER - report design wizard does not start on click (missing libjava_uno.jnilib symlink)
Summary: REPORTBUILDER - report design wizard does not start on click (missing libjava...
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Base (show other bugs)
Version:
(earliest affected)
4.1.0.2 rc
Hardware: x86-64 (AMD64) Mac OS X (All)
: highest blocker
Assignee: Stephan Bergmann
URL:
Whiteboard: target:4.2.0 target:4.1.0
Keywords: regression
: 66082 66239 66389 (view as bug list)
Depends on:
Blocks: mab4.1
  Show dependency treegraph
 
Reported: 2013-07-08 14:51 UTC by Alex Thurgood
Modified: 2013-07-10 06:07 UTC (History)
5 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Alex Thurgood 2013-07-08 14:51:11 UTC
The Report Designer wizard seems to have been disabled.

How to reproduce :

1) Open an ODB file.
2) Click on the Reports button
3) Click on Use Wizard to Create Report
4) Nothing happens

What should happen :
Wizard should start to help user design report.

regression

Alex
Comment 1 Alex Thurgood 2013-07-08 14:51:50 UTC
Adding Lionel, Julien to CC
Comment 2 Lionel Elie Mamane 2013-07-08 17:01:32 UTC
Cannot reproduce on master (4.2.0.alpha), my own (dbg-util) dev tree on top of b440845b9f04fdf498caf3bcdcc52ffc8c489639 of 2013-07-05 17:55:30 on Debian GNU/Linux amd64.

What version exactly are you using? Your own build? A nightly/daily?
Comment 3 Alex Thurgood 2013-07-08 20:20:07 UTC
(In reply to comment #2)
> Cannot reproduce on master (4.2.0.alpha), my own (dbg-util) dev tree on top
> of b440845b9f04fdf498caf3bcdcc52ffc8c489639 of 2013-07-05 17:55:30 on Debian
> GNU/Linux amd64.
> 
> What version exactly are you using? Your own build? A nightly/daily?

Hi Lionel,

It is my own OSX build from master, from 07/07/2013.

I can't reproduce on my 32bit Linux build from yesterday either.


Alex
Comment 4 Jorendc 2013-07-09 10:06:51 UTC
Even worse ... reproducible using Mac OSX 10.8.4 with LibreOffice Versie: 4.1.0.2.0 Build ID: 103a942746cfe346e87daab62acbd4268c38097; Dutch UI
Comment 5 Commit Notification 2013-07-09 14:04:14 UTC
Stephan Bergmann committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=e83ce4d1495db41cb68142da771c10e61cda0fd9

fdo#66703: Missing libjava_uno.jnilib symlink



The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 6 Stephan Bergmann 2013-07-09 14:10:24 UTC
*** Bug 66239 has been marked as a duplicate of this bug. ***
Comment 7 Stephan Bergmann 2013-07-09 14:11:39 UTC
*** Bug 66389 has been marked as a duplicate of this bug. ***
Comment 8 Commit Notification 2013-07-09 14:13:05 UTC
Stephan Bergmann committed a patch related to this issue.
It has been pushed to "libreoffice-4-1":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=b08fbd0fddcfca82153af9d29dc145f4396f9a45&h=libreoffice-4-1

fdo#66703: Missing libjava_uno.jnilib symlink


It will be available in LibreOffice 4.1.1.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 9 Stephan Bergmann 2013-07-09 14:13:45 UTC
*** Bug 66082 has been marked as a duplicate of this bug. ***
Comment 10 Stephan Bergmann 2013-07-09 14:18:45 UTC
requested backport of fix to libreoffice-4-1-0 as <https://gerrit.libreoffice.org/#/c/4787/>
Comment 11 Commit Notification 2013-07-10 06:07:00 UTC
Stephan Bergmann committed a patch related to this issue.
It has been pushed to "libreoffice-4-1-0":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=dc5faf7021001777a7127cb88b0d7f32434bf868&h=libreoffice-4-1-0

fdo#66703: Missing libjava_uno.jnilib symlink


It will be available already in LibreOffice 4.1.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.