Bug Hunting Session
Bug 66239 - REPORTBUILDER - can not open report - java loader error - no mapping from java to C++
Summary: REPORTBUILDER - can not open report - java loader error - no mapping from jav...
Status: RESOLVED DUPLICATE of bug 66703
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Base (show other bugs)
Version:
(earliest affected)
4.2.0.0.alpha0+ Master
Hardware: x86-64 (AMD64) Mac OS X (All)
: highest blocker
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: regression
Depends on:
Blocks:
 
Reported: 2013-06-27 08:00 UTC by Alex Thurgood
Modified: 2013-07-09 14:10 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Alex Thurgood 2013-06-27 08:00:46 UTC
How to reproduce :

on Mac OSX, with master build from 26/06/2013 

1) Open a Base file containing a report
2) Click on the Reports icon
3) Double-click on a report to open it for display
4) Error message "Java loader error - no mapping from java to C++"

What should happen : report should open and be displayed.


Regression over LO 4.0.3.3


Alex
Comment 1 Alex Thurgood 2013-06-27 08:02:18 UTC
Adding Lionel, Julien to CC for info.
Adding Stephan for the Java stuff

@Stephan : any idea what is happening here ?




Alex
Comment 2 Alex Thurgood 2013-06-27 08:03:49 UTC
In 4.0.3.3, on the same OSX system, the report opens just fine.


Alex
Comment 3 Julien Nabet 2013-06-27 20:33:12 UTC
On pc Debian x86-64 with master sources updated today, I don't reproduce this.

Alex: just to be sure, could you attach the file? Perhaps it's specific to this one?
Also, what's your Java version?
Comment 4 Alex Thurgood 2013-06-27 21:30:37 UTC
Hi Julien,

It is OSX specific I'm afraid. Using Apple supplied JVM, 1.6_29 I think. I don't have the problem on my master build on Linux either.

Alex
Comment 5 Alex Thurgood 2013-06-27 21:33:15 UTC
I've this with three different ODB files, all of them are taken fron bugzilla.
Comment 6 Julien Nabet 2013-06-29 11:25:54 UTC
Alex: perhaps it'll be useless but could you try to launch LO from console to see if there are some logs?
BTW, do you build from sources or do you still have some problems about building?
The interest would be to enable debug mode since http://dev-builds.libreoffice.org/daily/master/ don't show any content for: 
- MacOSX-Intel@1-built_no-moz_on_10.6.8 
- MacOSX-Intel@3-OSX_10.6.0-gcc_4.0.1
- MacOSX-Intel@27-OSX_10.7.0-gcc_4.2.1_llvm
Comment 7 Julien Nabet 2013-06-29 11:29:02 UTC
Alex: forget my question about building, just read this: http://nabble.documentfoundation.org/Build-breakage-in-master-on-OSX-with-openclwrapper-cxx-td4063552.html
Comment 8 tim 2013-07-03 12:59:44 UTC
Using 4.1.0.1, Debian, 32 bit, if I try to open or edit an existing report, built using  3.5/3.6 Report Builder extension, Base just crashes.  

If I try to create a new report using the wizard it says 'No valid report template was found'.

If I open a new one in design mode it appears to work (although I have not pursued this).

I can't easily submit a sample since this application is on mysql.  I am even unable now to run the report on 3.5/6 since the 4.1 report builder has supplanted the compatible extension and I can't download it any more from the extension library (why is that - isn't 3.6.n a valid version any more?). 

All in all I have had to give up entirely on LO reports on Base and create them another way (using the ancient DataVision).  The Report Builder always rather flaky.
Comment 9 Julien Nabet 2013-07-03 18:47:05 UTC
Tim: this bugtracker is specific to MacOs so it could be better you comment on fdo#63817 (not fdo#63398 which is solved now)
Comment 10 Alex Thurgood 2013-07-04 10:41:53 UTC
(In reply to comment #6)

Hi Julien,

> Alex: perhaps it'll be useless but could you try to launch LO from console
> to see if there are some logs?
> BTW, do you build from sources or do you still have some problems about
> building?

I build from master source, and most of the time, the build completes just fine. 

> The interest would be to enable debug mode since

Yes, but enabling symbols or dbgutil all currently fail for me on OSX.

It used to work for a while, then stopped working about 3 months ago, and the number of exceptions to DEBUG=true that you have to put in for each of the modules is a real PITA, and kind of defeats the point of having a debug build.


Alex
Comment 11 Stephan Bergmann 2013-07-09 14:10:24 UTC

*** This bug has been marked as a duplicate of bug 66703 ***