Bug Hunting Session
Bug 66100 - 4.1RC1 App Icon of LibreOffice is a default App Icon
Summary: 4.1RC1 App Icon of LibreOffice is a default App Icon
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
4.1.0.1 rc
Hardware: Other Mac OS X (All)
: medium minor
Assignee: Not Assigned
URL:
Whiteboard: target:4.1.0 target:4.2.0
Keywords:
: 66390 66585 (view as bug list)
Depends on:
Blocks:
 
Reported: 2013-06-23 21:31 UTC by Martin Srebotnjak
Modified: 2013-11-13 12:55 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Martin Srebotnjak 2013-06-23 21:31:31 UTC
Instead of the official LibreOffice "document" icon the 4.1RC1 has a default OSX app icon (a piece of paper with a pen and stencil crossed over a meter, forming the A letter in its bottom right part).
This is normal for beta versions, but should not be the case with RC versions, as they install as regular releases.
Comment 1 Jorendc 2013-06-23 21:55:36 UTC
I can confirm this behavior using Mac OSX 10.8.3 with LibreOffice 4.1.0 and current master.

Maybe to 'trivial' to ping a developer for this one, but doesn't look professional. I'll have a look later this week.

Kind regards,
Joren
Comment 2 Adolfo Jayme 2013-07-01 20:16:46 UTC
*** Bug 66390 has been marked as a duplicate of this bug. ***
Comment 3 Norbert Thiebaud 2013-07-04 09:54:38 UTC
confirmed, and fixed in 4.1.0.3 and master : e2f002c044243ddd79eea7837167a72c82b98599
Comment 4 Commit Notification 2013-07-04 09:58:11 UTC
Norbert Thiebaud committed a patch related to this issue.
It has been pushed to "libreoffice-4-1":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=69876d6bdca0a527c4d10b9a3c724f5df9d035ec&h=libreoffice-4-1

fdo#66100 : fix icons associations on MacOSX


It will be available in LibreOffice 4.1.1.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 5 Commit Notification 2013-07-04 09:58:30 UTC
Norbert Thiebaud committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=e2f002c044243ddd79eea7837167a72c82b98599

fdo#66100 : fix icons associations on MacOSX



The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 6 Martin Srebotnjak 2013-07-04 10:10:52 UTC
So this will not make it to 4.1.0?
I see it as a stopper, because it really looks unprofessional on an OSX desktop and in the app bar. Could it be re-iterated to consider it as a 4.1.0 stopper bug?
Comment 7 Emir Sarı (away) 2013-07-04 10:43:23 UTC
This should be a stopper for 4.1.0. Key marketing error: Shipping a product without icon. 

Joren, what do you think?
Comment 8 Jorendc 2013-07-04 11:21:50 UTC
(In reply to comment #7)
> This should be a stopper for 4.1.0. Key marketing error: Shipping a product
> without icon. 
> 
> Joren, what do you think?

Well, actually I agree with the marketing fact. Although it's just an icon, it doesn't look that professional. As always a major release is always a quite big 'event' and news wide spread in the media. Releasing a version without "brands" is for me a no-go. Don't know about the development "to-do" (don't know how long it takes to create an extra branch/...).

Branch 4.1.0.2 branch is created 2days ago?/yesterday? Maybe it's possible to skip RC2 and create RC3 at once?
@Petr, Christian: what do you think?

Kind regards,
Joren
Comment 9 retired 2013-07-04 14:16:18 UTC
*** Bug 66585 has been marked as a duplicate of this bug. ***
Comment 10 retired 2013-07-04 14:19:10 UTC
Well if there is a RC3 that's fine. Or if the icon now is def in the final release.

Have been wondering since RC1 where the icon is. :P

Good to see it's back (and sad it missed RC2 by a day or two).
Comment 11 Christian Lohmaier 2013-07-04 14:25:40 UTC
@jordenc not possible to skip rc2 as that one was already prepared (tag created and pushed, builds already building/partly done,...)

but there is rc3 planned in two weeks from now, so please double-check in rc3
https://wiki.documentfoundation.org/ReleasePlan/4.1

IMHO it is not good to skip rc2, as that would mean missing lot of feedback. But I'll add a comment to the release-notes wiki page
Comment 12 Jorendc 2013-07-04 14:29:00 UTC
(In reply to comment #11)
> @jordenc not possible to skip rc2 as that one was already prepared (tag
> created and pushed, builds already building/partly done,...)
> 
> but there is rc3 planned in two weeks from now, so please double-check in rc3
> https://wiki.documentfoundation.org/ReleasePlan/4.1

Oh, wasn't aware of the fact there will be a RC3 (for major release).
 
> IMHO it is not good to skip rc2, as that would mean missing lot of feedback.
> But I'll add a comment to the release-notes wiki page

Yes, indeed. In this case (3 RC's) it makes sense not to 'skip' a RC and follow the original release schedule.

Thanks for your feedback, and thanks Norbert for the patch!
Kind regards,
Joren
Comment 13 Petr Mladek 2013-07-04 15:01:46 UTC
The fix is nominated for 4.1.0.3, see https://gerrit.libreoffice.org/#/c/4725/
Comment 14 Commit Notification 2013-07-05 05:17:35 UTC
Norbert Thiebaud committed a patch related to this issue.
It has been pushed to "libreoffice-4-1-0":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=fec68441e79dbd042381f882c4f9814f637013ac&h=libreoffice-4-1-0

fdo#66100 : fix icons associations on MacOSX


It will be available already in LibreOffice 4.1.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 15 Martin Srebotnjak 2013-07-05 06:48:34 UTC
Great work, guys. Thanks!
Comment 16 Lucian 2013-11-13 07:49:16 UTC
The problem still exists in LibreOffice version 4.1.3.2. Seen in both OS X 10.8 and 10.9.
Comment 17 retired 2013-11-13 12:55:52 UTC
Hi Lucian,

I cannot confirm your report. Please open a separate bug for this problem. But I highly doubt this is still a problem. Did you try re-downloading the latest stable release of LO and re-install that under OS X 10.9?

LO 4.1.3.2 and 10.9 running fine here. Icon looks sweet.