Download it now!
Bug 66233 - EDITING: Enhancement request: Enable copy&paste of cell area from Calc into Chart data tables
Summary: EDITING: Enhancement request: Enable copy&paste of cell area from Calc into C...
Status: RESOLVED DUPLICATE of bug 38212
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
4.0.4.2 release
Hardware: Other All
: medium enhancement
Assignee: Not Assigned
URL:
Whiteboard: BSA
Keywords:
Depends on:
Blocks:
 
Reported: 2013-06-27 03:40 UTC by bugquestcontri
Modified: 2014-07-18 22:29 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description bugquestcontri 2013-06-27 03:40:23 UTC
Problem description:

Currently it is not possible to copy a cell area in Calc and paste it as an area into the data table of an chart. in Impress, Writer and Draw. 
When an area is copied in Calc, next  a cell is selected in the data table of the chart, and the Calc area is pasted, all figures appear only in the selected cell.

As consequence all data needed in an Impress chart must be entered by typing or copy&paste cell by cell. Both methods are very time consuming. Method 1 also has typical mistype chance of 10% .This results in a tremendous loss of productivity. It is also a disadvantage point of LibO against MSO.

Impress charts do not have a style, thus keeping often used charts in an Impress template helps to maintain the layout of charts but then data must be replaced in above-mentioned 

Enhance ment Reques:
Enable copy & paste of 1- and 2-dimensional areas from Calc into a chart table.

Result: 
A big increase of productivity and matching a Powerpoint feature.

I can be contacted.
Operating System: All
Version: 4.0.4.2 release
Comment 1 Cor Nouws 2013-06-27 19:31:50 UTC
Hi,
thanks for your report.
What I know - if I understand your request well:
it is possible to select a range and drag that to an existing chart.
Does that help?
Regards - Cor
Comment 2 bugquestcontri 2013-06-29 14:33:37 UTC
I feel we misunderstand each other. 

If I want to get content from a Calc file into an Impress file I only can copy in Calc and paste in Impress. This means drag and drop is not possible.

I want to copy a range from Calc into the Chart Data Table to Impress.

Copy in Calc means: select a range and copy (ctrl+c)

Paste in Impress Chart Data Table means: 
Select a cell in the Chart Data Table and paste (ctrl+v)
Comment 3 A (Andy) 2014-03-28 21:46:17 UTC
reproducible with LO 4.2.2.1 (Win 8.1)

Steps Done:
1. Open IMPRESS
2. Go to INSERT -> TABLE and press OK
3. Open CALC
4. Type in cell A1 = "A" and in cell A2 = "B"
5. Select the cells A1 and A2 and press CTRL + C to copy it (or go to EDIT -> COPY)
6. Go to the still empty table in IMPRESS and put the cursor in the top left corner and press CTRL + V to insert the clipboard (or go to EDIT -> PASTE)

Result: Both cells from CALC are pasted in only one cell in IMPRESS, but not in two cells corresponding to CALC.
Comment 4 bugquestcontri 2014-06-20 13:36:49 UTC
Just made a test in 4.2.4.2 on XP/SP3 and still see the same situation.
Comment 5 Francisco 2014-07-18 22:29:06 UTC

*** This bug has been marked as a duplicate of bug 38212 ***