Bug 66619 - FORMATTING: format page orientation same for all sheets
Summary: FORMATTING: format page orientation same for all sheets
Status: RESOLVED NOTABUG
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
4.0.4.2 release
Hardware: Other Linux (All)
: high normal
Assignee: Not Assigned
URL:
Whiteboard: BSA
Keywords:
Depends on:
Blocks:
 
Reported: 2013-07-05 13:17 UTC by Ljiljan
Modified: 2014-11-15 16:11 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Ljiljan 2013-07-05 13:17:05 UTC
Problem description: 

Not possible to change page orientation from the menu Format -> Page for different sheets.

Steps to reproduce:
1. Create Sheet 1
2. Create Sheet 2
3. Go to Sheet 1
4. Change Format -> Page -> Orientation = Landscape
5. Go to Sheet 2
6. Change Format -> Page -> Orientation = Portrait

Current behavior:

Only one page orientation for all sheets is possible.

Expected behavior:

Each sheet could have different page orientation (for example, sheet could be landscape oriented, while sheet2 portrait...)
              
Operating System: Ubuntu
Version: 4.0.4.2 release
Comment 1 m.a.riosv 2013-07-05 21:30:59 UTC
Hi  Ljiljan, thanks for reporting.

But I think this is not a bug.
The page options are for page style.
To do what you want, you need to create a new page style at least for every page type with different options.
In Menu/Format/Styles&Formatting, select the bottom for page, right-click the style and select new to create a new one.
Then while in the sheet where to apply the new style double.click in it.

The documentation about calc:
https://wiki.documentfoundation.org/Documentation/Publications#LibreOffice_Calc_Guide
Some help here also:
http://ask.libreoffice.org/en/question/9150/portrait-in-sheet1-and-landscape-in-sheet2/

Changed status to resolved notabug. Please if  you are not agree reopen it.
Comment 2 Ljiljan 2013-07-06 07:30:24 UTC
Thanks... it is bit complicated, but it works. Could this be marked as "enhancement"?
Comment 3 m.a.riosv 2013-07-06 11:02:39 UTC
Maybe seems complicated at the begin, but once you are a used, it is simple and very powerful.

Use styles make easier the job, if e.g. giving it a clear name, or if you have several sheets with one style, do not needed go one by one to change some option, modifying the style is enough.

Docking the windows such as Styles&Formatting facilitates the work, look in the Help Index tab for "Docking windows".

>Thanks... it is bit complicated, but it works. Could this be marked as "enhancement"?

If you want you are free to do it,
but I think it is better review a bit the documentation and work a while with LibreOffice. If afterwards you even want request the enhancement, fill one explaining in detail what you want will be achieved, to get a better chance to get it implemented.
Comment 4 Eric 2014-06-07 23:33:01 UTC
It is not only the orientation that can't be individually set but also page size and fit to sheet parameters (number of pages wide and tall) and no doubt there are other page formatting parameters similarly affected.

Whilst I agree that styles would work, this is certainly not an intuitive approach such as used in Microsoft Excel.  I would have to say that I have wasted a lot of time trying to find out how to accomplish different page sizes and orientations for different sheets.  

This is a fairly common user action so why make it hard for the user to understand and accomplish those functions?  I am therefore filing an enhancement request (as it is not really a "bug" per se).
Comment 5 Joel Madero 2014-11-02 16:34:47 UTC
Never confirmed by QA team - setting to UNCONFIRMED.
Comment 6 Buovjaga 2014-11-15 16:11:34 UTC
This is supposed to be NOTABUG. Eric filed bug 79782, which was then closed by Cor with a reference to docs.