Download it now!
Bug 66927 - EDITING: inserting endnote loses focus from document when other dialogs are open (such as Styles and Formatting)
Summary: EDITING: inserting endnote loses focus from document when other dialogs are o...
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
Inherited From OOo
Hardware: Other Linux (All)
: medium minor
Assignee: Not Assigned
URL:
Whiteboard: BSA
Keywords:
Depends on:
Blocks: Footnote-Endnote
  Show dependency treegraph
 
Reported: 2013-07-15 13:23 UTC by freddi34
Modified: 2019-06-23 20:23 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description freddi34 2013-07-15 13:23:06 UTC
Problem description: 
When inserting an endnote (menu: Insert → Foot-/Endnote), the document scrolls correctly to the end of the document, but looses focus when other dialogs are open (Styles and Formats). The "Styles and Formats" dialog steals focus so that the user has to click another time into the document before starting to type the endnote.

Steps to reproduce:
1. Click in the menu Format → Styles and Formats
2. Focus the main document and insert and click the menu Insert → Foot-/Endnote
3. Click OK in the endnote dialog
4. Start typing the foot-/endnote text

Current behavior:
No text is inserted because the document has no focus, the formats dialog gets focus instead.

Expected behavior:
The document gets focus again, because it was focussed before inserting the endnote.
              
Operating System: Ubuntu
Version: 4.0.4.2 release
Comment 1 retired 2013-07-16 10:55:24 UTC
Can confirm this behavior on Ubuntu 13.04, LO 4.1.0.2.0.
Setting to NEW.
Working fine on OS X 10.8.4, so Linux only.
Comment 2 QA Administrators 2015-04-01 14:41:49 UTC Comment hidden (obsolete)
Comment 3 Buovjaga 2015-04-23 19:29:58 UTC
Only reproduced on Linux.

Win 7 Pro 64-bit Version: 5.0.0.0.alpha1+ (x64)
Build ID: f3375fa07f27bd2ade519af3c07d69040d10eaa9
TinderBox: Win-x86_64@42, Branch:master, Time: 2015-04-22_23:38:50
Locale: fi_FI

Ubuntu 14.10 64-bit 
Version: 5.0.0.0.alpha1+
Build ID: badec7478035008f514e0976a94438fe2e32dc40
TinderBox: Linux-rpm_deb-x86_64@46-TDF-dbg, Branch:master, Time: 2015-04-22_00:50:58
Locale: en_US

LibreOffice 3.3.0 
OOO330m19 (Build:6)
tag libreoffice-3.3.0.4
Comment 4 QA Administrators 2016-09-20 09:32:15 UTC Comment hidden (obsolete)
Comment 5 Thomas Lendo 2019-06-23 20:23:59 UTC
I can't reproduce that with

Version: 6.3.0.0.beta1
Build ID: a187af327633f5f00363be5131bd21a13e0f1a7b
CPU threads: 4; OS: Linux 4.15; UI render: default; VCL: gtk3; 
Locale: de-DE (de_DE.UTF-8); UI-Language: en-US
Calc: threaded

Therefore I close this bug as RESOLVED WORKSFORME.

If you still see this problem, please reopen as NEW with new steps to reproduce.