Bug 67014 - Customizations made to Writer are not present in Master Document view
Summary: Customizations made to Writer are not present in Master Document view
Status: RESOLVED WONTFIX
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: UI (show other bugs)
Version:
(earliest affected)
4.0.4.2 release
Hardware: All All
: low trivial
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: Writer-Master-Doc Writer-Toolbars
  Show dependency treegraph
 
Reported: 2013-07-17 21:16 UTC by Mirosław Zalewski
Modified: 2019-05-08 11:18 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:


Attachments
Screenshot 1: Writer and Master doc view before customizations (128.38 KB, image/png)
2013-07-17 21:16 UTC, Mirosław Zalewski
Details
Screenshot 2: Writer and Master doc view after customizations. They differ. (126.17 KB, image/png)
2013-07-17 21:18 UTC, Mirosław Zalewski
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Mirosław Zalewski 2013-07-17 21:16:16 UTC
Created attachment 82564 [details]
Screenshot 1: Writer and Master doc view before customizations

Any customizations (toolbars, keyboard shortcuts, menus) made in Writer are not present in Master document View. They are designed to look and behave the same and this causes inconsistencies.

Steps to reproduce:
1. Open up Writer and Master doc view. Compare them. They look pretty much the same, master doc even distinguishes itself as "LibreOffice Writer" (see screenshot 1, attached; Writer on top, Master doc view on bottom).
2. Go to Tools → Customize... and make some obvious changes, such as moving Help to first position and removing new/load/save icons.
3. Restart LO.
4. Open up Writer and Master doc view again. Compare.

Results:
As screenshot 2 (attached) shows, changes made to Writer (top) are not present in Master doc view (bottom). Windows differ from each other.

Expected result:
Customizations made to Writer should be present in Master doc view.

Rationale:
Master document is inherent view of Writer. There is no equivalent option in any other app in suite. Using Master document view without subdocuments created in Writer does not make any sense.
The point is, both Writer windows and Master document window are part of the same context and are interchangeable in process of creating long documents. Since one can edit text in Master document, he or she expects the same experience as in Writer. There is no reason for keyboard shortcut to be available in Writer, but not in Master document view.
As far as Writer and Master document view are concerned, each and every customization made in one should be automatically present in another.

The fact that this is not a case points out possibility that these apps do not share some codebase, which is wrong anyway. Fixing it might require major refactoring of Master doc view.
Comment 1 Mirosław Zalewski 2013-07-17 21:18:16 UTC
Created attachment 82565 [details]
Screenshot 2: Writer and Master doc view after customizations. They differ.

Forgot to mention (sigh):
Bug seen on LibreOffice 3.6.5 and 4.0.4, both on Debian testing amd64.
Comment 2 Joel Madero 2014-06-25 04:55:30 UTC
Thank you for reporting this issue! I have been able to confirm the issue on:
Version: 4.3.0.0.alpha0
Date:   Mon Jun 23 15:40:45 2014 +0200
Platform :Ubuntu 14.04
DE: GNOME3

+ + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + +
As I've been able to confirm this problem I am marking as:

New (confirmed)
Trivial - while a little annoying it doesn't do much in terms of preventing or slowing down high quality work. One time fix (you can edit the toolbar in the master document to match)
Low - In one year no other user has added a comment or from what I know of reported a similar bug.

+ + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + +
LibreOffice is powered by a team of volunteers, every bug is confirmed (triaged) by human beings who mostly give their time for free. We invite you to join our triaging by checking out this link:
https://wiki.documentfoundation.org/QA/BugTriage and join us on freenode at #libreoffice-qa

There are also other ways to get involved including with marketing, UX, documentation, and of course developing -  http://www.libreoffice.org/get-help/mailing-lists/. 

Lastly, good bug reports help tremendously in making the process go smoother, please always provide reproducible steps (even if it seems easy) and attach any and all relevant material
Comment 3 QA Administrators 2015-07-18 17:42:45 UTC Comment hidden (obsolete)
Comment 4 QA Administrators 2016-09-20 10:18:03 UTC Comment hidden (obsolete)
Comment 5 Mirosław Zalewski 2016-09-20 17:06:18 UTC
Reproduced on:
Version: 5.2.0.4
Build ID: 066b007f5ebcc236395c7d282ba488bca6720265
CPU Threads: 1; OS Version: Windows 6.2; UI Render: default; 
Locale: pl-PL (pl_PL)
Comment 6 QA Administrators 2018-10-23 02:50:39 UTC Comment hidden (obsolete)
Comment 7 Dieter Praas 2018-10-23 07:33:12 UTC
Still reproducible with

Version: 6.0.6.2 (x64)
Build-ID: 0c292870b25a325b5ed35f6b45599d2ea4458e77
CPU-Threads: 4; BS: Windows 10.0; UI-Render: Standard; 
Gebietsschema: de-DE (de_DE); Calc: group
Comment 8 Roman Kuznetsov 2019-05-08 08:00:09 UTC
I think it's not a bug. 
Because Writer and Writer Master mode are different modules inside of LibreOffice. And if you customize anything in Writer Master mode, for example move main menu item, then this changing will be save only for Writer Master mode but not for Writer. The same works for Writer.

Heiko, what do you think?
Comment 9 Heiko Tietze 2019-05-08 11:14:13 UTC
Yes, let's close it. You may benefit from the individual configuration by having a special UI layout for the master document.