Download it now!
Bug 67106 - fileopen: page rendering of DOCX File wrong (mostly caused by missing font)
Summary: fileopen: page rendering of DOCX File wrong (mostly caused by missing font)
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
Inherited From OOo
Hardware: Other All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: filter:doc, filter:docx
Depends on:
Blocks: DOCX-Page
  Show dependency treegraph
 
Reported: 2013-07-20 01:25 UTC by chuck.pobanz
Modified: 2017-08-08 14:16 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:


Attachments
image issues with this docx (1.47 MB, image/png)
2013-07-20 08:03 UTC, retired
Details
sample docx file that displays differently (1.69 MB, application/vnd.openxmlformats-officedocument.wordprocessingml.document)
2014-07-03 04:09 UTC, chuck.pobanz
Details
Comparison between Libreoffice 5.0.1.2 (left) and Word 2010 (right) (139.95 KB, image/jpeg)
2015-09-09 09:02 UTC, Xisco Faulí
Details

Note You need to log in before you can comment on or make changes to this bug.
Description chuck.pobanz 2013-07-20 01:25:11 UTC
FILEOPEN of the attached .DOCX displays differently in Writer than Word. Pictures are repeated many times in Libreoffice making document 16 pages long instead of 4. 

running on Ubuntu 13.04
Comment 1 chuck.pobanz 2013-07-20 01:46:44 UTC
File can be downloaded from:
http://wikisend.com/download/434424/Coach_Training_Flyer.docx
Comment 2 retired 2013-07-20 08:03:00 UTC
Created attachment 82719 [details]
image issues with this docx
Comment 3 retired 2013-07-20 08:03:21 UTC
Confirming with LO 4.1.0.3 on OS X 10.8.4. See screenshot.
Comment 4 chuck.pobanz 2013-07-20 16:40:54 UTC
Because the file is too large, I could not upload it to this site, hense the remote location of the .docx file. The temperary location of the uploaded file will only be available for a week. 

I do not have Microsoft Word, so can not modify the file. James or anyone, could you delete the last 3 pages and keep only the first page (assuming it displays the problem), and then upload it to this bugtracker. 

Thanks James for uploading the screen shots.
Comment 5 Jorendc 2014-04-21 23:28:02 UTC
@Chuck: can you please retry to attach it to this bug report? Without document to test, we can't keep track of this issue.

Placing in NEEDINFO until particular file is available again.

Thanks in advance,
Joren
Comment 6 chuck.pobanz 2014-07-03 04:09:46 UTC
Created attachment 102178 [details]
sample docx file that displays differently

The original file is too big to attach, so I deleted all but the first page and removed some of the pictures. This file still displays differently and should display the issue(s).
Comment 7 Buovjaga 2014-11-25 08:54:00 UTC
Reproduced -> NEW.

Win 7 64-bit Version: 4.5.0.0.alpha0+
Build ID: 772befa08f02b08da1ab493896a0744bc73781c7
TinderBox: Win-x86@51-TDF, Branch:MASTER, Time: 2014-11-23_22:39:02
Comment 8 Xisco Faulí 2015-09-09 09:02:09 UTC
Created attachment 118544 [details]
Comparison between Libreoffice 5.0.1.2 (left) and Word 2010 (right)

This issue is still present in

Version: 5.0.1.2
Build ID: 81898c9f5c0d43f3473ba111d7b351050be20261
Locale: es-ES (es_ES)

on Windows 7 (64-bit)
Comment 9 chuck.pobanz 2016-05-13 17:19:29 UTC
Still an issue. Libreoffice 5.1.3.2 on Linux Mint.
Comment 10 Cor Nouws 2016-08-25 13:52:11 UTC
Hi,

Can you please make sure that for your test the fonts Tw Cen MT is installed? I don't have it and that definitely will be (one of) the caus(es).

If you open this file in Word and introduce a new page, the background image is there too. So the image itself not related.
(maybe the first bugdoc, but we don't have that any more..)

In 3.3.0.4 (on the same system) the page rendering is a problem too.
(Plus that there the background image is on top, not in the background :) )
Comment 11 Cor Nouws 2016-08-25 14:09:45 UTC
(In reply to Cor Nouws from comment #10)
> Hi,
> 
> Can you please make sure that for your test the fonts Tw Cen MT is
> installed? I don't have it and that definitely will be (one of) the caus(es).

installing the font nearly corrects the case, only one Enter too much is left..
Comment 12 Timur 2017-08-08 13:32:58 UTC
This started as a rendering issue and it's mostly resolved. 
Wasn't really related to missing font. 
What's left is "one Enter too much" which is trivial to delete. 
That could be interesting to explain, so I'll report separately.