Bug Hunting Session
Bug 67230 - Sidebar does not keep state of Content View in Navigator
Summary: Sidebar does not keep state of Content View in Navigator
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
4.0.3.3 release
Hardware: Other All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: needsDevEval
Depends on:
Blocks: Navigator
  Show dependency treegraph
 
Reported: 2013-07-23 21:36 UTC by David
Modified: 2016-10-24 12:17 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments
Screencopy with content view button in the Navigator (86.21 KB, image/png)
2015-03-02 08:22 UTC, Jean-Baptiste Faure
Details

Note You need to log in before you can comment on or make changes to this bug.
Description David 2013-07-23 21:36:50 UTC
When using Navigator within the new sidebar feature I like to have the Content View button enabled.  But when another pane is selected in the sidebar then when you go back to the Navigator the Content View button is disabled.  It is rather annoying and a waste of time to have to continually enable it when switching between the sidebar panes.
Comment 1 Jorendc 2013-07-26 19:38:51 UTC
Thanks for reporting!

I can reproduce this behavior, tested using Linux Mint 15 x64 with LibreOffice Version: 4.2.0.0.alpha0+ Build ID: 7fd81244c21ad54a8b9766902fd7c34e8055b165 (	2013-07-24 08:04:44)

Kind regards,
Joren
Comment 2 Kumāra 2015-02-22 10:42:08 UTC
In 4.4, I can't even find Content View!

Because of this, and bug 80960, I'm sticking with 4.1.6.2.
Comment 3 Jean-Baptiste Faure 2015-03-02 05:22:53 UTC
(In reply to Kumāra from comment #2)
> In 4.4, I can't even find Content View!

First button of the second line in the Navigator toolbar.

Best regards. JBF
Comment 4 Kumāra 2015-03-02 07:32:59 UTC
(In reply to Jean-Baptiste Faure from comment #3)
> (In reply to Kumāra from comment #2)
> > In 4.4, I can't even find Content View!
> 
> First button of the second line in the Navigator toolbar.

Thanks. I was referring to the new sidebar version. As I recall, the Content View button isn't there, and it's defunct on the old Navigator toolbar.

Now I've returned to LO4.1.6.2 (for the 2nd time) where things are "good enough". So, I don't have 4.4 to test anymore.
Comment 5 Jean-Baptiste Faure 2015-03-02 08:22:57 UTC
Created attachment 113811 [details]
Screencopy with content view button in the Navigator

(In reply to Kumāra from comment #4)
> (In reply to Jean-Baptiste Faure from comment #3)
> > First button of the second line in the Navigator toolbar.
> 
> Thanks. I was referring to the new sidebar version.

Me too. Please see attachment.

Best regards. JBF
Comment 6 Yousuf Philips (jay) (retired) 2015-08-08 21:22:16 UTC
This has been fixed in master.

Version: 5.1.0.0.alpha1+
Build ID: 25534a62b2ba398c6298c6b9e521f20de1087540
TinderBox: Linux-rpm_deb-x86_64@70-TDF, Branch:master, Time: 2015-08-07_14:13:33
Locale: en-US (en_US.UTF-8)
Comment 7 Robinson Tryon (qubit) 2015-12-18 10:34:59 UTC Comment hidden (obsolete)