Download it now!
Bug 67240 - Cannot insert EPS file
Summary: Cannot insert EPS file
Status: RESOLVED NOTABUG
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
4.0.4.2 release
Hardware: Other Windows (All)
: high normal
Assignee: Not Assigned
URL:
Whiteboard: BSA
Keywords:
Depends on:
Blocks:
 
Reported: 2013-07-24 05:27 UTC by Luiz Angelo Daros de Luca
Modified: 2013-08-15 18:18 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:


Attachments
Text document with eps and png file (36.18 KB, application/vnd.oasis.opendocument.text)
2013-07-24 05:27 UTC, Luiz Angelo Daros de Luca
Details
ODT file exported as PDF (86.94 KB, application/pdf)
2013-07-24 05:28 UTC, Luiz Angelo Daros de Luca
Details
EPS image (21.50 KB, application/postscript)
2013-07-24 05:29 UTC, Luiz Angelo Daros de Luca
Details
PNG version of EPS file (29.63 KB, image/png)
2013-07-24 05:35 UTC, Luiz Angelo Daros de Luca
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Luiz Angelo Daros de Luca 2013-07-24 05:27:55 UTC
Created attachment 82892 [details]
Text document with eps and png file

Hello,

I'm trying to insert an eps image file into a text document. All I get is some lines of this image metadata in red and no image at all.

The EPS was generated by MATLAB. In Linux, this file is inserted correctly (but with some bug in color processing that I might report later).

I'll attach an odt file with the EPS and a PNG verion of it. Also, I'll attach the images and a PDF version of the odt file. 

Steps to reproduce:
1. new text document
2. insert/figure/from a file
3. select the eps file
4. insert

Current behavior:
5. Instead of the correct image, LO shows 4 lines of metadata in red font

Expected behavior:
5. The correct image.

              
Operating System: Windows 7
Version: 4.1.0.3 rc
Comment 1 Luiz Angelo Daros de Luca 2013-07-24 05:28:38 UTC
Created attachment 82893 [details]
ODT file exported as  PDF
Comment 2 Luiz Angelo Daros de Luca 2013-07-24 05:29:03 UTC
Created attachment 82894 [details]
EPS image
Comment 3 Luiz Angelo Daros de Luca 2013-07-24 05:35:12 UTC
Created attachment 82896 [details]
PNG version of EPS file
Comment 4 ign_christian 2013-07-24 07:08:15 UTC
Hello Luiz.. I can confirm that problem not only with Writer, but also with Draw & Impress. Opening that EPS file directly with Draw also generates same behavior.

Tested on LO 4.0.4.2 (Win7 32bit), so I change version to 4.0.4.2 since this is older version which can reproduce the problem.
Comment 5 ign_christian 2013-07-24 07:36:17 UTC
Tested on LO 3.6.7.2 (Ubuntu 12.04 32bit), I can opened that EPS file directly with Draw & inserted in Writer/Impress/Draw. Though there are some rendering glitches.
Comment 6 Luiz Angelo Daros de Luca 2013-07-24 19:45:22 UTC
I'm aware of color glitches on Linux. I reported it in bug 67271.
Is it another problem?
Comment 7 Björgvin Ragnarsson 2013-08-02 15:11:04 UTC

*** This bug has been marked as a duplicate of bug 64161 ***
Comment 8 Luiz Angelo Daros de Luca 2013-08-02 16:26:11 UTC
This is not duplicated. AFAIK, bug 64161 reports that EPS images are inserted correctly but not exported to PDF. In my case, they are not shown even in LO.
Also, this is specific for windows.
Comment 9 Björgvin Ragnarsson 2013-08-02 16:32:35 UTC
You are right, I just tested this and I misattributed this as a duplicate of #64161.

The reason why this happens is because LO does not come with an EPS renderer, something that bug #67464 is supposed to fix.

If you install imagemagick or ghostscript and make sure LO can find it with the PATH environment variable, then LO can make use of those programs to render EPS files.
Comment 10 Luiz Angelo Daros de Luca 2013-08-02 17:46:48 UTC
Yes, 

bug #67464 seems to be the cause but I think that this is not a simple  enhancement. For the user point of view, its just a functionality that does not work. LO should, at least, inform that it cannot convert the EPS file into something else because it could not find ghostscript, or whatever, in path.
Comment 11 Jean-Baptiste Faure 2013-08-15 18:18:41 UTC
The problem is that your EPS file does not have a preview inside and LibreOffice needs to generate one on the fly. Under Linux LO can find the needed tools to do that because they are generally installed by default. Under MS-Windows it is more problematic. You should try again after having installed ImageMagick and Ghostscript.
Another way is to use softwares which create EPS files with a preview inside.

So I am closing this bug report as NOTABUG because the EPS file is actually inserted in the document and is visible if LO find appropriate tools.

If you think that LO should be more explicit when it does not find the software it needs to show the image under MS-Windows, please open another bug report against this specific behavior.

Best regards JBF