Download it now!
Bug 67271 - FILEOPEN: EPS image colors are interpreted wrongly
Summary: FILEOPEN: EPS image colors are interpreted wrongly
Status: RESOLVED NOTOURBUG
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: UI (show other bugs)
Version:
(earliest affected)
4.1.0.4 release
Hardware: Other Linux (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard: BSA
Keywords:
Depends on:
Blocks:
 
Reported: 2013-07-24 19:40 UTC by Luiz Angelo Daros de Luca
Modified: 2013-12-13 17:31 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:


Attachments
pdf version of odt file (265.86 KB, application/pdf)
2013-07-24 19:42 UTC, Luiz Angelo Daros de Luca
Details
odt file with the image in both formats (36.48 KB, application/vnd.oasis.opendocument.text)
2013-07-24 19:42 UTC, Luiz Angelo Daros de Luca
Details
image in png format (29.63 KB, image/png)
2013-07-24 19:43 UTC, Luiz Angelo Daros de Luca
Details
The EPS image. (21.50 KB, image/x-eps)
2013-07-24 19:43 UTC, Luiz Angelo Daros de Luca
Details
Both images outside LibreOffice (212.13 KB, image/png)
2013-12-13 16:33 UTC, Jean-Baptiste Faure
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Luiz Angelo Daros de Luca 2013-07-24 19:40:45 UTC
When a EPS image is inserted, the file colors are interpreted wrongly. Even pure red (FF0000) becomes something lighter (but not human visible) while pure green (00FF00) gets very different.

I generated the same image in PNG and EPS format. They seems to be correct in, both PNG and EPS, inside inkscape and gwenview. The difference in colors inside inkscape is not visible and probably because colors in EPS are represented by floats.

I'll attach the eps/png file, an odt and a pdf version of an text document with both formats inserted.

Steps to reproduce:
1. create a new text document
2. insert the EPS image
3. insert the PNG image

Current behavior:
4. Colors are visibly different

Expected behavior:
5. Besides some white space and font size, both images should look the same.

PS: EPS files does not work at all in Windows. I reported it in bug 67240              
Operating System: Linux (Other)
Version: 4.1.0.4 rc
Comment 1 Luiz Angelo Daros de Luca 2013-07-24 19:42:17 UTC
Created attachment 82954 [details]
pdf version of odt file
Comment 2 Luiz Angelo Daros de Luca 2013-07-24 19:42:43 UTC
Created attachment 82955 [details]
odt file with the image in both formats
Comment 3 Luiz Angelo Daros de Luca 2013-07-24 19:43:12 UTC
Created attachment 82956 [details]
image in png format
Comment 4 Luiz Angelo Daros de Luca 2013-07-24 19:43:54 UTC
Created attachment 82957 [details]
The EPS image.
Comment 5 Jean-Baptiste Faure 2013-12-13 16:33:54 UTC
Created attachment 90734 [details]
Both images outside LibreOffice

How do you know that the problem is in LibreOffice? If I open your PNG in Firefox and your EPS in Evince I see that the colors differ. See my screen copy which show both images on the same screen.

Best regards. JBF
Comment 6 Luiz Angelo Daros de Luca 2013-12-13 17:31:16 UTC
I was sure that the EPS colors were wrong because I read the file (it is a text script). I also tested it with inkscape. I workaround the problem converting all files to SVG, which does not have color problems.

Testing again the odt file, it seems to be fixed. What I learned from bug 67240 is that LO does not have a EPS reader, and uses system ghostscript for the job. I don't know if it was an LO update or the ghostscript update but in my ubuntu 13.10, all colors seems to be ok. Now, the previously attached odt file has no visual difference between the two images (EPS and PNG).

If you are curious what the problem looks like when I reported, check the attached PDF file. The colors are visually different.

I'll mark it as RESOLVED/NOTOURBUG as it is probably a GS bug.