Bug Hunting Session
Bug 67401 - "Help -> About LibreOffice" Logo not smooth when anti-aliasing is OFF
Summary: "Help -> About LibreOffice" Logo not smooth when anti-aliasing is OFF
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
4.0.4.2 release
Hardware: x86-64 (AMD64) All
: medium normal
Assignee: Andras Timar
URL:
Whiteboard: target:4.2.0
Keywords:
: 69580 (view as bug list)
Depends on:
Blocks: mab4.0
  Show dependency treegraph
 
Reported: 2013-07-27 14:40 UTC by Samuel
Modified: 2013-11-09 05:02 UTC (History)
6 users (show)

See Also:
Crash report or crash signature:


Attachments
Screenshot (47.62 KB, image/png)
2013-07-27 14:40 UTC, Samuel
Details
1440x900 (75.23 KB, image/png)
2013-08-28 09:33 UTC, Samuel
Details
1920x1080 (75.20 KB, image/png)
2013-08-28 09:33 UTC, Samuel
Details
LibreOffice 4.1.3.2 (64.76 KB, image/png)
2013-11-01 14:55 UTC, Samuel
Details
LibO 4.2 alpha 2013-11-01 logo (13.50 KB, image/png)
2013-11-02 08:08 UTC, tommy27
Details
original -> enlarged (10.43 KB, image/png)
2013-11-03 14:10 UTC, Samuel
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Samuel 2013-07-27 14:40:07 UTC
Created attachment 83090 [details]
Screenshot

Do not know why, on some debian wheezy desktops the LibreOffice Logo is not sharp.
My display resolution is 1680x1050
Comment 1 tommy27 2013-08-11 17:22:11 UTC
looks fine on Windows 7 64bit.
probabbly a Linux specific bug.
Comment 2 Samuel 2013-08-12 13:01:45 UTC
I have some desktop with a different resolution than 1680x1050 and the libreoffice logo is ok.
Comment 3 tommy27 2013-08-20 14:15:39 UTC
did you try changing resolution settings in those 2 computers? 
does it change things or not?
Comment 4 Samuel 2013-08-28 09:33:28 UTC
Created attachment 84780 [details]
1440x900
Comment 5 Samuel 2013-08-28 09:33:53 UTC
Created attachment 84781 [details]
1920x1080
Comment 6 tommy27 2013-08-28 12:00:02 UTC
the question is: 
in the computer where the logo is OK, is it still OK at any resolution setting?

viceversa:
in the computer where the logo is not smooth, is it still bad at any resolution setting?
Comment 7 Maxim Monastirsky 2013-09-19 18:43:51 UTC
*** Bug 69580 has been marked as a duplicate of this bug. ***
Comment 8 tommy27 2013-09-21 18:03:38 UTC
(In reply to comment #1)
> looks fine on Windows 7 64bit.
> probabbly a Linux specific bug.

that was true with 4.1.0.4 under Win7 64bit. logo looked normal.
now using 4.1.1.2 on the same machine I see the same ugly logo reported by Samuel under Debian

changing status to NEW and platform to ALL

as additional informations I'm using a laptop with 1200x800 resolution and an external secondary monitor with 1400x1050 resolution. "about" logo is awful in both monitors.

same issue with 4.2.0.0 master build Sept.10
Comment 9 tommy27 2013-09-21 19:00:40 UTC
@samuel
please do not revert status from NEW to NEEDINFO

NEW means the bug has been confirmed.
NEEDINFO means the bug is not yet confirmed and additional informations about reproducibility are needed.

so the correct status is now NEW
Comment 10 tommy27 2013-10-05 16:35:00 UTC
logo still ugly in 4.1.2.3 under Win7 64bit.

I add Astron to CC-list, maybe he can help.
Comment 11 bordfeldt 2013-10-06 09:52:58 UTC
the same in 4.1.2.3 under Linux (Ubuntu 12.04 64bit)
Comment 12 Samuel 2013-11-01 14:55:18 UTC
Created attachment 88480 [details]
LibreOffice 4.1.3.2

KDE4 Debian 7.2
Comment 13 tommy27 2013-11-01 17:39:57 UTC
this issue seems minor since it doesn't affect productivity and is just a matter of aesthetics... however I feel that this ugly about logo could be used against the LibO project to discredit the quality of the project.

I know that you should not judge a book by it's cover, but I think action must be taken before someone uses this to accuse LibO of being a buggy software...

I mean, somebody could argue that "LibO comes out with a scrambled about box, would you dare compose your documents with such a software?"

so I'm thinking if we should give this bug a MAB status.

CCing Joel about this.
Comment 14 Stefan Knorr (astron) 2013-11-01 20:19:29 UTC
Confirming for LibO 4.1 (openSUSE 12.3/x86-64 build).
Can't (!) confirm on my own few-weeks-old 4.2-master build (again, Linux x86-64).

This logo is an SVG, so any corruption in this logo may also occur with other SVG images. On openSUSE, the file is installed under:
  /usr/share/libreoffice/program/flat-logo.svg (may be elsewhere on other OS's),
in the LibO core repo, it is in:
  $REPO/icon-themes/galaxy/brand/flat-logo.svg


Given that the triangles in the background (another SVG) are not pixelated, the bug may just have to do with how the SVG is embedded into the window in this particular place..?
Comment 15 tommy27 2013-11-02 08:08:54 UTC
Created attachment 88527 [details]
LibO 4.2 alpha 2013-11-01 logo

logo still abnormal under Win7 64bit using yesterday night daily build.
see my screenshot.
Comment 16 Samuel 2013-11-03 14:10:20 UTC
(In reply to comment #13)
> I know that you should not judge a book by it's cover, but I think action
> must be taken before someone uses this to accuse LibO of being a buggy
> software...
> 
> I mean, somebody could argue that "LibO comes out with a scrambled about
> box, would you dare compose your documents with such a software?"

That's what I think too!

486x80 -> original /opt/libreoffice4.1/program/flat_logo.svg

665x109 -> cut out on a screenshot, looks as if it has been enlarged, maybe thats the problem?
Comment 17 Samuel 2013-11-03 14:10:55 UTC
Created attachment 88560 [details]
original -> enlarged
Comment 18 tommy27 2013-11-07 06:52:23 UTC
added to mab4.1 list.

as an additional information I see that after resetting the user profile in Win7 64bit the logo look fine.

there is probably something causing conflicts (maybe extensions?)

is there any other user that can confirm issue disappear after resetting the user profile?
Comment 19 Michael Meeks 2013-11-07 11:11:14 UTC
Andras - a duplicate of my complaint for our internal builds ;-) I wonder guys - do you change your default font size at all. My first suspicion would be that there is some TWIPS magic in here that is affected by some font size change =) any fiddling with that / re-testing appreciated. IIRC that is an svg file in there so ... it should scale beautifully.
Comment 20 Samuel 2013-11-07 11:20:54 UTC
That's it!

Icon size and style 
[Automatic] | [Automatic (Tango)] = logo scale bad
[Automatic] | [Galaxy (default)] = logo scale fine

After delete LibreOffice profile, the logo is scale fine with "Automatic (Tango)".
Comment 21 Andras Timar 2013-11-07 11:49:02 UTC
So, as far as I understand, the bug does not occur with a new profile. At least I could not reproduce it with any scaling/icon style combinations.
Comment 22 Andras Timar 2013-11-07 14:58:25 UTC
Tools - Options - LibreOffice - View - Graphics output - Use Anti-Aliasing

This has to checked for smooth About box logo. I wonder what to do now...
Comment 23 Samuel 2013-11-07 15:06:01 UTC
(In reply to comment #22)
> Tools - Options - LibreOffice - View - Graphics output - Use Anti-Aliasing
Yes, that is the solution, with anti-aliasing any icon size and style work.
Comment 24 tommy27 2013-11-07 20:14:26 UTC
(In reply to comment #23)
> (In reply to comment #22)
> > Tools - Options - LibreOffice - View - Graphics output - Use Anti-Aliasing
> Yes, that is the solution, with anti-aliasing any icon size and style work.

yes, it works now in 4.1.3.2

however logo is smooth in 3.6.7 even if auto-aliasing is off.

all 4.1.x releases and probably all 4.0.x releases (I've tested backwards up to 4.0.4) show ugly logo when auto-aliasing is OFF and nice logo when auto-aliasing is ON

I suspect the regression took place with 4.0.0
Comment 25 Andras Timar 2013-11-07 20:52:27 UTC
(In reply to comment #24)
> I suspect the regression took place with 4.0.0

See bug 59970. The svg image first was converted to a large bitmap, then it was scaled down to the right size. This performed awfully slow, so the current solution was chosen.
Comment 26 tommy27 2013-11-08 05:37:37 UTC
Ok. now I wonder if we can close this report.
the workaround is very easy, just toggle ON the auto-aliasing option and the logo will be nice as expected.

can anybody tell me if the default setting for auto-aliasing in a fresh new installation is ON or OFF?

as said before a new user should not see that ugly logo which could give a bad impression about to LibO, so I recommend auto-aliasing to be ON by default.

the issue will happen only to those users using an old profile where anti-aliasing is OFF.
Comment 27 Michael Meeks 2013-11-08 10:00:33 UTC
> See bug 59970. The svg image first was converted to a large bitmap,
> then it was scaled down to the right size. This performed awfully slow,
> so the current solution was chosen.

I guess we just need some way of forcing AA to 'on' in the drawinglayer programatically for this piece :-)

cui/source/options/optgdlg.cxx:            mpDrawinglayerOpt->SetAntiAliasing(m_pUseAntiAliase->IsChecked());

Is where the global setting is set I guess.

calc has this horrible class:

/**
 * Temporarily turn off antialiasing.
 */
class AntiAliasingSwitch
{
    SvtOptionsDrawinglayer maDrawOpt;
    bool mbOldSetting;

Which we could invert and mirror here [ if that would help ;-]. Having said that the output is sufficiently awfully ugly that IMHO AA is not the whole story - surely ? either way - patches welcome for 4.2 ...
Comment 28 Commit Notification 2013-11-08 21:44:15 UTC
Andras Timar committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=f6449bf0bb93874f189aab9765c1de43dca69807

fdo#67401 set AntiAliasing for SVG logo



The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 29 tommy27 2013-11-09 05:02:16 UTC
(In reply to comment #18)
> added to mab4.1 list.
> 

just for the record I moved this to the mab4.0 list since the issue started with 4.0.x

nice to hear that Andras fixed it.