Bug 67412 - FORMATTING Regression Bullet Points Not Displaying Correctly in MacOSX
Summary: FORMATTING Regression Bullet Points Not Displaying Correctly in MacOSX
Status: RESOLVED DUPLICATE of bug 68192
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
4.1.0.4 release
Hardware: All Mac OS X (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: regression
Depends on:
Blocks:
 
Reported: 2013-07-27 19:58 UTC by junk_2010
Modified: 2013-09-04 15:04 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments
MacOSX10.6_LibreOffice4.1.0.4_Microsoft_doc_bullets_incorrect (122.98 KB, image/png)
2013-07-27 19:59 UTC, junk_2010
Details
MacOSX10.6_LibreOffice4.1.0.4_Microsoft_docx_bullets_incorrect (130.71 KB, image/png)
2013-07-27 20:01 UTC, junk_2010
Details
fixed in latest build from git (250.50 KB, image/png)
2013-08-28 21:17 UTC, Ward van Wanrooij
Details

Note You need to log in before you can comment on or make changes to this bug.
Description junk_2010 2013-07-27 19:58:01 UTC
It looks like there has been a partial regression in LibreOffice 4.1.0.4 when used on MacOSX 10.6.

A previous bug 50284 was closed when all bullet points were displaying correctly when the word doc attachment 60428 [details] and docx attachment 60429 [details] were opened in LibreOffice.
After installing LibreOffice 4.1.0.4 there appears to have been a partial regression in that some of the bullets points are not being displayed correctly.
They should look like attachment 60430 [details] and attachment 60431 [details].

I will attach screenshots of what they look like in LibreOffice 4.1.0.4.

My recollection is that the bullets were displaying correctly when using LibreOffice 4.0.
Comment 1 junk_2010 2013-07-27 19:59:50 UTC
Created attachment 83098 [details]
MacOSX10.6_LibreOffice4.1.0.4_Microsoft_doc_bullets_incorrect

Screenshot of incorrect bullet points in doc document.
Comment 2 junk_2010 2013-07-27 20:01:33 UTC
Created attachment 83099 [details]
MacOSX10.6_LibreOffice4.1.0.4_Microsoft_docx_bullets_incorrect

Screenshot showing incorrect display os bullets points in docx document
Comment 3 junk_2010 2013-07-29 21:44:02 UTC
I have checked the documents using libreOffice 4.1.0.4 on Ubuntu 12.04, installed using the libreOffice ppa, and the documents display as expected.
So it looks like an issue on Max OSX only so far.

I believe 4.1 has changed the way it handles fonts, with the ability to embed fonts in documents. Did that change have this side effect?
Comment 4 Martin Srebotnjak 2013-07-30 09:03:22 UTC
I can confirm on OS X, it looks as a regression, but might also have other causes. The effect is the same.
Comment 5 mrry04 2013-08-05 18:31:57 UTC
I also can confirm the findings of junk_2010@live.co.uk.
An excellent description of the problem. Although the link to att 83098 does not work. Att. 83099 gives an example of exactly the problem I get in an own existing document: only the main bullet is not correct.

In the earlier solved bug 50284 also the other bullets were incorrect. So it is not a 100% exact regression, but probably a man like Caolan McNamara (bug killer of bug 50284) could quickly analyze the problem.

I am not a programmer, but when I read the release notes of v 4.1 (https://wiki.documentfoundation.org/ReleaseNotes/4.1) 
I come across the following line:
Import and export of graphical bullets of numberings in the DOC, DOCX and RTF filters i#120928 (Jian Hong Cheng - Apache: DOC part, Miklos Vajna: DOCX, RTF parts)

Could this 'improvement / extension' be the cause of the new problem?

I hope this is solved quickly because it is a real drawback for every potential new LibreOffice user coming from MS O.

Good luck!

Marcel
Comment 6 Ward van Wanrooij 2013-08-28 21:17:15 UTC
Created attachment 84817 [details]
fixed in latest build from git

This is fixed (at least for me on OS X 10.8.4) using the latest build from git.
Comment 7 mrry04 2013-09-04 11:45:35 UTC
In LO-version 4.1.1.2 for Mac OS X 10.7.5 (up-to-date) this issue is still there.

As stated in the original bugs from which this is a regression: for the 'acceptance' of LO as an alternative for MS Office this is really killing!

A solution for this is far more important than new functionality!!!
(If the basic functionality is not there no one will want to use it).

For the success of LO I hope this get the highest priority.

Good luck.


Marcel
Comment 8 Alex Thurgood 2013-09-04 14:13:26 UTC
Adding Caolan to CC
@Caolan : you fixed bug 50284, want to take a look at this one ?


Alex
Comment 9 Alex Thurgood 2013-09-04 14:14:02 UTC
If only to confirm that the fix is in master and will be backported ;-)

Alex
Comment 10 Alex Thurgood 2013-09-04 14:21:52 UTC
In my build from master (02/09/2013), attachment 60429 [details] displays fine.

OSX : 10.8.4

Version: 4.2.0.0.alpha0+
Build ID: d9b62a48d75e596888fcf10f5f73fed93e7b88a3


Alex
Comment 11 Alex Thurgood 2013-09-04 14:25:09 UTC
Confirming defect in 

Version: 4.1.1.2
Build ID: 7e4286b58adc75a14f6d83f53a03b6c11fa2903

on OSX 10.8.4

Marking as regression
Comment 12 Caolán McNamara 2013-09-04 15:04:50 UTC
This should be good in 4.1.2, two problems, lack of registering the "opensymbol" font and a .docx specific issue with the "symbol" font on MacOSX

*** This bug has been marked as a duplicate of bug 68192 ***