Bug 68192 - Writer incorrectly displays non-numbered list dot.
Summary: Writer incorrectly displays non-numbered list dot.
Status: VERIFIED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
4.1.0.4 release
Hardware: x86-64 (AMD64) Mac OS X (All)
: medium major
Assignee: Caolán McNamara
URL:
Whiteboard: target:4.2.0 target:4.1.2 target:4.0.6
Keywords: regression
: 67412 68560 69896 (view as bug list)
Depends on:
Blocks: mab4.1
  Show dependency treegraph
 
Reported: 2013-08-16 17:35 UTC by UCLAgeek
Modified: 2013-10-11 09:49 UTC (History)
10 users (show)

See Also:
Crash report or crash signature:


Attachments
Screen shots of the error (711.49 KB, application/vnd.oasis.opendocument.text)
2013-08-16 17:35 UTC, UCLAgeek
Details
Example (29.43 KB, application/vnd.openxmlformats-officedocument.wordprocessingml.document)
2013-08-19 05:39 UTC, UCLAgeek
Details
LO 4.1.1.2 Examples of Problem (Bullets and Numbering) (185.92 KB, application/pdf)
2013-10-11 09:48 UTC, Richard
Details

Note You need to log in before you can comment on or make changes to this bug.
Description UCLAgeek 2013-08-16 17:35:41 UTC
Created attachment 84148 [details]
Screen shots of the error

When I open a Docx document in Writer is shows an "unknown" character for the basic list "dot"

Document was created using: MS Word:MAC 2011 version 14.0 (100825)
system info:
OS: OSX 10.8.4
LibreOffice Version: 4.1.0.4
Comment 1 retired 2013-08-17 08:22:44 UTC
Please attach an example coducment to reproduce this problem.
Comment 2 UCLAgeek 2013-08-19 05:38:35 UTC
Attached
Comment 3 UCLAgeek 2013-08-19 05:39:03 UTC
Created attachment 84223 [details]
Example
Comment 4 Thomas van der Meulen 2013-08-23 09:27:57 UTC
Thank you for your bug report, I can reproduce this bug running LibreOffice.
Version: 4.1.1.2
Build ID: 7e4286b58adc75a14f6d83f53a03b6c11fa2903 on Mac osx 10.8.4. 

It was all oké in
Version: 4.1.0.0.beta1
Build ID: 3a2c2d2417101e45fe07cfd8358acf2204a98f3

and started since 
Version: 4.1.0.0.beta2
Build ID: 33224f4f11a05cfad2249e812fcc2975fbb61f6
Comment 5 Michael Stahl (CIB) 2013-08-26 21:34:29 UTC
cannot reproduce the problem on master or 4.1.0.4 on Linux or on master on Windows.  is it perhaps Mac-specific?
Comment 6 Thomas van der Meulen 2013-08-27 06:11:47 UTC
*** Bug 68560 has been marked as a duplicate of this bug. ***
Comment 7 Thomas van der Meulen 2013-08-27 06:11:54 UTC
A user says that is also with Numbering (see screenshot of bug 68560)
Comment 8 Caolán McNamara 2013-08-27 14:28:01 UTC
I think this is mac-specific.

Even if you even just do format->bullet and numbering on a blank new document that there is something screwy right there in the bullet and numbering previews. I think that the OpenSymbol font is not getting found/used at all. Indeed if I manually install the opensymbol .ttf into the system fonts on Mac then the numbering preview window works, but this .docx is still broken so those might be independent bugs.
Comment 9 Commit Notification 2013-08-27 15:52:23 UTC
Caolan McNamara committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=8efbafaf8681d39c8c3674368e02ddd572ba5d32

Related: fdo#68192 register bundled fonts



The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 10 Commit Notification 2013-08-27 16:02:43 UTC
Caolan McNamara committed a patch related to this issue.
It has been pushed to "libreoffice-4-1":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=31fbd9d8b65c7eb9ad618fd68f331a32760c468e&h=libreoffice-4-1

Related: fdo#68192 register bundled fonts


It will be available in LibreOffice 4.1.2.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 11 Commit Notification 2013-08-28 19:35:56 UTC
Caolan McNamara committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=b129867306ce918f4f8fbf9ec5f7dce86e52c9d2

Resolves: fdo#68192 always recode from trad symbol to apple symbol



The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 12 Commit Notification 2013-08-29 07:32:12 UTC
Caolan McNamara committed a patch related to this issue.
It has been pushed to "libreoffice-4-1":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=43288da5bfcaf5f7be8191194e635570ef7426d0&h=libreoffice-4-1

Resolves: fdo#68192 always recode from trad symbol to apple symbol


It will be available in LibreOffice 4.1.2.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 13 Commit Notification 2013-08-29 07:32:31 UTC
Caolan McNamara committed a patch related to this issue.
It has been pushed to "libreoffice-4-0":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=6ae2a7521f5ea34d052e7eb51a63f936d1d06aae&h=libreoffice-4-0

Resolves: fdo#68192 always recode from trad symbol to apple symbol


It will be available in LibreOffice 4.0.6.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 14 Thomas van der Meulen 2013-08-31 10:04:08 UTC
*** Bug 68770 has been marked as a duplicate of this bug. ***
Comment 15 Thomas van der Meulen 2013-08-31 10:04:13 UTC
Verified with Version: 4.2.0.0.alpha0+
Build ID: 1bdc9d4380abccfbb095a76000a75dec8f10defb
Comment 16 Caolán McNamara 2013-09-04 15:04:50 UTC
*** Bug 67412 has been marked as a duplicate of this bug. ***
Comment 17 Matt 2013-10-02 22:25:46 UTC
*** Bug 69896 has been marked as a duplicate of this bug. ***
Comment 18 Richard 2013-10-11 09:48:29 UTC
Created attachment 87445 [details]
LO 4.1.1.2 Examples of Problem (Bullets and Numbering)
Comment 19 Richard 2013-10-11 09:49:28 UTC
the problem persists in LO 4.1.1.2 (OSX 10.8.5).
Am too tech.naive to be able to handle the provided patches. 
thanks for your advice and efforts in advance.