Bug Hunting Session
Bug 67495 - Experimental Sidebar enabled: Grid on/off function in calc does not work properly
Summary: Experimental Sidebar enabled: Grid on/off function in calc does not work prop...
Status: RESOLVED DUPLICATE of bug 67104
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: UI (show other bugs)
Version:
(earliest affected)
4.1.0.4 release
Hardware: Other All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2013-07-29 18:03 UTC by OfficeUser
Modified: 2015-01-05 13:22 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:


Attachments
screeb shot (153.71 KB, image/png)
2013-07-29 18:03 UTC, OfficeUser
Details
screen shot (153.71 KB, image/png)
2013-07-29 18:05 UTC, OfficeUser
Details

Note You need to log in before you can comment on or make changes to this bug.
Description OfficeUser 2013-07-29 18:03:10 UTC
Created attachment 83223 [details]
screeb shot

With the new sidebar there is a second way beside the button of the (old) toolbar to turn on/off the grid.

The checkbox in the new sidebar and the button in the toolbar don't interact as expected. Clicking the toolbar button or the checbox does not change the state of the other element.
Comment 1 OfficeUser 2013-07-29 18:05:15 UTC
Created attachment 83224 [details]
screen shot
Comment 2 Jorendc 2013-08-02 13:28:28 UTC

*** This bug has been marked as a duplicate of bug 67104 ***
Comment 3 OfficeUser 2013-08-04 18:58:23 UTC
The situation is that while the grid is turned off on the sidebar, it cannot be turned on in the toolbar.
Comment 4 OfficeUser 2013-08-26 08:25:45 UTC
REOPENED because not really a duplicate of Bug 67104. Bug 67104 is only about the default value.

This bug describes bad behaviour of the checkbox:

"The situation is that while the grid is turned off on the sidebar, it cannot be turned on in the toolbar."
Comment 5 Julien Nabet 2013-10-29 23:06:53 UTC
With 4.1 sources update some days ago, here's what I got:
- When I open Calc, the checkbox isn't checked whereas the grid is present -> KO
- then when I check checkbox, nothing happens -> OK
- then when I uncheck checkbox, the grid disappears -> OK
- then when I check again checkbox, the grid appears -> OK

Could you give a try to 4.1.2 or with pre release 4.1.3?
Comment 6 Owen Genat (retired) 2013-11-13 10:33:51 UTC
IMO this bug is a duplicate of bug #67104 as indicated by Joren in comment #2 - if not in terms of current description then certainly in terms of spirit. Basically the option is currently broken, both in terms of the initial setting and toggling behaviour. Under Crunchbang 11 linux running v4.1.3.2 it is the OFF states that override. 

My experience here confirms what is stated by Julien in comment #5. By default, when opening Calc the toolbar button is turned ON and the Sidebar checkbox is turned OFF, which is wrong. If the toolbar button is turned OFF subsequent clicking of the Sidebar option has no effect. With both turned ON, further toggling (OFF/ON) of either option has the desired effect (assuming each toggle returns the switch to an ON state). Turning the Sidebar checkbox OFF while the toolbar button is ON, hides the grid. Now, subsequent clicking of the toolbar button has no effect.
Comment 7 Maxim Monastirsky 2014-03-05 13:09:32 UTC
Should be fixed now.

*** This bug has been marked as a duplicate of bug 67104 ***