Download it now!
Bug 67104 - UI - Default value of "Show cell grid lines" checkbox on sidebar
Summary: UI - Default value of "Show cell grid lines" checkbox on sidebar
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
4.1.0.1 rc
Hardware: All All
: highest normal
Assignee: Maxim Monastirsky
URL:
Whiteboard: target:4.3.0 target:4.2.3
Keywords:
: 67495 68429 (view as bug list)
Depends on:
Blocks: Sidebar-Properties mab4.1
  Show dependency treegraph
 
Reported: 2013-07-19 21:09 UTC by lxlalexlxl
Modified: 2016-10-24 13:51 UTC (History)
6 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description lxlalexlxl 2013-07-19 21:09:36 UTC
After LibreOffice Calc start cell grid is visible, but on side bar on "Cell Appearance" tab "Show cell grid lines" checkbox is unchecked. First click on this checkbox changes it's state to checked and have no other effect. Next clicks changes checkbox state and view of table. Default state of "Show cell grid lines" checkbox must be checked.
Comment 1 Jorendc 2013-08-02 11:23:02 UTC
Thanks for reporting!

I can confirm this behavior, tested using Windows 8 with LibreOffice Version: 4.2.0.0.alpha0+ Build ID: 2f6cbe13e61c44d4bab8192a4708b698d3d9da33
TinderBox: Win-x86@6-debug, Branch:master, Time: 2013-07-25_00:00:21

Kind regards,
Joren
Comment 2 Jorendc 2013-08-02 12:30:57 UTC
Also reproducible using Linux Mint 15 x64
Comment 3 Jorendc 2013-08-02 12:37:57 UTC
Adding involved conversion expert developers :).

Kind regards,
Joren
Comment 4 Jorendc 2013-08-02 13:28:28 UTC
*** Bug 67495 has been marked as a duplicate of this bug. ***
Comment 5 OfficeUser 2013-08-02 20:17:54 UTC
The problem is more serious than described here.

Once the grid has been disabled in the sidebar, it can never be turned on via the toolbar. Toolbar and sidebare state are never synchronous for grid on/off.

See also bug 67104 which has better description.



Thus changed Importance to medium normal.
Comment 6 Prashant 2013-08-02 20:32:41 UTC
Hi Joren,
Thanks for adding me and Jan to the CC list :-)

I think the non-synchronous part should be reported as a separate bug-report. As far as this default-check is concerned, I've submitted a patch: https://gerrit.libreoffice.org/#/c/5260 and hopefully this issue is solved.

Thanks and Regards,
Prashant
Comment 7 OfficeUser 2013-08-04 18:57:44 UTC
The situation is that while the grid is turned off on the sidebar, it cannot be turned on in the toolbar.
Comment 8 OfficeUser 2013-08-04 18:59:05 UTC
You may reopen Bug 67495 and consider it as seperate bug report.
Comment 9 Stephan van den Akker 2013-08-25 10:00:59 UTC
*** Bug 68429 has been marked as a duplicate of this bug. ***
Comment 10 Julien Nabet 2013-10-29 23:07:57 UTC
Just for the record, I can reproduce this with master sources updated today.
Comment 11 Jean-Baptiste Faure 2014-01-11 09:42:18 UTC
Reproducible in 4.2.0.2 under Ubuntu 13.10 x86-64

Best regards. JBF
Comment 12 Björn Michaelsen 2014-01-17 09:51:46 UTC Comment hidden (obsolete)
Comment 13 Commit Notification 2014-03-05 13:07:44 UTC
Maxim Monastirsky committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=c3403ac888c2e62edaf8befe7982f5f8cc95c16f

fdo#67104 Use correct command for show grid



The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 14 Maxim Monastirsky 2014-03-05 13:09:32 UTC
*** Bug 67495 has been marked as a duplicate of this bug. ***
Comment 15 Commit Notification 2014-03-07 21:39:21 UTC
Maxim Monastirsky committed a patch related to this issue.
It has been pushed to "libreoffice-4-2":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=cb2a2813f8fdcb3c888c203a72370883df178c60&h=libreoffice-4-2

fdo#67104 Use correct command for show grid


It will be available in LibreOffice 4.2.3.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 16 Commit Notification 2014-04-09 08:41:18 UTC
Maxim Monastirsky committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=f4006967e815a6dbe701dac5e83b4dc74e63a708

related: fdo#67104 correct the tooltip



The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.