Bug Hunting Session
Bug 67601 - Assertion opening an Arabic text file
Summary: Assertion opening an Arabic text file
Status: RESOLVED DUPLICATE of bug 95650
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
4.2.0.0.alpha0+ Master
Hardware: Other Windows (All)
: medium major
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
: 67803 79866 84499 85721 88967 (view as bug list)
Depends on:
Blocks: RTL-Arabic
  Show dependency treegraph
 
Reported: 2013-08-01 02:25 UTC by Urmas
Modified: 2017-11-04 08:59 UTC (History)
6 users (show)

See Also:
Crash report or crash signature:


Attachments
Minimal example (166 bytes, text/plain)
2013-08-01 02:33 UTC, Urmas
Details
Test file #2 (8 bytes, text/plain)
2015-02-01 11:23 UTC, vvort
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Urmas 2013-08-01 02:25:58 UTC
File: .../winlayout.cxx
Line: 1342

Expression: mnSubStringMin <= rVisualItem.mnEndCharPos
Comment 1 Urmas 2013-08-01 02:33:33 UTC
Created attachment 83411 [details]
Minimal example
Comment 2 Maxim Monastirsky 2013-08-01 07:57:56 UTC
Confirmed with 4.2.0.0.alpha0+ Build ID: 8b96cfd6caedbad7b3b79e57421a834f18c5c511
TinderBox: Win-x86@6-debug, Branch:master, Time: 2013-07-27_22:47:00

Same happens with several other documents, including:
attachment 82600 [details] from Bug 64232
attachment 76821 [details] from Bug 62559

This assert was added because of bug 47553
Comment 3 Maxim Monastirsky 2013-11-20 12:04:30 UTC
(In reply to comment #2)
> Same happens with several other documents, including:
> attachment 82600 [details] from Bug 64232
> attachment 76821 [details] from Bug 62559
A quick update: Those two test cases are fixed by http://cgit.freedesktop.org/libreoffice/core/commit/?id=7cbf4629eadfe0f3da611ee0430a3ab6f2bd33ff, but only for Win7. WinXP is still affected (see Bug 65124). The attached test case (Minimal example - attachment 83411 [details]) is not affected by this change.
Comment 4 Urmas 2014-06-12 09:09:23 UTC
With Windows 7, that assertion still happens in preview window in Formatting dialogs.
Comment 5 Caolán McNamara 2014-09-30 10:52:45 UTC
*** Bug 84499 has been marked as a duplicate of this bug. ***
Comment 6 Caolán McNamara 2014-09-30 10:54:47 UTC
*** Bug 67803 has been marked as a duplicate of this bug. ***
Comment 7 Caolán McNamara 2014-09-30 10:56:00 UTC
*** Bug 79866 has been marked as a duplicate of this bug. ***
Comment 8 Maxim Monastirsky 2014-11-01 17:43:12 UTC
*** Bug 85721 has been marked as a duplicate of this bug. ***
Comment 9 Buovjaga 2015-02-01 10:56:39 UTC
*** Bug 88967 has been marked as a duplicate of this bug. ***
Comment 10 vvort 2015-02-01 11:23:09 UTC
Created attachment 113019 [details]
Test file #2

This test file (from bug 88967) gives more stable result.
Comment 11 Maxim Monastirsky 2015-11-10 11:20:47 UTC

*** This bug has been marked as a duplicate of bug 95650 ***