Bug 67803 - Runtime Assertion failure on winlayout.cxx line 1802 on language settings
Summary: Runtime Assertion failure on winlayout.cxx line 1802 on language settings
Status: RESOLVED DUPLICATE of bug 67601
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
4.2.0.0.alpha0+ Master
Hardware: Other Windows (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard: Confirmed:4.2.0.0.alpha0+:Windows8 No...
Keywords:
Depends on:
Blocks:
 
Reported: 2013-08-05 20:29 UTC by Jorendc
Modified: 2014-09-30 10:54 UTC (History)
8 users (show)

See Also:
Crash report or crash signature:


Attachments
Failure screenshot (14.15 KB, image/png)
2013-08-05 20:29 UTC, Jorendc
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Jorendc 2013-08-05 20:29:59 UTC
Created attachment 83682 [details]
Failure screenshot

How to reproduce

* Open LibreOffice
* Tools > Options
* Expand Language Settings
* -> Languages

Behavior: window will pop up with an assertion failure


---------------------------------
Assertion failed!

Program: ...
File: C:/cygwin/home/tinderbox/master-bui.../winlayout.cxx
line: 1802

Expression: -1 != nCharPos

For information on how you program can cause an assertion failure, see the Visual C++ documentation on asserts

(Press Retry to debug the application - JIT must be enabled)
---------------------------------

Tested using Windows 8, Version: 4.2.0.0.alpha0+
Build ID: 087a610fcd5c0c354a9ed6bfccd3451b667d62a3
TinderBox: Win-x86@6-debug, Branch:master, Time: 2013-08-04_21:41:24

Joel also tested with a build from 2013-07-11, NOT reproducible.
So bug introduced between 2013-07-11 and 2013-08-04

Kind regards,
Joren
Comment 1 Jorendc 2013-08-05 20:30:35 UTC
Might be related to bug 67801
Comment 2 Jorendc 2013-08-05 20:42:10 UTC
More info: Clicking on "Retry" result in a crash
Comment 3 Joel Madero 2013-08-05 20:44:31 UTC
Another blocker that I thought needed some people involved to make sure it's taken care of.

Sorry for the noise if you're uninterested
Comment 4 Michael Meeks 2013-08-06 09:55:16 UTC
Could it be a dialog conversion snafu ? :-)
Comment 5 Caolán McNamara 2013-08-06 13:12:01 UTC
That's an assert that mstahl put in back last year with cec68bceba9aa1e984d74897fcd7bf4db702d14b so when you say that it works on "2013-07-11" and fails on "2013-08-04" then both versions are dbgutil versions right ? Not one version dbgutil and one not ?

Can't see how it might be related to a document conversion, and I'd ideally like that not to become the default "goto answer". It might be of course, but would need some evidence.
Comment 6 Joel Madero 2013-08-06 16:07:38 UTC
Forgot about that - yes my older install was a non dbutil install.
Comment 7 Maxim Monastirsky 2013-08-06 17:05:10 UTC
Just for the record: bug 67601 contains the second assert from that commit.
Comment 8 Caolán McNamara 2013-08-08 14:51:44 UTC
I'd be interested to know if 022da4ea298d5d5c134c374546d963926dae2b37 made any difference, i.e. does this assert persist in a windows dbgutil daily after >= 08.08.2013
Comment 9 Jorendc 2013-08-08 15:04:48 UTC
(In reply to comment #8)
> I'd be interested to know if 022da4ea298d5d5c134c374546d963926dae2b37 made
> any difference, i.e. does this assert persist in a windows dbgutil daily
> after >= 08.08.2013

:( still reproducible using Windows 8 with LibreOffice Version: 4.2.0.0.alpha0+
Build ID: 07112a712245bdcca40bb87e2bd118eec9635848
TinderBox: Win-x86@6-debug, Branch:master, Time: 2013-08-08_01:00:04

Thanks for looking at this Caolan!
Comment 10 Thomas Arnhold 2013-09-07 11:18:20 UTC
NOT reproducible with Windows 7 and German locale and empty profile:

Version: 4.2.0.0.alpha0+
Build ID: a8865e5df62b5f33aa769d459b9823eb5b110d4b
TinderBox: Win-x86@6-debug, Branch:master, Time: 2013-09-03_14:36:22

Maybe Windows 8 specific?! Joel, which Windows are you using?
Comment 11 Caolán McNamara 2013-10-11 18:49:30 UTC
caolanm->mstahl: IIRC you added this assert. Any ideas around it ?
Comment 12 Michael Stahl (CIB) 2013-10-11 20:05:33 UTC
iirc mpGlyphs2Chars is not supposed to contain "-1" entries.
but i've forgotten everything else about that.
Comment 13 Robinson Tryon (qubit) 2013-11-24 05:36:02 UTC
Add repro info to whiteboard.
Comment 14 Jorendc 2014-03-18 17:35:20 UTC
It has been a while, but I can't retest this bug. No master debug build are available.

Due the fact this is a debug-only bug, I remove it from the mab4.2 list. Looks like regular build are not affected.
Comment 15 Julien Nabet 2014-07-29 20:45:28 UTC
Any update with last master daily builds? (all Windows ones are not empty)
Comment 16 Caolán McNamara 2014-09-30 10:54:47 UTC

*** This bug has been marked as a duplicate of bug 67601 ***