Bug Hunting Session
Bug 67801 - SpellCheck completely broken
Summary: SpellCheck completely broken
Status: RESOLVED NOTABUG
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Linguistic (show other bugs)
Version:
(earliest affected)
4.2.0.0.alpha0+ Master
Hardware: Other Windows (All)
: highest blocker
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: mab4.2
  Show dependency treegraph
 
Reported: 2013-08-05 19:55 UTC by Jorendc
Modified: 2013-09-07 11:29 UTC (History)
6 users (show)

See Also:
Crash report or crash signature:


Attachments
Screenshot; no red underline, buggy title and incorrect spellcheck (76.94 KB, image/png)
2013-08-05 19:55 UTC, Jorendc
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Jorendc 2013-08-05 19:55:23 UTC
Created attachment 83679 [details]
Screenshot; no red underline, buggy title and incorrect spellcheck

How to test:

* Open Writer
* Make sure AutoSpellCheck is enabled (see Toolbar)
* Type some random words like "maijfsdqfn, nvqfjghqg"

Behavior: no red line under the 'incorrect' words

* Go to 'Spelling and Grammar' (via toolbar, or F7, or Tools > Spelling and Grammar)

Behavior: you'll receive a message "The spellcheck is complete."

Also notable is the buggy title of the Spelling and Grammar window (see screenshot). $LANGUAGE($LOCATION)

Tested using Windows 8, with Version: 4.2.0.0.alpha0+
Build ID: 087a610fcd5c0c354a9ed6bfccd3451b667d62a3
TinderBox: Win-x86@6-debug, Branch:master, Time: 2013-08-04_21:41:24

Joel already confirmed this bug with a build of 2013-07-11
Comment 1 Joel Madero 2013-08-05 19:57:07 UTC
Indeed - confirmed on W8

CC'ed a couple people that we though would want to be well aware of this one.
Comment 2 Caolán McNamara 2013-08-23 13:55:22 UTC
Is this reproducible for anyone not on windows ?
Comment 3 Maxim Monastirsky 2013-09-01 18:41:21 UTC
(In reply to comment #0)
> Also notable is the buggy title of the Spelling and Grammar window (see
> screenshot). $LANGUAGE($LOCATION)
This one is reproducible with 4.1 too, see Bug 68794.
Comment 4 Caolán McNamara 2013-09-03 14:24:49 UTC
Hmm...

caolan->jorendc: What windows install sets are you using ? e.g. is it this one http://dev-builds.libreoffice.org/daily/master/Win-x86@6-debug/current/ because if so it appears that one simply doesn't have the dictionaries included which would explain that.
Comment 5 Thomas Arnhold 2013-09-07 11:29:03 UTC
Caolan, yes this seems to be the problem, as it's the tinderbox Win-x86@6-debug build. So marking this as NOTABUG. The $LANGUAGE($LOCATION) thing got already fixed.