Bug 67677 - PDF: Export PDF crashes Writer
Summary: PDF: Export PDF crashes Writer
Status: RESOLVED DUPLICATE of bug 67416
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
4.1.0.1 rc
Hardware: Other macOS (All)
: high major
Assignee: Not Assigned
URL:
Whiteboard: BSA
Keywords: regression
Depends on:
Blocks:
 
Reported: 2013-08-02 16:33 UTC by Gerlach
Modified: 2013-08-06 11:03 UTC (History)
0 users

See Also:
Crash report or crash signature:
Regression By:


Attachments
Target image in my document that crashes the PDF Export (840.90 KB, application/vnd.oasis.opendocument.text)
2013-08-02 17:22 UTC, Gerlach
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Gerlach 2013-08-02 16:33:26 UTC
Problem description: 
Hello, I've been maintaining an ODT document for many years (so this could be some legacy trash being dragged in the meta-code)...But recently the export-to-pdf button up top has crashed Writer.

***I have reverted the attached document back to 4.0.4.2, but it should happen when the document is opened in the newer release.

Steps to reproduce:
1. ....Open the attached file in LibO 4.1.0.4
2. ....Click the Export to PDF button on th etoolbar
3. ....

Current behavior:
It should crash when the progress meter is near 20-30%. It may be image related, and it usually hesitates at each image point in the document.

Expected behavior:
PDF generated.

              
Operating System: Mac OS X
Version: 4.1.0.4 release
Last worked in: 4.0.4.2 release
Comment 1 Gerlach 2013-08-02 16:38:28 UTC
Attachment is too large, so we may have to figure out a Plan B.
Comment 2 Michael 2013-08-02 16:54:40 UTC
Hi,

can you try and reduce the document size through deleting pages until the bug still occurs with minimal content? This would help to reduce the attachment size and make it easier to try and find the reason for crashing. 
Otherwise you could try and send the document to my email or upload it to a file hoster and send the link.

Thank you for your help.
Comment 3 Gerlach 2013-08-02 17:22:33 UTC
Created attachment 83547 [details]
Target image in my document that crashes the PDF Export
Comment 4 Gerlach 2013-08-02 17:23:39 UTC
(In reply to comment #2)
> Hi,
> 
> can you try and reduce the document size through deleting pages until the
> bug still occurs with minimal content? This would help to reduce the
> attachment size and make it easier to try and find the reason for crashing. 
> Otherwise you could try and send the document to my email or upload it to a
> file hoster and send the link.
> 
> Thank you for your help.


Done. I started to do that, but then I kept paring it down out of curiosity to get it as lean as possible. 

This image (attached) has been in my document for over 2 years and spanned many, many versions past.
Comment 5 Michael 2013-08-02 21:03:20 UTC
Hi,

I can confirm with 4.1.0.4 and 4.1.0.1 on OSX 10.8.4. pdf export works with 4.0.4.2. It also works with 4.1.0.4 on Ubuntu linux.

Looks similar to https://bugs.freedesktop.org/show_bug.cgi?id=67416 but not sure if it really has the same cause, so setting status to new.

Thanks for reporting.
Comment 6 Gerlach 2013-08-05 15:13:56 UTC
I swapped out the jpg with a differently-sourced version, and all is 
well. So I'd say that it implies corrupt jpg content (either metadata or 
visual). LibreOffice appears to function well, though it would be nice 
to have it scan for valid jpg content and warn, if that was the issue.

- gerlach



On 8/2/2013 5:03 PM, bugzilla-daemon@freedesktop.org wrote:
> Michael <mailto:michael@m06.org> changed bug 67677 
> <https://bugs.freedesktop.org/show_bug.cgi?id=67677>
> What 	Removed 	Added
> Status 	UNCONFIRMED 	NEW
> Severity 	normal 	major
> Priority 	medium 	high
> Version 	4.1.0.4 release 	4.1.0.1 rc
> Ever confirmed 		1
>
> *Comment # 5 <https://bugs.freedesktop.org/show_bug.cgi?id=67677#c5> 
> on bug 67677 <https://bugs.freedesktop.org/show_bug.cgi?id=67677> from 
> Michael <mailto:michael@m06.org> *
> Hi,
>
> I can confirm with 4.1.0.4 and 4.1.0.1 on OSX 10.8.4. pdf export works with
> 4.0.4.2. It also works with 4.1.0.4 on Ubuntu linux.
>
> Looks similar tohttps://bugs.freedesktop.org/show_bug.cgi?id=67416  <show_bug.cgi?id=67416>  but not
> sure if it really has the same cause, so setting status to new.
>
> Thanks for reporting.
> ------------------------------------------------------------------------
> You are receiving this mail because:
>
>   * You reported the bug.
>
Comment 7 Don't use this account, use tml@iki.fi 2013-08-06 11:03:44 UTC
Same root cause as bug #67416, fixed by commit a321be22907c47e2e378c494f0de9f3f68af5167 .

*** This bug has been marked as a duplicate of bug 67416 ***