Bug Hunting Session
Bug 67416 - PDF: Crash while exporting to PDF with specific SVG image
Summary: PDF: Crash while exporting to PDF with specific SVG image
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: graphics stack (show other bugs)
Version:
(earliest affected)
4.1.0.4 release
Hardware: x86-64 (AMD64) Mac OS X (All)
: high major
Assignee: Don't use this account, use tml@iki.fi
URL:
Whiteboard:
Keywords:
: 67677 (view as bug list)
Depends on:
Blocks:
 
Reported: 2013-07-27 21:29 UTC by deepjungle.maca
Modified: 2013-08-27 05:31 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments
PDF export crash test file (91.75 KB, application/vnd.oasis.opendocument.text)
2013-07-27 21:29 UTC, deepjungle.maca
Details

Note You need to log in before you can comment on or make changes to this bug.
Description deepjungle.maca 2013-07-27 21:29:06 UTC
Created attachment 83104 [details]
PDF export crash test file
Comment 1 deepjungle.maca 2013-07-27 21:49:21 UTC
No problem with exporting under AOO 4.0
Comment 2 deepjungle.maca 2013-08-01 18:13:24 UTC
The same problem with LO 4.2.0.0+ Build: 02fb63f8f29085213659b730456dbf0438c2f7cc on Mac OS X 10.8.4
Comment 3 Michael 2013-08-02 18:19:55 UTC
Hi,

I can confirm it with 4.1.0.4 on OSX 10.8.4. Earliest version with the crash seems to be 4.1.0.1 and pdf exports works with 4.0.4.2
Works as well with 4.1.0.4 in Ubuntu 

Changed status to NEW. Thanks for reporting this bug.
Comment 4 Don't use this account, use tml@iki.fi 2013-08-06 10:24:42 UTC
Is fixed by this commit in master although I accidentally referred another PDF export bug report in the commit message. (I haven't yet verified whether that bug, too, is fixed by the commit.)

commit a321be22907c47e2e378c494f0de9f3f68af5167
Author: Tor Lillqvist <tml@iki.fi>
Date:   Tue Aug 6 11:55:14 2013 +0300

    fdo#67660: Fix memory mismanagement crash
    
    The CTLayout constructor called CFRetain() on the associated
    CTTextStyle's attribute directory (a CFMutableDictionaryRef) and the
    destructor then called CFRelease() on it, even if there was no
    guarantee it was still the same CTTextStyle. And in the scenario that
    caused this crash, AquaSalGraphics::SetFont() had in fact deleted the
    original CTTextStyle and created a new one.
    
    It seems to me that these CFRetain() and CFRelease() calls are not
    necessary.
Comment 5 Don't use this account, use tml@iki.fi 2013-08-06 11:03:44 UTC
*** Bug 67677 has been marked as a duplicate of this bug. ***
Comment 6 Don't use this account, use tml@iki.fi 2013-08-06 11:08:20 UTC
*** Bug 67660 has been marked as a duplicate of this bug. ***
Comment 7 deepjungle.maca 2013-08-24 22:55:16 UTC
Thanks for fix. It's okay in LO 4.2. But it still exists in 4.1.1.2. Can this fix be backported to 4.1, please?
Comment 8 Tor Lillqvist 2013-08-25 18:45:21 UTC
@deepjungle: It has been. (There was no automatic comment added to this bug report because, as I said in comment #4, I accidentally used a different bug number in the commit message.) See bug#67660 .
Comment 9 deepjungle.maca 2013-08-26 22:56:07 UTC
Unfortunately, it stills crashes in LO 4.1.1.2 (Build: 7e4286b58adc75a14f6d83f53a03b6c11fa2903) but not in latest LO 4.2.0.0+ builds. In my latest tested case the build is e926621fb00f31471b0037d7955b6a3d7f908dc0

So this bug is being connected with a different problem than it was fixed in bug#67660 .
Comment 10 Tor Lillqvist 2013-08-27 05:31:24 UTC
It isn't fixed in 4.1.1. It will be fixed in 4.1.2. I told you to see bug #67660. There it says clearly "It will be available in LibreOffice 4.1.2"